Migrate data from a PolarDB for MySQL cluster to a PolarDB-X 1.0 instance
This topic describes how to use Data Transmission Service (DTS) to migrate the data of aPolarDB for MySQLcluster to aPolarDB-X 1.0.
Prerequisites
The storage capacity of the destination instance is larger than the used storage of the sourcePolarDB for MySQLcluster. The destinationPolarDB-X 1.0instance. For more information, seeCreate an instance.
NoteWhen you create the instance, select RDS MySQL as the storage type.
Databases and tables for receiving data are created in the destinationPolarDB-X 1.0instance. For more information, seeCreate a database and Basic SQL operations.
Precautions
Type | Description |
Source database limits |
|
Other limits |
|
Billing
Migration type | Task configuration fee | Internet traffic fee |
Full data migration | Free of charge. | Free of charge in this example. |
Incremental data migration | Fees apply. For more information, seeBilling overview. |
SQL statements that support incremental migration
Operation type | SQL statements |
DML | INSERT, UPDATE, and DELETE |
Permissions required for database accounts
Database | Full data migration | Incremental data migration |
sourcePolarDB for MySQL | SELECT permission | Read and write permissions |
destinationPolarDB-X 1.0 | Read and write permissions | |
For more information about how to create and authorize database accounts:
PolarDB for MySQLcluster, seeCreate and manage database accounts and Manage database account passwords.
PolarDB-X 1.0instance, seeManage database accounts.
Procedure
-
Navigate to the migration task list page for the destination region using one of the following methods.
From the DTS console
-
Log on to the Data Transmission Service (DTS) console.
-
In the navigation pane on the left, click Data Migration.
-
In the upper-left corner of the page, select the region where the migration instance is located.
From the DMS console
NoteThe actual operations may vary based on the mode and layout of the DMS console. For more information, see Simple mode console and Customize the layout and style of the DMS console.
-
Log on to the Data Management (DMS) console.
-
In the top menu bar, choose .
-
To the right of Data Migration Tasks, select the region where the migration instance is located.
-
-
Click Create Task to navigate to the task configuration page.
Configure the source and destination databases.
Category
Setting
Description
None
Task Name
DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.
Source Database
Select Existing Connection
You can choose whether to use an existing database instance based on your business requirements.
If you use an existing instance, the database information below is automatically filled in. You do not need to enter it again.
If you do not use an existing instance, you must configure the database information below.
NoteYou can log on to theDatabase Connectionspage or the new configuration page to add the database to DTS. For more information, seeManage database connections.
For the DMS console, the configuration item isSelect a DMS database instance.. You can clickAdd DMS Database Instanceor add the database to DMS from the console homepage. For more information, seeRegister a cloud database instance and Add a third-party or self-managed database.
Database Type
SelectPolarDB for MySQL.
Access Method
SelectAlibaba Cloud Instance.
Instance Region
Select the sourcePolarDB for MySQLregion.
Replicate Data Across Alibaba Cloud Accounts
In this example, a database instance under the current Alibaba Cloud account is used. Select No.
PolarDB Cluster ID
Select the sourcePolarDB for MySQLcluster.
Database Account
Enter the database account of the sourcePolarDB for MySQLcluster. For more information about the permission requirements, seePermissions required for database accounts.
Database Password
Enter the password for the database account.
Encryption
Select a value based on the actual situation. For more information about SSL encryption, seeConfigure SSL encryption.
Destination Database
Select Existing Connection
You can choose whether to use an existing database instance based on your business requirements.
If you use an existing instance, the database information below is automatically filled in. You do not need to enter it again.
If you do not use an existing instance, you must configure the database information below.
NoteYou can log on to theDatabase Connectionspage or the new configuration page to add the database to DTS. For more information, seeManage database connections.
For the DMS console, the configuration item isSelect a DMS database instance.. You can clickAdd DMS Database Instanceor add the database to DMS from the console homepage. For more information, seeRegister a cloud database instance and Add a third-party or self-managed database.
Database Type
SelectPolarDB-X 1.0.
Access Method
SelectAlibaba Cloud Instance.
Instance Region
Select the destinationPolarDB-X 1.0region.
Instance ID
Select the destinationPolarDB-X 1.0instance.
Database Account
Enter the database account of the destinationPolarDB-X 1.0instance. For more information about the permission requirements, seePermissions required for database accounts.
Database Password
Enter the password for the database account.
-
After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page.
NoteEnsure that the DTS service IP address segments are automatically or manually added to the security settings of the source and destination databases to allow access from DTS servers. For more information, see Add DTS server IP addresses to a whitelist.
Configure the task objects.
On the Configure Objects page, configure the objects that you want to migrate.
Setting
Description
Migration Types
-
If you only need to perform a full migration, select Full Data Migration.
-
To perform a migration with no downtime, select both Full Data Migration and Incremental Data Migration.
NoteIf you do not select Incremental Data Migration, do not write new data to the source instance during data migration to ensure data consistency.
Processing Mode of Conflicting Tables
-
Precheck and Report Errors: Checks whether tables with the same names exist in the destination database. If no tables with the same names exist, the precheck is passed. If tables with the same names exist, an error is reported during the precheck, and the data migration task does not start.
NoteIf a table in the destination database has the same name but cannot be easily deleted or renamed, you can change the name of the table in the destination database. For more information, see Object name mapping.
-
Ignore Errors and Proceed: Skips the check for tables with the same names.
WarningSelecting Ignore Errors and Proceed may cause data inconsistency and business risks. For example:
-
If the table schemas are consistent and a record in the destination database has the same primary key value as a record in the source database:
-
During full migration, DTS keeps the record in the destination database. The record from the source database is not migrated.
-
During incremental migration, DTS does not keep the record in the destination database. The record from the source database overwrites the record in the destination database.
-
-
If the table schemas are inconsistent, only some columns of data may be migrated, or the migration may fail. Proceed with caution.
-
Capitalization of Object Names in Destination Instance
You can configure the case sensitivity policy for the names of migrated objects, such as databases, tables, and columns, in the destination instance. By default, DTS default policy is selected. You can also choose to keep the case sensitivity consistent with the default policy of the source or destination database. For more information, see Case sensitivity of object names in the destination database.
Source Objects
In the Source Objects box, click the objects to migrate, and then click
to move them to the Selected Objects box.NoteThe minimum granularity for selecting migration objects is table.
Selected Objects
-
To change the name of a single migration object in the target instance, right-click the object in the Selected Objects box. For more information, see Map individual schema, table, and column names.
-
To change the names of multiple migration objects in the target instance, click Selected Objects in the upper-right corner of the Batch Edit box. For more information, see Map multiple schema, table, and column names.
NoteTo filter data by condition, right-click the table to be migrated inSelected Objectsand set the filter conditions in the dialog box that appears. For more information, seeSet filter conditions.
If you use the object name mapping feature, other objects that depend on this object may fail to be migrated.
-
Click Next: Advanced Settings to configure advanced parameters.
Setting
Description
Dedicated Cluster for Task Scheduling
By default, DTS schedules tasks on a shared cluster. You do not need to select one. If you want more stable tasks, you can purchase a dedicated cluster to run DTS migration tasks.
Retry Time for Failed Connections
After the migration task starts, if the connection to the source or destination database fails, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1440 minutes. We recommend that you set the duration to more than 30 minutes. If DTS reconnects to the source and destination databases within the specified duration, the migration task automatically resumes. Otherwise, the task fails.
Note-
For multiple DTS instances that share the same source or destination, the network retry time is determined by the setting of the last created task.
-
Because you are charged for the task during the connection retry period, we recommend that you customize the retry time based on your business needs, or release the DTS instance as soon as possible after the source and destination database instances are released.
Retry Time for Other Issues
After the migration task starts, if a non-connectivity issue, such as a DDL or DML execution exception, occurs in the source or destination database, DTS reports an error and immediately begins to retry the operation. The default retry duration is 10 minutes. You can customize the retry time to a value from 1 to 1440 minutes. We recommend that you set the duration to more than 10 minutes. If the related operations succeed within the specified retry duration, the migration task automatically resumes. Otherwise, the task fails.
ImportantThe value of Retry Time for Other Issues must be less than the value of Retry Time for Failed Connections.
Enable Throttling for Full Data Migration
During full migration, DTS consumes read and write resources on the source and destination databases, which may increase the database load. If required, you can enable throttling for the full migration task. You can set Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s) to reduce the load on the destination database.
Note-
This configuration item is available only if you select Full Data Migration for Migration Types.
-
You can also adjust the full migration speed after the migration instance is running.
Enable Throttling for Incremental Data Migration
If required, you can also choose to set speed limits for the incremental migration task. You can set RPS of Incremental Data Migration and Data migration speed for incremental migration (MB/s) to reduce the load on the destination database.
Note-
This configuration item is available only if you select Incremental Data Migration for Migration Types.
-
You can also adjust the incremental migration speed after the migration instance is running.
Environment Tag
You can select environment tags that identify the instance based on your business requirements. You do not need to select a tag in this example.
Whether to delete SQL operations on heartbeat tables of forward and reverse tasks
Choose whether DTS writes heartbeat SQL information to the source database while the instance is running.
Yes: Does not write heartbeat SQL information to the source database. The DTS instance may display latency.
No: Writes heartbeat SQL information to the source database. This may interfere with source database operations like physical backups and cloning.
Configure ETL
Based on your business needs, select whether to configure the ETL feature to process data.
-
Yes: Configures the ETL feature. You must also enter data processing statements in the text box.
-
No: Does not configure the ETL feature.
Monitoring and Alerting
Select whether to set alerts and receive alert notifications based on your business needs.
-
No: Does not set an alert.
-
Yes: Configure alerts by setting an alert threshold and an alert contact. If a migration fails or the latency exceeds the threshold, the system sends an alert notification.
-
-
Save the task and run a precheck.
-
To view the parameters for configuring this instance when you call the API operation, move the pointer over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the bubble that appears.
-
If you do not need to view or have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.
Note-
Before the migration task starts, DTS performs a precheck. The task starts only after it passes the precheck.
-
If the precheck fails, click View Details next to the failed check item, fix the issue based on the prompt, and then run the precheck again.
-
If a warning is reported during the precheck:
-
For check items that cannot be ignored, click View Details next to the failed item, fix the issue based on the prompt, and then run the precheck again.
-
For check items that can be ignored, you can click Confirm Alert Details, Ignore, OK, and Precheck Again to skip the alert item and run the precheck again. If you choose to ignore a warning, it may cause issues such as data inconsistency and pose risks to your business.
-
-
Purchase an instance.
-
When the Success Rate is 100%, click Next: Purchase Instance.
-
On the Purchase page, select the link specification for the data migration instance. For more information, see the following table.
Category
Parameter
Description
New Instance Class
Resource Group Settings
Select the resource group to which the instance belongs. The default value is default resource group. For more information, see What is Resource Management?
Instance Class
DTS provides migration specifications with different performance levels. The link specification affects the migration speed. You can select a specification based on your business scenario. For more information, see Data migration link specifications.
-
After the configuration is complete, read and select Data Transmission Service (Pay-as-you-go) Service Terms.
-
Click Buy and Start. In the OK dialog box that appears, click OK.
You can view the progress of the migration task on the Data Migration Tasks list page.
Note-
If the migration task does not include incremental migration, it stops automatically after the full migration is complete. After the task stops, its Status changes to Completed.
-
If the migration task includes incremental migration, it does not stop automatically. The incremental migration task continues to run. While the incremental migration task is running, the Status of the task is Running.
-
-