Migrate data from a PolarDB for MySQL cluster to a PolarDB-X 1.0 instance

Updated at:

This topic describes how to use Data Transmission Service (DTS) to migrate the data of aPolarDB for MySQLcluster to aPolarDB-X 1.0.

Prerequisites

  • The storage capacity of the destination instance is larger than the used storage of the sourcePolarDB for MySQLcluster. The destinationPolarDB-X 1.0instance. For more information, seeCreate an instance.

    Note

    When you create the instance, select RDS MySQL as the storage type.

  • Databases and tables for receiving data are created in the destinationPolarDB-X 1.0instance. For more information, seeCreate a database and Basic SQL operations.

Precautions

Type

Description

Source database limits

  • The server that hosts the source database must have sufficient outbound bandwidth. Otherwise, the data migration speed is affected.

  • The tables to be migrated must have a primary key or a UNIQUE constraint, and the fields in the key or constraint must be unique. Otherwise, duplicate data may appear in the destination database.

  • If you migrate data at the table level and need to edit the tables, such as mapping column names, a single data migration task can migrate a maximum of 1,000 tables. If you exceed this limit, an error is reported after you submit the task. In this case, split the tables into multiple migration tasks or configure a task to migrate the entire database.

  • If you perform incremental migration:

    • You must enable binary logging and set the loose_polar_log_bin parameter to on. Otherwise, the precheck reports an error and the data migration task cannot start. For more information about how to enable binary logging and modify parameters, see Enable binary logging and Modify parameters.

      Note

      Enabling binary logging for a PolarDB for MySQL cluster consumes storage space and incurs storage fees.

    • The binary logs of the PolarDB for MySQL cluster must be retained for at least 3 days. We recommend a retention period of 7 days. Otherwise, DTS may fail to obtain the binary logs, which can cause the task to fail. In extreme cases, this can lead to data inconsistency or data loss. Issues caused by a binary log retention period shorter than the DTS requirement are not covered by the DTS Service-Level Agreement (SLA).

      Note

      For more information about how to set the retention period for binary logs of a PolarDB for MySQL cluster, see Modify the retention period.

  • Operational limits for the source database:

    • During schema migration and full data migration, do not perform DDL operations that change the database or table schema. Otherwise, the data migration task fails.

      Note

      During full data migration, DTS queries the source database. This creates a metadata lock, which may block DDL operations on the source database.

    • If you perform only full data migration, do not write new data to the source instance. Otherwise, data inconsistency occurs between the source and destination. To maintain real-time data consistency, select schema migration, full data migration, and incremental data migration.

Other limits

  • Migration object requirements:

    • Data of the BIT, VARBIT, GEOMETRY, ARRAY, UUID, TSQUERY, TSVECTOR, and TXID_SNAPSHOT types cannot be migrated.

    • Prefix indexes are not supported. If the source database contains prefix indexes, data migration may fail.

    • DTS does not support the migration of read-only nodes of the source PolarDB for MySQL instance.

    • DTS does not support the migration of OSS external tables from the source PolarDB for MySQL instance.

  • DTS does not support primary/standby switchover scenarios for the database instance during full data migration. In such a scenario, reconfigure the migration task promptly.

  • If your source database uses temporary-table-mode online DDL operations—including multi-table merge scenarios—or adds function-based indexes to unique key columns, data loss or task failure may occur on the destination database.

  • Schema migration is not supported. Before you configure a migration task, create the corresponding databases and tables in the destinationPolarDB-X 1.0instance.

  • Before you migrate data, evaluate the performance of the source and destination databases. We recommend that you migrate data during off-peak hours. Otherwise, the full data initialization process occupies read and write resources of the source and destination databases, which may increase the database load.

  • The full data initialization process concurrently executes INSERT statements, which causes table fragmentation in the destination database. Therefore, the tablespace of the destination instance is larger than that of the source instance after full data initialization is complete.

  • During data migration, do not use tools such as pt-online-schema-change to perform online DDL changes on the source objects. Otherwise, the migration fails.

  • During data migration, if data other than DTS writes to the destination database, data inconsistency between the source and destination databases may occur.

  • If a task fails, DTS support staff will attempt to restore it within eight hours. During restoration, they may restart the task or adjust its parameters.

    Note

    Only DTS task parameters are modified—not database parameters. Parameters that may be adjusted include those listed in Modify instance parameters.

  • If the destination PolarDB-X 1.0 table has auto partitioning enabled (auto_partition=true), each DDL statement executed on the source can contain only one alter_specification. Otherwise, DTS reports an error (TDDL-4998: Multi alter specifications when create GSI not support yet). To execute a DDL statement that contains multiple alter_specification items, split each alter_specification into a separate DDL statement and execute them one by one. For more information, see ALTER TABLE.

Billing

Migration type

Task configuration fee

Internet traffic fee

Full data migration

Free of charge.

Free of charge in this example.

Incremental data migration

Fees apply. For more information, seeBilling overview.

SQL statements that support incremental migration

Operation type

SQL statements

DML

INSERT, UPDATE, and DELETE

Permissions required for database accounts

Database

Full data migration

Incremental data migration

sourcePolarDB for MySQL

SELECT permission

Read and write permissions

destinationPolarDB-X 1.0

Read and write permissions

For more information about how to create and authorize database accounts:

Procedure

  1. Navigate to the migration task list page for the destination region using one of the following methods.

    From the DTS console

    1. Log on to the Data Transmission Service (DTS) console.

    2. In the navigation pane on the left, click Data Migration.

    3. In the upper-left corner of the page, select the region where the migration instance is located.

    From the DMS console

    Note

    The actual operations may vary based on the mode and layout of the DMS console. For more information, see Simple mode console and Customize the layout and style of the DMS console.

    1. Log on to the Data Management (DMS) console.

    2. In the top menu bar, choose Data + AI > Data Transmission (DTS) > Data Migration.

    3. To the right of Data Migration Tasks, select the region where the migration instance is located.

  2. Click Create Task to navigate to the task configuration page.

  3. Configure the source and destination databases.

    Category

    Setting

    Description

    None

    Task Name

    DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.

    Source Database

    Select Existing Connection

    You can choose whether to use an existing database instance based on your business requirements.

    • If you use an existing instance, the database information below is automatically filled in. You do not need to enter it again.

    • If you do not use an existing instance, you must configure the database information below.

    Note

    Database Type

    SelectPolarDB for MySQL.

    Access Method

    SelectAlibaba Cloud Instance.

    Instance Region

    Select the sourcePolarDB for MySQLregion.

    Replicate Data Across Alibaba Cloud Accounts

    In this example, a database instance under the current Alibaba Cloud account is used. Select No.

    PolarDB Cluster ID

    Select the sourcePolarDB for MySQLcluster.

    Database Account

    Enter the database account of the sourcePolarDB for MySQLcluster. For more information about the permission requirements, seePermissions required for database accounts.

    Database Password

    Enter the password for the database account.

    Encryption

    Select a value based on the actual situation. For more information about SSL encryption, seeConfigure SSL encryption.

    Destination Database

    Select Existing Connection

    You can choose whether to use an existing database instance based on your business requirements.

    • If you use an existing instance, the database information below is automatically filled in. You do not need to enter it again.

    • If you do not use an existing instance, you must configure the database information below.

    Note

    Database Type

    SelectPolarDB-X 1.0.

    Access Method

    SelectAlibaba Cloud Instance.

    Instance Region

    Select the destinationPolarDB-X 1.0region.

    Instance ID

    Select the destinationPolarDB-X 1.0instance.

    Database Account

    Enter the database account of the destinationPolarDB-X 1.0instance. For more information about the permission requirements, seePermissions required for database accounts.

    Database Password

    Enter the password for the database account.

  4. After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page.

    Note

    Ensure that the DTS service IP address segments are automatically or manually added to the security settings of the source and destination databases to allow access from DTS servers. For more information, see Add DTS server IP addresses to a whitelist.

  5. Configure the task objects.

    1. On the Configure Objects page, configure the objects that you want to migrate.

      Setting

      Description

      Migration Types

      • If you only need to perform a full migration, select Full Data Migration.

      • To perform a migration with no downtime, select both Full Data Migration and Incremental Data Migration.

      Note

      If you do not select Incremental Data Migration, do not write new data to the source instance during data migration to ensure data consistency.

      Processing Mode of Conflicting Tables

      • Precheck and Report Errors: Checks whether tables with the same names exist in the destination database. If no tables with the same names exist, the precheck is passed. If tables with the same names exist, an error is reported during the precheck, and the data migration task does not start.

        Note

        If a table in the destination database has the same name but cannot be easily deleted or renamed, you can change the name of the table in the destination database. For more information, see Object name mapping.

      • Ignore Errors and Proceed: Skips the check for tables with the same names.

        Warning

        Selecting Ignore Errors and Proceed may cause data inconsistency and business risks. For example:

        • If the table schemas are consistent and a record in the destination database has the same primary key value as a record in the source database:

          • During full migration, DTS keeps the record in the destination database. The record from the source database is not migrated.

          • During incremental migration, DTS does not keep the record in the destination database. The record from the source database overwrites the record in the destination database.

        • If the table schemas are inconsistent, only some columns of data may be migrated, or the migration may fail. Proceed with caution.

      Capitalization of Object Names in Destination Instance

      You can configure the case sensitivity policy for the names of migrated objects, such as databases, tables, and columns, in the destination instance. By default, DTS default policy is selected. You can also choose to keep the case sensitivity consistent with the default policy of the source or destination database. For more information, see Case sensitivity of object names in the destination database.

      Source Objects

      In the Source Objects box, click the objects to migrate, and then click Right arrow to move them to the Selected Objects box.

      Note

      The minimum granularity for selecting migration objects is table.

      Selected Objects

      Note
      • To filter data by condition, right-click the table to be migrated inSelected Objectsand set the filter conditions in the dialog box that appears. For more information, seeSet filter conditions.

      • If you use the object name mapping feature, other objects that depend on this object may fail to be migrated.

    2. Click Next: Advanced Settings to configure advanced parameters.

      Setting

      Description

      Dedicated Cluster for Task Scheduling

      By default, DTS schedules tasks on a shared cluster. You do not need to select one. If you want more stable tasks, you can purchase a dedicated cluster to run DTS migration tasks.

      Retry Time for Failed Connections

      After the migration task starts, if the connection to the source or destination database fails, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1440 minutes. We recommend that you set the duration to more than 30 minutes. If DTS reconnects to the source and destination databases within the specified duration, the migration task automatically resumes. Otherwise, the task fails.

      Note
      • For multiple DTS instances that share the same source or destination, the network retry time is determined by the setting of the last created task.

      • Because you are charged for the task during the connection retry period, we recommend that you customize the retry time based on your business needs, or release the DTS instance as soon as possible after the source and destination database instances are released.

      Retry Time for Other Issues

      After the migration task starts, if a non-connectivity issue, such as a DDL or DML execution exception, occurs in the source or destination database, DTS reports an error and immediately begins to retry the operation. The default retry duration is 10 minutes. You can customize the retry time to a value from 1 to 1440 minutes. We recommend that you set the duration to more than 10 minutes. If the related operations succeed within the specified retry duration, the migration task automatically resumes. Otherwise, the task fails.

      Important

      The value of Retry Time for Other Issues must be less than the value of Retry Time for Failed Connections.

      Enable Throttling for Full Data Migration

      During full migration, DTS consumes read and write resources on the source and destination databases, which may increase the database load. If required, you can enable throttling for the full migration task. You can set Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s) to reduce the load on the destination database.

      Note
      • This configuration item is available only if you select Full Data Migration for Migration Types.

      • You can also adjust the full migration speed after the migration instance is running.

      Enable Throttling for Incremental Data Migration

      If required, you can also choose to set speed limits for the incremental migration task. You can set RPS of Incremental Data Migration and Data migration speed for incremental migration (MB/s) to reduce the load on the destination database.

      Note
      • This configuration item is available only if you select Incremental Data Migration for Migration Types.

      • You can also adjust the incremental migration speed after the migration instance is running.

      Environment Tag

      You can select environment tags that identify the instance based on your business requirements. You do not need to select a tag in this example.

      Whether to delete SQL operations on heartbeat tables of forward and reverse tasks

      Choose whether DTS writes heartbeat SQL information to the source database while the instance is running.

      • Yes: Does not write heartbeat SQL information to the source database. The DTS instance may display latency.

      • No: Writes heartbeat SQL information to the source database. This may interfere with source database operations like physical backups and cloning.

      Configure ETL

      Based on your business needs, select whether to configure the ETL feature to process data.

      • Yes: Configures the ETL feature. You must also enter data processing statements in the text box.

      • No: Does not configure the ETL feature.

      Monitoring and Alerting

      Select whether to set alerts and receive alert notifications based on your business needs.

      • No: Does not set an alert.

      • Yes: Configure alerts by setting an alert threshold and an alert contact. If a migration fails or the latency exceeds the threshold, the system sends an alert notification.

  6. Save the task and run a precheck.

    • To view the parameters for configuring this instance when you call the API operation, move the pointer over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the bubble that appears.

    • If you do not need to view or have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.

    Note
    • Before the migration task starts, DTS performs a precheck. The task starts only after it passes the precheck.

    • If the precheck fails, click View Details next to the failed check item, fix the issue based on the prompt, and then run the precheck again.

    • If a warning is reported during the precheck:

      • For check items that cannot be ignored, click View Details next to the failed item, fix the issue based on the prompt, and then run the precheck again.

      • For check items that can be ignored, you can click Confirm Alert Details, Ignore, OK, and Precheck Again to skip the alert item and run the precheck again. If you choose to ignore a warning, it may cause issues such as data inconsistency and pose risks to your business.

  7. Purchase an instance.

    1. When the Success Rate is 100%, click Next: Purchase Instance.

    2. On the Purchase page, select the link specification for the data migration instance. For more information, see the following table.

      Category

      Parameter

      Description

      New Instance Class

      Resource Group Settings

      Select the resource group to which the instance belongs. The default value is default resource group. For more information, see What is Resource Management?

      Instance Class

      DTS provides migration specifications with different performance levels. The link specification affects the migration speed. You can select a specification based on your business scenario. For more information, see Data migration link specifications.

    3. After the configuration is complete, read and select Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Click Buy and Start. In the OK dialog box that appears, click OK.

      You can view the progress of the migration task on the Data Migration Tasks list page.

      Note
      • If the migration task does not include incremental migration, it stops automatically after the full migration is complete. After the task stops, its Status changes to Completed.

      • If the migration task includes incremental migration, it does not stop automatically. The incremental migration task continues to run. While the incremental migration task is running, the Status of the task is Running.