Migrate from RDS MySQL to a self-managed Oracle database
You can use Data Transmission Service (DTS) to migrate data from an ApsaraDB RDS for MySQL instance to a self-managed Oracle database.
Prerequisites
-
A self-managed Oracle database is created as the migration destination.
NoteThe destination Oracle database must have more available storage space than the data to be migrated from the source ApsaraDB RDS for MySQL instance.
-
For self-managed Oracle databases that use a RAC architecture, a VPC connection to Alibaba Cloud is required. To ensure the DTS task runs correctly, connect the SCAN IP of the Oracle RAC and the VIP of each node to the VPC, and configure the necessary routing rules. For more information, see Overview of solutions for connecting an on-premises data center to Alibaba Cloud and Connect a data center to DTS through VPN Gateway.
Usage notes
During full and incremental data migration:
-
If cascading update or delete operations exist in the source database, data inconsistencies may occur.
-
If foreign keys or triggers exist in the destination database, you must disable them. Otherwise, the data migration task may fail.
|
Type |
Description |
|
Source database limits |
|
|
Other limits |
|
|
Special cases |
|
Billing
|
Migration type |
Instance configuration fee |
Internet traffic fee |
|
Schema migration and full data migration |
Free of charge. |
When the Access Method parameter of the destination database is set to Public IP Address, you are charged for Internet traffic. For more information, see Billing overview. |
|
Incremental data migration |
Charged. For more information, see Billing overview. |
Migration types
-
Schema migration
DTS migrates the schemas of the migration objects from the source database to the destination database.
-
Full data migration
DTS migrates all existing data in the migration objects from the source database to the destination database.
-
Incremental data migration
After full data migration, DTS migrates incremental updates from the source database to the destination database, minimizing downtime for self-managed applications.
SQL operations for incremental migration
|
Operation type |
SQL statement |
|
DML |
INSERT, UPDATE, and DELETE |
|
DDL |
CREATE TABLE, ALTER TABLE, RENAME TABLE, TRUNCATE TABLE, and DROP TABLE |
Required permissions for database accounts
|
Database |
Schema migration |
Full migration |
Incremental migration |
|
ApsaraDB RDS for MySQL |
SELECT permission |
SELECT permission |
REPLICATION SLAVE, REPLICATION CLIENT, and SELECT permissions for the source objects. DTS automatically grants these permissions to the database account. |
|
Oracle |
Schema owner permissions. |
||
For more information about creating and authorizing a database account, see the following topics:
-
For an ApsaraDB RDS for MySQL instance: Create an account and Modify account permissions.
-
For a self-managed Oracle database: CREATE USER and GRANT.
Procedure
This example uses a self-managed Oracle database on an ECS instance as the destination database.
-
Navigate to the migration task list page for the destination region using one of the following methods.
From the DTS console
-
Log on to the Data Transmission Service (DTS) console.
-
In the navigation pane on the left, click Data Migration.
-
In the upper-left corner of the page, select the region where the migration instance is located.
From the DMS console
NoteThe actual operations may vary based on the mode and layout of the DMS console. For more information, see Simple mode console and Customize the layout and style of the DMS console.
-
Log on to the Data Management (DMS) console.
-
In the top menu bar, choose .
-
To the right of Data Migration Tasks, select the region where the migration instance is located.
-
-
Click Create Task to navigate to the task configuration page.
-
Configure the source and destination databases.
Category
Parameter
Description
N/A
Task Name
DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.
Source Database
Select DMS Database Instance
Choose whether to use an existing instance as needed.
If you use an existing instance, the database information is automatically filled in. You do not need to enter it again.
If you do not use an existing instance, enter the database information below.
Database Type
Select MySQL.
Access Method
Select Alibaba Cloud Instance.
Instance Region
Select the region of the source ApsaraDB RDS for MySQL instance.
Cross-account
Specifies whether the source database belongs to a different Alibaba Cloud account. In this example, select No.
RDS Instance ID
Select the ID of the source ApsaraDB RDS for MySQL instance.
Database Account
Enter the database account of the source ApsaraDB RDS for MySQL instance. For more information about the required permissions, see Permissions required for database accounts.
Database Password
Enter the password for the database account.
Connection Method
Select Non-encrypted or SSL-encrypted based on your database requirements. If you set this parameter to SSL-encrypted, you must enable SSL encryption for the RDS for MySQL instance beforehand. For more information, see Quickly enable SSL encryption using a cloud certificate.
Destination Database
Select DMS Database Instance
Choose whether to use an existing instance as needed.
If you use an existing instance, the database information is automatically filled in. You do not need to enter it again.
If you do not use an existing instance, enter the database information below.
Database Type
Select Oracle.
Access Method
Select Self-managed Database on ECS.
NoteIf your destination database is a self-managed database, you must perform preparatory work. For more information, see Preparation overview.
Instance Region
Select the region of the destination self-managed Oracle instance.
ECS Instance ID
Select the ID of the ECS instance hosting the destination self-managed Oracle database.
Port Number
Enter the service port of the destination self-managed Oracle database. Default value: 1521.
Oracle Type
Select the Oracle instance type. In this example, select RAC or PDB Instance.
-
Non-RAC Instance: If you select this option, you must specify the SID.
-
RAC or PDB Instance: If you select this option, you must specify the Service Name.
Database Account
Enter the database account of the destination self-managed Oracle instance.
Database Password
Enter the password for the database account.
-
After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page. In the CIDR Blocks of DTS Servers dialog box that appears, click Test Connectivity.
NoteEnsure that the IP address segments of the DTS service are automatically or manually added to the security settings of the source and destination databases to allow access from DTS servers. For more information, see Add DTS server IP addresses to a whitelist.
-
Configure the task objects.
-
On the Configure Objects page, configure the objects that you want to migrate.
Parameter
Description
Migration Types
-
If you only need to perform a full migration, select both Schema Migration and Full Data Migration.
-
To perform a migration with no downtime, select Schema Migration, Full Data Migration, and Incremental Data Migration.
Note-
If you do not select Schema Migration, you must ensure that a database and tables to receive the data exist in the destination database. You can also use the object name mapping feature in the Selected Objects box as needed.
-
If you do not select Incremental Data Migration, do not write new data to the source instance during data migration to ensure data consistency.
Processing Mode for Existing Destination Tables
-
Precheck and Report Errors: Checks for tables in the destination database with the same names as tables in the source database. The precheck passes if no such tables exist. Otherwise, the precheck fails and the migration task cannot start.
NoteIf you cannot delete or rename the tables with the same names in the destination database, you can change the names of these tables in the destination database. For more information, see Map table and column names.
-
Ignore Errors and Proceed: Skips the check for tables with the same names in the destination database.
WarningIf you select Ignore Errors and Proceed, data inconsistency may occur and expose your business to risks. For example:
-
If a destination record has the same primary key as a source record, and the schemas match:
-
During a full data migration, DTS keeps the destination record and does not migrate the source record.
-
During an incremental data migration, DTS overwrites the destination record with the source record.
-
-
If the source and destination databases have different schemas, data initialization may fail, resulting in partial data migration or a complete migration failure.
-
Case Policy for Destination Object Names
Configure the case-sensitivity of database names, table names, and column names in the destination instance. By default, DTS default policy is selected. You can also select other options to ensure that the case of object names is consistent with that in the source or destination database. For more information, see Case-sensitivity of object names in the destination instance.
Source Objects
In the Source Objects box, click the objects to migrate, and then click
to move them to the Selected Objects box.NoteThe granularity for selecting migration objects is schema, table, and column. If you select only tables or columns as migration objects, other objects such as views, triggers, and stored procedures are not migrated to the destination database.
Selected Objects
Right-click a database in the Selected Objects box. On the Edit Schema page, change the Schema Name to the schema of the destination database in your self-managed Oracle database. By default, the schema name is the same as the Database Account. For more information about the object name mapping feature, see Map table and column names.
Note-
Using object name mapping can cause migrations to fail for dependent objects.
-
To set a
WHEREcondition to filter data, right-click the table to be migrated in the Selected Objects section, and set the filter condition in the dialog box that appears. For more information, see Configure filter conditions. -
To select SQL operations for migration at the database or table level, right-click a migration object in the Selected Objects box and select the required SQL operations in the dialog box.
-
-
Click Next: Advanced Settings to configure advanced parameters.
Parameter
Description
Dedicated Cluster for Task Scheduling
By default, DTS schedules tasks on a shared cluster. You do not need to select one. If you want more stable tasks, you can purchase a dedicated cluster to run DTS migration tasks.
Retry Time for Failed Connections
After the migration task starts, if the connection to the source or destination database fails, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1440 minutes. We recommend that you set the duration to more than 30 minutes. If DTS reconnects to the source and destination databases within the specified duration, the migration task automatically resumes. Otherwise, the task fails.
Note-
For multiple DTS instances that share the same source or destination, the network retry time is determined by the setting of the last created task.
-
Because you are charged for the task during the connection retry period, we recommend that you customize the retry time based on your business needs, or release the DTS instance as soon as possible after the source and destination database instances are released.
Retry Time for Other Issues
After the migration task starts, if a non-connectivity issue, such as a DDL or DML execution exception, occurs in the source or destination database, DTS reports an error and immediately begins to retry the operation. The default retry duration is 10 minutes. You can customize the retry time to a value from 1 to 1440 minutes. We recommend that you set the duration to more than 10 minutes. If the related operations succeed within the specified retry duration, the migration task automatically resumes. Otherwise, the task fails.
ImportantThe value of Retry Time for Other Issues must be less than the value of Retry Time for Failed Connections.
Enable Throttling for Full Data Migration
During full migration, DTS consumes read and write resources on the source and destination databases, which may increase the database load. If required, you can enable throttling for the full migration task. You can set Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s) to reduce the load on the destination database.
Note-
This configuration item is available only if you select Full Data Migration for Migration Types.
-
You can also adjust the full migration speed after the migration instance is running.
Enable Throttling for Incremental Data Migration
If required, you can also choose to set speed limits for the incremental migration task. You can set RPS of Incremental Data Migration and Data migration speed for incremental migration (MB/s) to reduce the load on the destination database.
Note-
This configuration item is available only if you select Incremental Data Migration for Migration Types.
-
You can also adjust the incremental migration speed after the migration instance is running.
Environment Tag
You can select an environment tag to identify the migration instance. In this example, no tag is needed.
Whether to delete SQL operations on heartbeat tables of forward and reverse tasks
Choose whether DTS writes heartbeat SQL information to the source database while the instance is running.
Yes: Does not write heartbeat SQL information to the source database. The DTS instance may display latency.
No: Writes heartbeat SQL information to the source database. This may interfere with source database operations like physical backups and cloning.
Configure ETL
Based on your business needs, select whether to configure the ETL feature to process data.
-
Yes: Configures the ETL feature. You must also enter data processing statements in the text box.
-
No: Does not configure the ETL feature.
Monitoring and Alerting
Select whether to set alerts and receive alert notifications based on your business needs.
-
No: Does not set an alert.
-
Yes: Configure alerts by setting an alert threshold and an alert contact. If a migration fails or the latency exceeds the threshold, the system sends an alert notification.
-
-
Click Next: Data Validation to configure a data validation task.
For more information about the data validation feature, see Configure data validation.
-
-
Save the task and run a precheck.
-
To view the parameters for configuring this instance when you call the API operation, move the pointer over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the bubble that appears.
-
If you do not need to view or have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.
Note-
Before the migration task starts, DTS performs a precheck. The task starts only after it passes the precheck.
-
If the precheck fails, click View Details next to the failed check item, fix the issue based on the prompt, and then run the precheck again.
-
If a warning is reported during the precheck:
-
For check items that cannot be ignored, click View Details next to the failed item, fix the issue based on the prompt, and then run the precheck again.
-
For check items that can be ignored, you can click Confirm Alert Details, Ignore, OK, and Precheck Again to skip the alert item and run the precheck again. If you choose to ignore a warning, it may cause issues such as data inconsistency and pose risks to your business.
-
-
-
Purchase an instance.
-
When the Success Rate is 100%, click Next: Purchase Instance.
-
On the Purchase page, select the link specification for the data migration instance. For more information, see the following table.
Category
Parameter
Description
New Instance Class
Resource Group Settings
Select the resource group to which the instance belongs. The default value is default resource group. For more information, see What is Resource Management?
Instance Class
DTS provides migration specifications with different performance levels. The link specification affects the migration speed. You can select a specification based on your business scenario. For more information, see Data migration link specifications.
-
After the configuration is complete, read and select Data Transmission Service (Pay-as-you-go) Service Terms.
-
Click Buy and Start. In the OK dialog box that appears, click OK.
You can view the progress of the migration task on the Data Migration Tasks list page.
Note-
If the migration task does not include incremental migration, it stops automatically after the full migration is complete. After the task stops, its Status changes to Completed.
-
If the migration task includes incremental migration, it does not stop automatically. The incremental migration task continues to run. While the incremental migration task is running, the Status of the task is Running.
-
-