Migrate self-managed MariaDB to ApsaraDB RDS for MariaDB

Updated at:

You can use Data Transmission Service (DTS) to migrate a self-managed MariaDB database to an ApsaraDB RDS for MariaDB instance. DTS supports schema migration, full data migration, and incremental data migration. By combining these migration types, you can seamlessly migrate your database to the cloud without service interruptions.

Note

To migrate data from a self-managed MariaDB database to an ApsaraDB RDS for MySQL instance, follow the instructions in this topic but use an ApsaraDB RDS for MySQL instance as the destination.

Prerequisites

  • You have created a destination ApsaraDB RDS for MariaDB instance.

  • The storage space of the destination ApsaraDB RDS for MariaDB instance must be greater than the space used by the source self-managed MariaDB database.

Limitations

Note
  • During schema migration, DTS migrates foreign keys from the source database to the destination database.

  • During full and incremental data migration, DTS temporarily disables constraint checks and foreign key cascade operations at the session level. If cascade update or delete operations occur in the source database while the task is running, data inconsistency may occur.

Type

Description

Source database limitations

  • Bandwidth requirements: The server that hosts the source database must have sufficient outbound bandwidth. Otherwise, migration speed is reduced.

  • Each table to be migrated must have a primary key or a unique constraint; otherwise, duplicate data may occur in the destination database.

  • If a data migration task involves editing more than 1,000 tables (for example, mapping table and column names), we recommend splitting them across multiple data migration instances or configuring the task to migrate the entire database.

  • If you perform incremental data migration, the data logs must meet the following requirements:

    • You must enable binary logging (binlog) and set the binlog_row_image parameter to full. Otherwise, an error is reported during the precheck and the data migration task fails to start.

    • Data logs from the source database must be retained for at least seven days. A shorter retention period may cause the task to fail because DTS cannot obtain the required logs, potentially leading to data inconsistency or loss. Such issues are not covered by the DTS Service Level Agreement (SLA).

  • During the schema migration and full migration phases, do not perform DDL operations that change the database or table structure. Otherwise, the data migration task will fail.

    Note

    During the full migration phase, DTS queries the source database. This creates a metadata lock that may block DDL operations on the source database.

  • If you perform only a full data migration, do not write new data to the source database. Otherwise, the data in the source and destination databases will become inconsistent. To maintain data consistency in real time, select both full data migration and incremental data migration.

Other limitations

  • Make sure that no invisible columns exist in the source or destination tables. Otherwise, the data migration instance may fail or data may be lost.

  • A full data migration task consumes read and write resources on the source and destination databases, increasing their load. We recommend evaluating your database performance and running the task during off-peak hours (for example, when CPU utilization is below 30%) to minimize impact.

  • Full data migration involves concurrent INSERT operations, which can cause fragmentation in the tables of the destination database. After full data migration is complete, the table storage space in the destination database is larger than that in the source database.

  • Writing data to the destination database from external sources during migration can cause data inconsistency or task failure. After the migration is complete, you can use DMS to perform online DDL changes.

  • If a DDL write operation fails on the destination database, the DTS task continues to run. You need to check the task logs for the DDL statement that failed.

  • If a task fails, DTS support staff will attempt to restore it within eight hours. During restoration, they may restart the task or adjust its parameters.

    Note

    Only DTS task parameters are modified—not database parameters. Parameters that may be adjusted include those listed in Modify instance parameters.

Special cases

Because the source MariaDB database is self-managed, note the following additional limitations:

  • If a primary/secondary switchover occurs on the source database during migration, the data migration task fails.

  • If no DML operations are performed on the source database for an extended period, the reported latency can become inaccurate. To get an accurate latency reading in this case, perform a DML operation on the source database.

Billing

Migration type

Link configuration fee

Public network traffic fee

Schema migration and full data migration

Free of charge.

Free of charge in this example.

Incremental data migration

Charged. For more information, see Billing overview.

Migration types

  • Schema migration

    Data Transmission Service (DTS) migrates the schema definitions of the migration objects from the source database to the destination database.

    • DTS supports schema migration for tables, views, triggers, stored procedures, and functions.

      Note

      The routine_body of stored procedures, the routine_body of functions, and the select_statement of views are not modified.

    • During schema migration, DTS changes the `DEFINER` to `INVOKER` for the views, stored procedures, and functions to be migrated. This action changes the value of `SQL SECURITY` to `INVOKER`. DTS also sets the `DEFINER` to the destination database account that is used for the migration task.

      Note

      The security authentication method and definer of the source database are not modified.

    • Because DTS does not migrate user information, you must grant read and write permissions to the invoker to call views, stored procedures, and functions in the destination database.

  • Full migration

    DTS migrates all historical data of the specified migration objects from the source database to the destination database.

  • Incremental migration

    After a full migration is complete, DTS migrates incremental data updates from the source database to the destination database. Incremental migration lets you smoothly migrate data without interrupting your self-managed applications.

SQL operations supported by incremental migration

Operation type

SQL statement

DML

INSERT, UPDATE, DELETE

DDL

  • ALTER TABLE, ALTER VIEW

  • CREATE FUNCTION, CREATE INDEX, CREATE PROCEDURE, CREATE TABLE, CREATE VIEW

  • DROP INDEX, DROP TABLE

  • RENAME TABLE

    Important

    A RENAME TABLE operation may cause data inconsistency. For example, if you select only one table as the migration object and rename the table in the source instance during migration, the data of this table is not migrated to the destination database. To prevent this issue, select the entire database to which the table belongs as the migration object when you configure the data migration task. Make sure that the databases to which the table belongs before and after the RENAME TABLE operation are both included in the migration objects.

  • TRUNCATE TABLE

Required permissions for database accounts

Database

Schema migration

Full data migration

Incremental data migration

Self-managed MariaDB database

SELECT permission

SELECT permission

Incremental data migration: SELECT permission on the objects to be migrated

REPLICATION CLIENT, REPLICATION SLAVE, SHOW VIEW

Permissions to create databases and tables. DTS uses these permissions to create a test database for recording heartbeat data.

ApsaraDB RDS for MariaDB instance

Read and write permissions

For instructions on creating accounts and granting permissions:

Procedure

  1. Navigate to the migration task list page for the destination region using one of the following methods.

    From the DTS console

    1. Log on to the Data Transmission Service (DTS) console.

    2. In the navigation pane on the left, click Data Migration.

    3. In the upper-left corner of the page, select the region where the migration instance is located.

    From the DMS console

    Note

    The actual operations may vary based on the mode and layout of the DMS console. For more information, see Simple mode console and Customize the layout and style of the DMS console.

    1. Log on to the Data Management (DMS) console.

    2. In the top menu bar, choose Data + AI > Data Transmission (DTS) > Data Migration.

    3. To the right of Data Migration Tasks, select the region where the migration instance is located.

  2. Click Create Task to navigate to the task configuration page.

  3. Optional: In the upper-right corner of the page, click New Configuration Page.

    Note
    • If you are already on the new configuration page (the button in the upper-right corner is Back to Previous Version), you can skip this step.

    • The parameters on the new and old configuration pages are different. We recommend that you use the new configuration page.

  4. Configure the source and destination databases.

    Warning

    After you select the source and destination instances, we recommend that you carefully read the limits displayed at the top of the page. Otherwise, the task may fail or data inconsistency may occur.

    Category

    Parameter

    Description

    N/A

    Task Name

    DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.

    Source Database

    Select Existing Connection

    • To use a database instance that has been added to the system (created or saved), select the desired database instance from the drop-down list. The database information below will be automatically configured.

      Note

      In the DMS console, this parameter is named Select a DMS database instance..

    • If you have not registered the database instance with the system, or do not need to use a registered instance, manually configure the database information below.

    Database Type

    Select MariaDB.

    Access Method

    Select an access method based on the deployment location of the source database. This topic uses Self-managed Database on ECS as an example.

    Instance Region

    Select the region where the source MariaDB database resides.

    ECS Instance ID

    Select the ID of the ECS instance that hosts the self-managed database.

    Port Number

    Enter the service port of the source MariaDB database. This port must be accessible over the public network. The default value is 3306.

    Database Account

    Enter the account for the source MariaDB database. For information about the required permissions, see Required permissions for database accounts.

    Database Password

    Enter the password for the database account.

    Encryption

    Select Non-encrypted.

    Destination Database

    Select Existing Connection

    • To use a database instance that has been added to the system (created or saved), select the desired database instance from the drop-down list. The database information below will be automatically configured.

      Note

      In the DMS console, this parameter is named Select a DMS database instance..

    • If you have not registered the database instance with the system, or do not need to use a registered instance, manually configure the database information below.

    Database Type

    Select MariaDB.

    Access Method

    Select Alibaba Cloud Instance.

    Instance Region

    Select the region where the destination ApsaraDB RDS for MariaDB instance resides.

    RDS Instance ID

    Select the ID of the destination ApsaraDB RDS for MariaDB instance.

    Database Account

    Enter the database account of the destination RDS instance. For information about the required permissions, see Required permissions for database accounts.

    Database Password

    Enter the password for the database account.

    Connection Method

    Select Non-encrypted.

  5. After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page.

    Note
    • Ensure that the IP address segment of the DTS service is automatically or manually added to the security settings of the source and destination databases to allow access from DTS servers. For more information, see Add DTS server IP addresses to a whitelist.

    • If the source or destination database is a self-managed database (the Access Method is not Alibaba Cloud Instance), you must also click Test Connectivity in the CIDR Blocks of DTS Servers dialog box that appears.

  6. Configure the task objects.

    1. On the Configure Objects page, configure the objects that you want to migrate.

      Parameter

      Description

      Migration Types

      • If you only need to perform a full migration, select both Schema Migration and Full Data Migration.

      • To perform a migration with no downtime, select Schema Migration, Full Data Migration, and Incremental Data Migration.

      Note
      • If you do not select Schema Migration, you must ensure that a database and tables to receive the data exist in the destination database. You can also use the object name mapping feature in the Selected Objects box as needed.

      • If you do not select Incremental Data Migration, do not write new data to the source instance during data migration to ensure data consistency.

      Method to Migrate Triggers in Source Database

      Select a method to migrate triggers based on your business requirements. If no triggers are involved, you can skip this parameter. For more information, see Configure how to synchronize or migrate triggers.

      Note

      This parameter is available only if you select both Schema Migration and Incremental Data Migration for Migration Types.

      Processing Mode for Existing Destination Tables

      • Precheck and Report Errors: Checks whether tables with the same names exist in the destination database. If no tables with the same names exist, the precheck is passed. If tables with the same names exist, an error is reported during the precheck, and the data migration task does not start.

        Note

        If a table in the destination database has the same name but cannot be easily deleted or renamed, you can change the name of the table in the destination database. For more information, see Object name mapping.

      • Ignore Errors and Proceed: Skips the check for tables with the same names.

        Warning

        Selecting Ignore Errors and Proceed may cause data inconsistency and business risks. For example:

        • If the table schemas are consistent and a record in the destination database has the same primary key value as a record in the source database:

          • During full migration, DTS keeps the record in the destination database. The record from the source database is not migrated.

          • During incremental migration, DTS does not keep the record in the destination database. The record from the source database overwrites the record in the destination database.

        • If the table schemas are inconsistent, only some columns of data may be migrated, or the migration may fail. Proceed with caution.

      Capitalization of Object Names in Destination Instance

      You can configure the case sensitivity policy for the names of migrated objects, such as databases, tables, and columns, in the destination instance. By default, DTS default policy is selected. You can also choose to keep the case sensitivity consistent with the default policy of the source or destination database. For more information, see Case sensitivity of object names in the destination database.

      Source Objects

      Select one or more objects from the Source Objects section. Click the Rightwards arrow icon and add the objects to the Selected Objects section.

      Note

      The granularity for selecting migration objects is database, table, and column. If you select only tables or columns as migration objects, other objects such as views, triggers, and stored procedures are not migrated to the destination database.

      Selected Objects

      Note
      • If you use the object name mapping feature, other objects that depend on the mapped object may fail to be migrated.

      • To filter data by using a WHERE condition, right-click the table to be migrated in the Selected Objects box and set the filter condition in the dialog box that appears. For more information, see Configure filter conditions.

      • To select the SQL operations to be migrated at the database or table level, right-click the migration object in the Selected Objects box and select the desired SQL operations in the dialog box that appears.

    2. Click Next: Advanced Settings to configure advanced parameters.

      Parameter

      Description

      Dedicated Cluster for Task Scheduling

      By default, DTS schedules tasks on a shared cluster. You do not need to select one. If you want more stable tasks, you can purchase a dedicated cluster to run DTS migration tasks.

      Retry Time for Failed Connections

      After the migration task starts, if the connection to the source or destination database fails, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1440 minutes. We recommend that you set the duration to more than 30 minutes. If DTS reconnects to the source and destination databases within the specified duration, the migration task automatically resumes. Otherwise, the task fails.

      Note
      • For multiple DTS instances that share the same source or destination, the network retry time is determined by the setting of the last created task.

      • Because you are charged for the task during the connection retry period, we recommend that you customize the retry time based on your business needs, or release the DTS instance as soon as possible after the source and destination database instances are released.

      Retry Time for Other Issues

      After the migration task starts, if a non-connectivity issue, such as a DDL or DML execution exception, occurs in the source or destination database, DTS reports an error and immediately begins to retry the operation. The default retry duration is 10 minutes. You can customize the retry time to a value from 1 to 1440 minutes. We recommend that you set the duration to more than 10 minutes. If the related operations succeed within the specified retry duration, the migration task automatically resumes. Otherwise, the task fails.

      Important

      The value of Retry Time for Other Issues must be less than the value of Retry Time for Failed Connections.

      Enable Throttling for Full Data Migration

      During full migration, DTS consumes read and write resources on the source and destination databases, which may increase the database load. If required, you can enable throttling for the full migration task. You can set Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s) to reduce the load on the destination database.

      Note
      • This configuration item is available only if you select Full Data Migration for Migration Types.

      • You can also adjust the full migration speed after the migration instance is running.

      Enable Throttling for Incremental Data Migration

      If required, you can also choose to set speed limits for the incremental migration task. You can set RPS of Incremental Data Migration and Data migration speed for incremental migration (MB/s) to reduce the load on the destination database.

      Note
      • This configuration item is available only if you select Incremental Data Migration for Migration Types.

      • You can also adjust the incremental migration speed after the migration instance is running.

      Environment Tag

      Select an environment tag to identify the instance based on your business requirements. In this example, no environment tag is required.

      Configure ETL

      Choose whether to enable the extract, transform, and load (ETL) feature. For more information, see What is ETL? Valid values:

      Monitoring and Alerting

      Select whether to set alerts and receive alert notifications based on your business needs.

      • No: Does not set an alert.

      • Yes: Configure alerts by setting an alert threshold and an alert contact. If a migration fails or the latency exceeds the threshold, the system sends an alert notification.

  7. Save the task and run a precheck.

    • To view the parameters for configuring this instance when you call the API operation, move the pointer over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the bubble that appears.

    • If you do not need to view or have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.

    Note
    • Before the migration task starts, DTS performs a precheck. The task starts only after it passes the precheck.

    • If the precheck fails, click View Details next to the failed check item, fix the issue based on the prompt, and then run the precheck again.

    • If a warning is reported during the precheck:

      • For check items that cannot be ignored, click View Details next to the failed item, fix the issue based on the prompt, and then run the precheck again.

      • For check items that can be ignored, you can click Confirm Alert Details, Ignore, OK, and Precheck Again to skip the alert item and run the precheck again. If you choose to ignore a warning, it may cause issues such as data inconsistency and pose risks to your business.

  8. Purchase the instance.

    1. When the Success Rate is 100%, click Next: Purchase Instance.

    2. On the Purchase page, select the link specification for the data migration instance. For more information, see the following table.

      Category

      Parameter

      Description

      New Instance Class

      Resource Group Settings

      Select the resource group to which the instance belongs. The default value is default resource group. For more information, see What is Resource Management?

      Instance Class

      DTS provides migration specifications with different performance levels. The link specification affects the migration speed. You can select a specification based on your business scenario. For more information, see Data migration link specifications.

    3. After the configuration is complete, read and select Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Click Buy and Start. In the OK dialog box that appears, click OK.

      You can view the progress of the migration task on the Data Migration Tasks list page.

      Note
      • If the migration task does not include incremental migration, it stops automatically after the full migration is complete. After the task stops, its Status changes to Completed.

      • If the migration task includes incremental migration, it does not stop automatically. The incremental migration task continues to run. While the incremental migration task is running, the Status of the task is Running.