Public error codes

Updated at:

Error codes

HTTP status code

Error code

Error message

Description

Action

400 Account.Arrearage Your account has an outstanding payment. Your account has an outstanding payment.
403 BatchCreateNotSupportExistingCloudDisk The batch create API does not support the mounting of existing disks.
400 CloudDisk.NotInSameZone %s. The specified disks are in different zones.
503 containerRepositoryAuthorizationFailed An error occurred while authenticating the container image repository. Make sure that you have activated ACR, and try again later. An error occurred while authenticating the container image repository. Make sure that you have activated ACR, and try again later.
400 CorePattern.UpdateFail Update coredump settings fail, please try again later. Failed to update Coredump settings, please try again.
403 CreateServiceLinkedRole.Denied Please make sure the account has ram:CreateServiceLinkedRole permission. Please make sure the account has ram:CreateServiceLinkedRole permission.
400 DedicatedHostQuotaExceeded The quota of DedicatedHost is exceeded.
400 Degrade.Api The request was denied due to API flow control. The system has been downgraded.
400 DiskNumber.LimitExceed The maximum number of disks in an instance is exceeded. The maximum number of disks in an instance is exceeded.
400 DiskVolume.NotInSameZone The instance to be created and the disk are not in the same zone. The instance to be created and the disk are not in the same zone.
400 DiskVolume.NotSupport The disk volume is not supported. Disk volume does not support your structure. If you want to enable this function, contact us.
400 DryRun.Success This request is a dryrun request with successful result.
400 DryRunOperation Request validation has been passed with DryRun flag set. Request validation has been passed with DryRun flag set.
400 EipAddressPoolIpNotEnough The ip address of specified PublicIpAddressPool is not enough.
400 EipPayInsufficientBalance Your account does not have enough balance to purchase eip.
400 EipPurchaseFlowControl Request was denied due to eip frequent purchase.
403 FeatureAccessRestricted Access to this feature:[%s] is restricted. Please contact Alibaba Cloud ECI support to request access. Access to this feature is restricted. Please contact Alibaba Cloud ECI support to request access.
400 FeatureBasedConstraintConflict A conflict occurs in specified feature constraints: [%s]. A conflict occurs in specified feature constraints
403 Forbidden.AccessKeyDisabled The Access Key is disabled.
403 Forbidden.AccountClosed The operation is forbidden. Your account has been closed.
403 Forbidden.NotSupportRAM This action does not support access in RAM mode.
400 Forbidden.OnlyForInvitedTest Eci create action is only open to invited users during public beta. Eci create action is only open to invited users during public beta.
403 Forbidden.RAM You are not authorized to operate on the specified resource, or this API does not support RAM mode.
403 Forbidden.RamRoleNotExist The specified RAM role does not exist.
403 Forbidden.RiskControl This operation has been identified as an abnormal operation and cannot be processed.
400 Forbidden.SubUser The specified action is not available for you. The specified action is not available for you.
403 Forbidden.Unauthorized You are not authorized to operate on the specified resource.
403 Forbidden.UserBussinessStatus This operation is not allowed, because you have overdue bills. Pay the overdue bill and try again.
403 Forbidden.UserNotRealNameAuthentication This operation is not allowed, because you have not passed the real-name verification.
400 HighCpuMemConfigRequired You need to apply to be added to the whitelist of the specified CPU and memory. You need to apply to be added to the whitelist of the specified CPU and memory.
400 Idempotence.Failed An error occurred while processing your request. Use the new Token and try again.
400 Idempotence.Processing The request is being processed. Please try again.
400 Idempotence.SignatureMismatch The idempotence signature of the specified request does not match the previous request.
400 IdempotentParameterMismatch Request uses a client token in a previous request but is not identical to that request. ClientToken does not match with the current request parameters.
400 ImageCache.IncorrectStatus %s
400 ImageCacheNotSupport Image cache is not available for all users. If you want to enable this function, contact us. Container image cache is currently not available to all users. Submit a ticket if you need to use the feature.
400 ImageSnapshot.IncorrectStatus %s The status of the specified snapshot is invalid.
404 ImageSnapshot.NotFound The specified snapshot does not exist.
400 ImageSnapshot.NotSupport %s Image caching based on data disk snapshots is not available for all users. If you want to enable this function, contact us.
400 IncorrectOperation %s You cannot perform this operation on the specified resource.
400 IncorrectStatus The current status of %s does not support this operation. The current status of %s does not support this operation.
400 IncorrectStatus %s
400 IncorrectUserTemplateFormat %s
400 InstanceTypeNotMatchCpuArch %s.
500 InternalError An unknown error occurred while processing your request.
403 InvalidAction The specified action is invalid Invalid operation.
400 InvalidCpuMemorySpec The specified CPU and memory specifications are invalid. The specified cpu and memory are not allowed.
404 InvalidDiskId.NotFound The specified disk does not exist.
400 InvalidInstanceType.NotSupported The specified InstanceType is invalid.
400 InvalidInstanceTypeForEciBuy Sales of this current instance type is not supported in eci.
400 InvalidInstanceTypeForEciSpotDurationBuy Current instance type does not support spot duration instance.
400 InvalidInstanceTypeForRaid %s. The current specification does not support Raid.
400 InvalidOperation.KMS.InstanceTypeNotSupport The specified instance is invalid. Only I/O optimized instances support KMS key. The specified instance is invalid. Only I/O optimized instances support KMS key.
403 InvalidOperation.ResourceManagedByCloudProduct The operation is forbidden. The security group has been managed by another cloud product.
400 InvalidParam.CpuOrMemorySpec The specified specification is invalid. The specified specification is invalid.
400 InvalidParameter %s
400 InvalidParameter.CPU.Memory The specified CPU and memory are not allowed. The specified cpu and memory are not allowed.
400 InvalidParameter.DuplicatedName The container group include containers with duplicate names.
400 InvalidParameter.DuplicatedName The container group includes volumes with duplicate names. The container group includes volumes with duplicate names.
400 InvalidParameter.DuplicatedVolumeName The container group includes volumes with duplicate names. The container group includes volumes with duplicate names.
400 InvalidParameter.Encrypted.KmsNotEnabled KMS must be enabled for encrypted disks.
400 InvalidParameter.KMS.EncryptedIllegal After configuring the parameter KmsKeyId, you must enable encryption. After configuring the parameter KmsKeyId, you must enable encryption.
403 InvalidParameter.KMS.KeyId.Forbidden You are not authorized to access the specified KMSKeyId. You are not authorized to access the specified KMSKeyId.
404 InvalidParameter.KMS.KeyId.NotFound The specified KMSKeyId does not exist. The specified KMSKeyId does not exist.
400 InvalidParameter.LengthExceeded %s
400 InvalidParameter.LengthExceeded %s. The length of the List type parameter exceeds limitation.
400 InvalidParameter.MismatchInstanceType The instanceId mismatch instance type.
404 InvalidParameter.NotFound %s
400 InvalidParameter.ValueExceeded %s
400 InvalidParameter.ValueExceeded ecs instance type or vcpu quota exceeded. Specifications exceed the specified quota range
400 InvalidPaymentMethod.InsufficientBalance No payment method is specified for your account. We recommend that you add a payment method or add funds to the prepayment balance. No payment method is specified for your account. We recommend that you add a payment method or add funds to the prepayment balance.
400 InvalidSpotCpuMemorySpec The specified CPU and memory are not allowed. You must create spot ECI using standard ECS specifications for CPU and memory.
403 InvalidUser.PassRoleForbidden The RAM user is not authorized to assume a RAM role. The RAM user is not authorized to assume a RAM role.
403 InvalidVSwitchId.IpNotEnough The specified VSwitch %s does not have enough IP addresses. The specified VSwitch %s does not have enough IP addresses.
400 Ipv6AddressNotSupport Ipv6 is not supported in specified region.
400 Ipv6AddressNotSupportInstanceType IPv6 is not supported for the specified instance type.
400 Ipv6AddressNotSupportVsw IPv6 is not supported in the specified vSwitch.
400 JobInstanceBatchCreateNotSupport You cannot create multiple job-optimized elastic container instances at a time. ECI job instance not support batch create.
400 JobInstanceEcsInstanceTypeNotSupport Job-optimized elastic container instances cannot be created by specifying ECS instance types.
400 JobInstanceSpotNotSupport Job-optimized elastic container instances cannot be created as preemptible instances. ECI job instance not support spot.
403 LastTokenProcessing The previous token request is being processed.
400 LocalDiskAmountNotMatch The number of local volumes does not match the instance type.
400 LocalDiskAmountNotMatch The amount of local volume is not matched with instance type. The amount of local volume is not matched with instance type.
400 MissingParameter %s
400 MissingParameter %s.
400 MissingParameter.Template The input parameter template for processing this request is not supplied. Missing key information: Template
400 NoNeedUpdate There are no changes to be updated for current resource. There are no changes to be updated for current resource.
400 NoPermission You are not authorized to use the Product-on-ECI feature. You are not authorized to use the "Product on ECI" feature.
400 NoPermission.Tag No permissions to operate tags.
400 NoPermissionForPorductOnEci You have no permission to use [product on eci] feature.
400 NumberExceed.Tags The length of tags exceeded limit: 20.
409 OperationConflict The request was denied. It conflicts with a previous request.
400 OperationConflict Request was denied due to conflict with a previous request. Request was denied due to conflict with a previous request.
403 OperationDenied.NoStock Sales of this resource are temporarily suspended in the specified zone. We recommend that you use the multi-zone creation function to avoid the risk of insufficient resource. Sales of this resource are temporarily suspended in the specified zone. We recommend that you use the multi-zone creation function to avoid the risk of insufficient resource.
403 OperationDenied.NoStock Sales of this resource with specified features are temporarily suspended in the specified region; please check the instance type features and try again later. Sales of this resource with specified features are temporarily suspended in the specified region; please check the instance type features and try again later.
403 OperationDenied.NoStockWithFeatures Sales of this resource with specific features are temporarily suspended in the specified region; please check the instance type features and try again later. Sales of this resource with specific features are temporarily suspended in the specified region; please check the instance type features and try again later.
403 OperationDenied.SecurityGroupMisMatch The specified VSwitchId and SecurityGroupId are not in the same VPC.
400 OperationDenied.SecurityGroupMisMatch The specified VSwitchId and SecurityGroupId are not in the same VPC. The specified VSwitchId and SecurityGroupId are not in the same VPC.
400 OperationDenied.VswZoneMisMatch The specified vSwitch is not in the zone. The specified VSwitchId is not in the specified Zone.
400 OperationFailed.RiskControl %s. We have detected that your account has security risks. Please contact customer service personnel for details.
400 Ops.ExecuteTaskFail %s. Operation and maintenance task execution failed, please try again later.
400 Payfor.CreditPayInsufficientBalance Your payment credit line is insufficient. Your payment credit line is insufficient.
400 PricingPlanNotFound There is no pricing plan for current specification in current region. The price of this specification is not configured for the current region.
400 PrivateIpAddress.Already.InUse The specific PrivateIpAddress already in use.
400 QuotaExceeded %s quota exceeded.
400 RamRole.NotSupport The RAM role is not supported. The RAM role is not supported.
403 RealNameAuthenticationError Your account has not passed the real-name authentication yet.
400 RecommendEmpty.InstanceTypeFamilyNotMatched The recommended instance type is unavailable in the current zone. Try again later.
400 RecommendEmpty.InstanceTypeSoldOut The instance type recommended in the current zone is unavailable..
400 RecommendEmpty.InstanceTypeSoldOut The recommended instance type is unavailable.
400 RecommendEmpty.PriceNotSatisfied %s The current price of recommend instanceTypes above user max price.
403 RegionNotSupport The specified Region is not supported.
400 RISK.RISK_CONTROL_REJECTION To protect the security of your account, your request has been denied by the risk control system. Please contact Alibaba Cloud Customer Service for details. In order to protect the security of your account, your request was rejected by the wind control system. Please contact customer service for details.
400 SecurityGroupInstanceLimitExceeded The maximum number of IP addresses in the specified security group is exceeded. The ip quota of the specified security group is exceeded.
400 SecurityGroupIpQuotaExceeded The maximum number of IP addresses in the same security group is exceeded.
403 SecurityRisk.3DVerification We have detected a security risk with your default credit or debit card. Please proceed with verification via the link in your email.
400 ServiceNotEnabled %s The service on which this request depends has not been activated. Please activate and try again.
503 ServiceUnavailable A server error occurred while processing your request.
503 ServiceUnavailable.RegionMaintaining System maintenance is in progress on the selected region, please wait a few minutes before trying again.
400 SignatureNonceUsed The request signature nonce has been used.
403 Spot.NotMatched %s. We recommend that you use the create multi-zone function to avoid insufficient inventory. We recommend that you use the create multi-zone function to avoid insufficient inventory.
400 Throttling You have made too many requests within a short time; your request is denied due to request throttling. You have made too many requests within a short time; your request is denied due to request throttling.
400 Throttling.Api The request was denied due to API flow control. The request was denied due to API flow control.
403 Throttling.Vcpu.PerDay The maximum number of request for the day has been exceeded. The maximum number of request for the day has been exceeded.
400 TradeBidCommodityNotMatch The trade ID and the commodity do not match.
400 UnknownError An unknown error occurred while processing your request
403 UnsupportedHTTPMethod This http method is not supported.
400 VnodeDedicatedHostIdAlreadyExist DedicatedHostId:%s of Vnode:%s already exists.
403 Zone.NotOnSale The specified zone is not available for purchase.
400 ResponseLengthExceeded The length of response data exceeded limit. The interface response data length exceeds the limit.
400 MultiAttachedCloudDiskNotSupport %s. You cannot mount a cloud disk with the multi-mount function enabled (that is, an NVMe shared disk).