Alibaba Cloud Workbench lets you manage files on your Elastic Compute Service (ECS) instances directly from your browser. You can upload, download, and edit files, or perform other basic file management tasks without installing an FTP or SSH client. This is ideal for lightweight operations such as modifying configuration files or viewing logs.
Scope
Supported operating systems: Workbench supports Linux and Windows. The procedures and limitations vary by operating system.
Supported connection types: The file management feature is available only for instances that you connect to by using a Workbench terminal connection.
If you connect to an instance by using session management (SSM), this feature is unavailable. The SSM connection method uses a pure terminal protocol and does not include a file transfer channel.
Permission requirements: You must log on to the instance as the
rootuser (for Linux), theAdministratoruser (for Windows), or a user with read and write permissions on the target files and directories.
Manage files on a Linux instance
For Linux instances, Workbench provides a sidebar with a file tree that offers an intuitive and efficient user experience similar to a local file manager.
Upload and download files
Workbench has two versions. If the Workbench iconappears in the upper-left corner when you log on, you are using Workbench 2.0. If the word WORKBENCH is displayed, you are using Workbench 1.0. To switch between versions, click New Version (to go to 2.0) or Old Version (to go back to 1.0) in the upper-right corner.
Workbench 2.0
Log on to the ECS instance.
Go to the Instances page in the ECS console. In the top-left corner of the page, select the target region and resource group.
Go to the details page of the target instance, click Connect, and select Workbench. Follow the prompts to log on to the terminal.
To avoid permission issues, log on as the root user or a user with the necessary permissions for the files you want to transfer.
Transfer files.
In the left-side navigation pane, click the file management icon
to open the file management page. Click the target instance to expand its file tree, and then double-click the folder where you want to upload or download files.Upload: In the right-side pane, click Upload File or drag files into the pane. Alternatively, in the file tree on the left, right-click the destination folder, select Upload, and then select the files to upload.
Download: In the right-side pane, find the file that you want to download and click in the Actions column. Alternatively, in the file tree on the left, right-click the file and select Download.
View file transfer progress.
After you start an upload or download, the transfer progress is displayed in the lower-right corner of the page.
Workbench 1.0
Log on to the ECS instance.
Go to the Instances page in the ECS console. In the top-left corner of the page, select the target region and resource group.
Go to the details page of the target instance, click Connect, and select Workbench. Follow the prompts to log on to the terminal.
To avoid permission issues, log on as the root user or a user with the necessary permissions for the files you want to transfer.
Transfer files.
In the top menu bar, choose File > Open New File Tree.
Upload: In the file tree, right-click the location where you want to upload files, click Upload File, and then select the target files.
If a single file fails to upload, you can retry the upload or delete the file. If multiple files fail to upload, click Re-upload All Failed Items.
Download: In the file tree, right-click the file that you want to download and click Download File.
View file transfer progress.
After you start an upload or download, the transfer progress is displayed in the lower-right corner of the page.
Create, edit, and delete files
Workbench 2.0
Log on to the ECS instance.
Go to the Instances page in the ECS console. In the top-left corner of the page, select the target region and resource group.
Go to the details page of the target instance, click Connect, and select Workbench. Follow the prompts to log on to the terminal.
To avoid permission issues, log on as the root user or a user with permissions to modify the files.
Perform file operations.
In the left-side navigation pane, click the
icon to open the file management page. Click the target instance to expand its file tree, and then double-click the folder that contains the files that you want to manage.Create a file or directory: In the right-side pane, click New Resources and select New File or New Folder. Alternatively, in the file tree on the left, right-click the target location and select New File or New Folder.
Edit a file: In the right-side pane, find the target file and click in the Actions column. Alternatively, you can double-click the file to open it in the editor on the right. After you finish editing, press
Ctrl+S(Windows) orCommand+S(Mac) to save your changes.Delete or rename a file: In the right-side pane, find the target file, click the
icon in the Actions column, and select Delete or Rename. Alternatively, in the file tree on the left, right-click the file and select Delete or Rename.WarningBefore you delete a file, ensure the file is not required by your services and has no system dependencies to prevent service disruptions.
Workbench 1.0
Log on to the ECS instance.
Go to the Instances page in the ECS console. In the top-left corner of the page, select the target region and resource group.
Go to the details page of the target instance, click Connect, and select Workbench. Follow the prompts to log on to the terminal.
To avoid permission issues, log on as the root user or a user with permissions to modify the files.
Perform file operations.
In the top menu bar, choose .
Create a file or directory: In the file tree on the left, right-click the target folder and select New File or New Folder.
Edit a file: In the file tree on the left, double-click the target file to open it in the editor on the right. After you finish editing, click the save icon
in the upper-right corner.Delete or rename a file: In the file tree on the left, right-click the target file and select Delete or Rename.
WarningBefore you delete a file, ensure the file is not required by your services and has no system dependencies to prevent service disruptions.
Manage files on a Windows instance
For Windows instances, Workbench creates a temporary network drive named workbench on xxx@ to enable file transfers. This drive and all files within it are automatically and permanently deleted when you disconnect from Workbench.
Upload and download files
Log on to the ECS instance.
Go to the Instances page in the ECS console. In the top-left corner of the page, select the target region and resource group.
Go to the details page of the target instance, click Connect, and select Workbench. For the connection method, select Terminal Connection, enter the username and password, and then log on to the graphical terminal.
In the search box, search for and open This PC.
If you cannot find This PC in the search results, open File Explorer and click This PC in the left-side navigation pane.
In the Redirected drives and folders section, double-click the workbench on xxx@ drive.
Upload: Drag the target file from your local computer to the Download directory. Then, from that directory, move the file to another drive on the instance, such as the C drive.
Download: Drag the target file from a drive on the instance, such as the C drive, to the Download directory. The file is automatically downloaded to your local computer.
You cannot download 0-byte files.
Quotas and limitations
Item | Description | Solution and recommendation |
File upload size |
|
|
Transfer performance | Transfer speeds may be slower during peak network hours. File transfers use the HTTPS protocol and do not support resumable transfers. | For files larger than 500 MB or for transfers over an unstable network, use a different transfer solution, such as |
FAQ
Identify and switch Workbench versions
You can identify the Workbench version based on the UI. Workbench 2.0 displays the Workbench icon
in the upper-left corner, whereas Workbench 1.0 displays the word WORKBENCH. The left-side navigation pane also differs between versions.
To switch between versions, click New Version (to go to 2.0) or Old Version (to go back to 1.0) in the upper-right corner.
"File management not supported" error
Symptom:
This message appears, and the instance name is followed by the ssm (session management) identifier.
Cause:
This feature is not supported when you connect to an instance by using session management.
Solution:
Option 1: Log on to the instance by using a Workbench terminal connection and then retry the file transfer.
Option 2: Upload or download files on the instance details page in the console.
Missing top menu bar
Symptom: The menu bar, including the File button, is not visible at the top of the Workbench interface.
Cause: The top menu bar is hidden.
Solution: Right-click the terminal interface and click Show/Hide Menu Bar.
Missing "Open New File Tree" feature
Symptom:
After you connect to a Linux instance in Workbench and click File in the top menu bar, the drop-down menu shows only the New File and New Folder options. The Open New File Tree option is missing.
Cause:
You may be connected to the instance by using session management, which does not support this feature.
If you are not using session management, try refreshing the page or reconnecting to the instance.
Solution:
Option 1: Log on to the instance by using a Workbench terminal connection and then retry the file transfer.
Option 2: Upload or download files on the instance details page in the console.
Resolve Permission Denied upload error
Symptom:
In the File Task Center, the file upload fails and a
Permission Deniederror appears in the Upload Task list.Cause:
The user account you used to log on may lack write permissions for the target directory. For example, this error occurs if you log on as the
ecs-useruser and try to upload a file to the/optdirectory.Solution:
Log on as the root user and upload the file again.
Log on to the instance as the root user and then retry the upload.
If you specified ecs-user as the logon name when you created the instance, you must reset the password for the root user to log on as the root user. For more information, see Method 1: Reset the password of an instance in the ECS console.
Upload the file to the home directory of the current user.
For example, if you are logged on as the ecs-user user, upload the file to the
/home/ecs-userhome directory.
"File management not supported" error
Symptom:
This message appears, and the instance name is followed by the ssm (session management) identifier.
Cause:
This feature is not supported when you connect to an instance by using session management.
Solution:
Option 1: Log on to the instance by using a Workbench terminal connection and then retry the file transfer.
Option 2: Upload or download files on the instance details page in the console.