Upload or download files by using Workbench

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After logging on to an ECS instance using Workbench, you can upload or download files using the file management feature.

Limitations

  • File size limits: Files uploaded to a Linux instance cannot exceed 1,200 MB. Files uploaded to a Windows instance cannot exceed 100 MB. If a file exceeds the limit, you must use other file transfer methods.

  • Transfer speed: When using Workbench to upload files, transfer speeds may be slower during peak hours. If the transfer speed is slow, you can use another file transfer method.

  • This feature is not supported for instance connections that use session management.

Upload files

Important

To upload multiple files, you must first compress the files into a single archive, transfer the archive to the instance, and then decompress it on the instance after the transfer is complete. Upload a compressed file

Linux instance

How do I determine whether I am using Workbench 1.0 or 2.0?

Workbench 2.0

  1. Log on to a Linux instance by using Workbench.

    Log on to the instance as the root user or a user with write permissions for the destination folder. Otherwise, the upload may fail due to insufficient permissions.
  2. In the left-side navigation pane, click image, go to the file management page, and then click the target instance to expand its file tree.

    When you click an instance in image, the message "The file management feature is not supported for the current logon method of this instance" is displayed.

    • Problem:

      The error message shown in the following figure appears, and the ssm (session management) identifier also appears after the instance name.

      image

    • Cause:

      This feature is not supported for connections that use session management.

    • Solution:

  3. Right-click the destination folder. Click Upload and select the file to upload.

    You can also double-click the destination folder in the left-side directory tree, and in the right-side pane, click Upload File or drag files to upload them.
  4. Wait for the file transfer to complete.

    After you upload a file, the upload progress appears in the lower-right corner of the page.

    image

Workbench 1.0

  1. Log on to a Linux instance by using Workbench.

    Log on to the instance as the root user or a user with write permissions for the destination folder. Otherwise, the upload may fail due to insufficient permissions.
  2. In the upper-left corner of the top menu bar, select File > Open New File Tree.

    image

    The "Open New File Tree" feature cannot be found

    • Problem:

      image

    • Cause:

      You may be connected to the instance by using session management, which does not support this feature.

      If you are not connected to the instance by using session management, try refreshing the page or reconnecting to the instance.

    • Solution:

  3. In the file tree, right-click the location to which you want to upload a file, and then click Upload File in the shortcut menu.

  4. Select the file to upload.

    The upload is complete when a success message appears.上传完成

    Note

    If a file fails to upload, you can retry the upload or delete the file. If multiple files fail to upload, you can click Re-upload All Failed Items to upload them again.

    You can modify, delete, download, or rename the uploaded file in the file list.

Windows instance

  1. Log on to a Windows instance by using Workbench

  2. In the search box, search for and open This PC.

    If you cannot find This PC, you can open File Explorer, and then in the left navigation bar, click This PC.
  3. In the Redirected Drives And Folders section, double-click the workbench on xxx@ drive.

    image

  4. Drag a file, such as test.txt, from your local machine to this folder.

    image

  5. Then, move the file from this folder to Drive C or another drive on the instance.

    Important

    When you reconnect to or exit an instance, Workbench automatically clears all uploaded files from the Redirected Drives And Folders directory to save space. This directory is for file transfers only, so do not save any files in it.

Download files

Linux instance

How do I determine whether I am using Workbench 1.0 or 2.0?

Workbench 2.0

  1. Log on to a Linux instance by using Workbench.

    Log on to the instance as the root user or a user with read permissions on the files to be downloaded. Otherwise, the download may fail due to insufficient permissions.
  2. In the left-side navigation pane, click image, go to the file management page, and then click the target instance to expand its file tree.

    When you click an instance in image, the message "The file management feature is not supported for the current logon method of this instance" is displayed.

    • Problem:

      The error message shown in the following figure appears, and the ssm (session management) identifier also appears after the instance name.

      image

    • Cause:

      This feature is not supported for connections that use session management.

    • Solution:

  3. Right-click the file that you want to download and click Download.

    Alternatively, in the directory tree on the left, double-click the folder that contains the file you want to download. In the pane on the right, click image > Download in the Actions column for the file.
  4. Wait for the file transfer to complete.

    After you click Download, the file download progress is displayed in the lower-right corner of the page.

Workbench 1.0

  1. Log on to a Linux instance by using Workbench.

    Log on to the instance as the root user or a user with read permissions on the files to be downloaded. Otherwise, the download may fail due to insufficient permissions.
  2. In the upper-left corner of the top menu bar, select File > New Navigator.

    image

    The "Open New File Tree" feature cannot be found

    • Problem:

      image

    • Cause:

      You may be connected to the instance by using session management, which does not support this feature.

      If you are not connected to the instance by using session management, try refreshing the page or reconnecting to the instance.

    • Solution:

  3. In the file tree, right-click the file that you want to download, and then click Download in the shortcut menu.

    The download is complete when a success message appears.下载完成

    Note

    If a file fails to download, you can retry the download or delete the file. If multiple files fail to download, you can click Download All Failed Items Again to download them again.

Windows instance

Important

Empty files cannot be downloaded.

  1. Log on to a Windows instance by using Workbench.

  2. In the Windows search box, search for and open This PC.

  3. In the Redirected Drives And Folders section, double-click the workbench on xxx@ drive.

    image

  4. Drag the target file from the C drive or another drive to the Download directory to download the file to your computer.Automatic download.png

FAQ

Identify Workbench version and switch versions

The UI indicates the Workbench version. Workbench 2.0 displays the Workbench icon image in the upper-left corner, while Workbench 1.0 displays the text WORKBENCH. The left-side navigation panes are also different.

Workbench 2.0

Workbench 1.0

image

image

To switch Workbench versions, click New Version (to use 2.0) or Old Version (to use 1.0) in the upper-right corner.

"File management not supported" error

  • Problem:

    The error message shown in the following figure appears, and the ssm (session management) identifier also appears after the instance name.

    image

  • Cause:

    This feature is not supported for connections that use session management.

  • Solution:

The top menu bar cannot be found

  • Problem: The top menu bar and the File button cannot be found on the Workbench page.

  • Cause: The top menu bar is hidden.

  • Solution: Right-click the terminal interface and click Show/Hide Menu Bar.

"Open New File Tree" feature not found

  • Problem:

    image

  • Cause:

    You may be connected to the instance by using session management, which does not support this feature.

    If you are not connected to the instance by using session management, try refreshing the page or reconnecting to the instance.

  • Solution:

"Permission Denied" error during upload

  • Problem:

    image

  • Cause:

    The file upload fails if the logon account lacks write permissions for the destination directory. For example, this error occurs when you log on as the ecs-user user and upload a file to the /opt directory.

  • Solution:

    • Log on to the instance as the root user and upload the file.

      Log on to the instance again as the root user to upload the file.

      If you specified ecs-user as the username when you created the instance, you must reset the password for the root user before you can log on to the instance as the root user. For more information, see Method 1: Reset the instance password in the console.
    • Upload the file to the home directory of the current user.

      For example, if you log on as the ecs-user user, upload the file to that user's home directory: /home/ecs-user.