This topic describes how to troubleshoot a Remote Desktop connection to a Windows instance that fails without an error message.
Symptoms
A Remote Desktop connection to a Windows ECS instance from your local computer fails, and no error message is displayed.
Cause
This issue occurs when Remote Desktop connections are disabled on the Windows ECS instance.
Solution
The following procedure uses Windows Server 2012 R2 as an example. The steps may vary depending on your operating system version. For specific instructions, refer to the official documentation for your OS.
Connect to the Windows instance by using VNC.
For more information, see Connect to an instance by using VNC.
Click the
icon, right-click This PC, and then click Properties. On the Control Panel Home, click Remote settings.
On the Remote tab, select Allow remote connections to this computer, click Apply, and then click OK.
Try to connect to the server again.
Related documents
For help with other remote connection issues for Windows instances, see the following articles: