Error message list

Updated at:

This topic provides some general error messages and solutions for the errors that occur when you use Graph Database (GDB).

Error list of data import tasks

Data import provides APIs to add, query, and delete tasks. In addition to command errors, the query API also returns errors that occur during task execution.

Request

Back

Description

Adding task

Loader File Format don't support

The file format is not supported. Only the CSV format is supported.

Operation not permitted on a read-replica instance

Read-only instances do not support import tasks. Check the status of the primary and replica instances.

Invalid loaderId

The task ID is invalid.

Unsupport Content-Type Request

Requests to add tasks must have the Content-Type set to application/json.

SERVER_ERROR: LOAD ACCOUNT MISSED

A server-side error occurred. Contact technical support.

Failed to Start load because of not found GraphDB instance

A server-side error occurred. Contact technical support.

too small size object

The import file is too small. It typically does not contain a complete, valid record.

Fail to get meta:{{msg}}

An error occurred when accessing OSS.

Max concurrent load limit breached

The maximum number of concurrent tasks (1) is exceeded.

LOAD_INVALID_REQUEST: {{msg}}

Failed to parse the task parameters in the request. Check the input parameters based on the returned error message.

No Sub-Key object in dir

The import file was not found in the OSS directory.

OSS: {{msg}}

An error occurred when accessing OSS. Contact technical support for assistance.

LOAD_ARN_ROLE_FAILED: {{msg}}

An error occurred with the role authorization request. Contact technical support for assistance.

LOAD_NOT_SUPPORT TO RESUME LOAD

Duplicate tasks are not supported. Delete the existing task before adding it again.

Deletion task

loaderId is needed for DELETE

The task ID was not provided in the delete request.

The load does not exist or active

The task specified in the delete request does not exist.

Query task

The load does not exist

The task specified in the query request does not exist.

CSV header error, {{path}}

The format of the import file is invalid.

Parser Record Error, line, record field size is mismatch with header

Failed to parse a CSV record. The number of fields in the record does not match the header.

Parser Record Error, {{line}}, id miss in record

Failed to parse a CSV record. The ID field is missing.

Parser Record Error, {{line}}, from and to needed in edge record

Failed to parse a CSV record. The edge record is missing the `to` or `from` field.

Fetch Line Record: {{line}} CSV record over limited

Failed to parse a CSV record from the stream. The record line is too long (exceeds 4 MB).

Commit record Error: {{line}}, {{code}}, record {{id}}

Failed to write data to the GDB instance. Contact technical support.

Common error codes for data write operations on GDB

  • code = 22 - ID does not exist. This error occurs when you import an edge, but its associated vertex does not exist in the GDB instance.

  • code = 21 - ID already exists. This error occurs when you import a vertex or edge with a duplicate ID. This usually happens because the failOnError import parameter is set to true. To resolve this, set the parameter to false.

  • code = 25 - ID already exists, but the label of the vertex or edge in GDB is different from the one you provided.

Note

The vertex or edge ID must be unique in GDB. This indicates that the IDs of all the vertices are different from each other in an instance in addition to a label. The IDs of all the edges are also different from each other in an instance in addition to a label. The vertex IDs can be the same as the edge IDs.

Common OSS access errors

  • An error occurs when you use an OSS endpoint. By default, GDB accesses OSS resources that are deployed in the same region. If the provided OSS bucket is not deployed in the same region as GDB, an error is reported.

    [OSS] AccessDenied : The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.

  • The OSS file does not exist and the import task cannot find the file of the OSS path that is specified by the parameter.

    [OSS] NoSuchKey : The specified key does not exist.