Common error codes
HTTP status code | Error code | Error message | Description | Solution | Operation |
400 | DiskCategoryUnsupported | The specified parameter DiskCategory is invalid. | The specified "DiskCategory" parameter is invalid. Valid values are: cloud_efficiency, cloud_ssd, local_ssd_pro, local_hdd_pro, cloud_essd, and cloud_essd_pl0. |
| |
400 | InstanceBusying | The instance is busy, please try again later. | An operation is in progress. Try again later. |
| |
400 | DiskUsage.FetchError | Exception occurred when getting disk usage, please try again later. | An exception occurred while getting the disk usage. Try again later. |
| |
400 | StorageUsage.TooHigh | Reducing is forbidden, because the storage usage is too high. | Scale-in is prohibited because the storage usage is too high. | Increase the storage capacity. | |
403 | LdfsVersion.TooLow | The minor version of ldfs is too low, please upgrade first. | The minor version of ldfs is too low. Upgrade it first. | Go to the Instance Details page in the console. In the Configuration Information section, check if the underlying storage is the latest version. If an upgrade is available, upgrade to the latest version. | |
404 | RamRole.NotFound | Please authorized the Lindorm Service Linked Role. | Grant the service-linked role for Lindorm. | Check if the service-linked role for Lindorm is granted. If not, grant the role. | |
400 | EnableAttachFirst.ParameterInvalid | Please enable attach cloud disk. | Enable disk attachment. | Check if the disk attachment feature is enabled. If not, enable it. | |
400 | Resource.ecsResource.soldout | Insufficient resources for master nodes, please change region or available zone. | Insufficient resources for master nodes. Change the region or zone. |
| |
400 | Resource.ecsResource.soldout | Insufficient resources for core nodes, please change region or available zone. | Insufficient resources for core nodes. Change the region or zone. |
| |
400 | Resource.ecsResource.soldout | Insufficient resources for capacity cloud storage, please change region or available zone. | Insufficient storage-optimized resources. Change the region or zone. |
| |
400 | VpcOrVswitchInsufficient | Insufficient IP of VPC switch. | Insufficient IP addresses in the VPC vSwitch. |
| |
400 | WrongParameter | Parameter wrong. | Incorrect parameter. |
| |
400 | UpdateType.NotSupported | The update type is not supported. | Unsupported update type. |
| |
403 | API.Forbidden | This api is forbidden in this environment. | This API is forbidden in this environment. |
| |
400 | InstanceInvalid | Instance status is invalid. | The instance status is invalid. |
| |
400 | Instance.UpdateFailed | Failed to update password for user '%s' on instance %s. | Failed to update the password for user '%s' on instance %s. |
| |
400 | InstanceUser.DeleteFailed | Failed to delete user '%s' on instance %s. | Failed to delete user '%s' on instance %s. |
| |
400 | Instance.DoesNotSupportShrinkStorage | Reducing storage capacity is not supported yet. | Reducing storage capacity is not supported. |
| |
400 | Instance.PleasePurchaseColdStorage | Please purchase cold storage. | Purchase cold storage. |
| |
400 | Instance.PleasePurchaseArchiveStorage | Please purchase archive storage. | Purchase Archive Storage. |
| |
400 | Resource.ecsResource.soldout | Insufficient resources, please change region or available zone. | Insufficient resources. Change the region or zone. |
| |
400 | InstanceUser.CreateFailed | Failed to create user '%s' on instance %s. | Failed to create user '%s' on instance %s. |
| |
400 | ReduceNodes.ParamError | Engine nodes only one is invalid, please chose more than 2 or set 0(close engine). | Having only one engine node is invalid. Select more than 2 nodes or set the number to 0 to close the engine. |
| |
400 | ReduceNodes.ParamError | Engine nodes must be at least %s due to the activation of HDFS Erasure Coding. | The number of engine nodes must be at least %s because HDFS erasure coding is enabled. |
| |
400 | ReduceNodes.CloudTypeParamError | Engine nodes of cloud disk type must be at least %s, and be reduced at most %s each time. | The number of engine nodes for the disk type must be at least %s. You can reduce the number of nodes by a maximum of %s at a time. |
| |
400 | ReduceNodes.LdfsCloudTypeParamError | Engine nodes of cloud disk type must be at least %s. | The number of engine nodes for the disk type must be at least %s. | Increase the number of nodes to the minimum requirement. | |
400 | ReduceNodes.LocalTypeParamError | Engine nodes of local disk type must be at least %s, and be reduced at most %s each time. | The number of engine nodes for the local disk type must be at least %s. You can reduce the number of nodes by a maximum of %s at a time. |
| |
400 | ReduceNodes.LdfsLocalTypeParamError | Engine nodes of local disk type must be at least %s. | The number of engine nodes for the local disk type must be at least %s. | Increase the number of nodes to the minimum requirement. | |
400 | ReduceNodes.LTSParamError | Engine nodes must be at least %s. | The number of engine nodes must be at least %s. | Increase the number of nodes to the minimum requirement. | |
400 | Resource.Engine.Open | The number of engine nodes must be greater than 0. | The number of engine nodes must be greater than 0. | Increase the number of engine nodes to be greater than 0. | |
404 | VpcCidrError | Get vpc cidr error, please contact us for more help. | Failed to get the VPC CIDR block. Contact us for help. |
| |
400 | InvalidParameter.%s | %s. | Invalid parameter. |
| |
400 | OperationDenied | The operation is denied, please contact us for more information. | The operation is denied. Contact us for more information. |
| |
400 | Instance.DoesNotSupportShrinkCoreNumber | Reducing nodes is not supported yet. | Reducing the number of nodes is not supported. |
| |
400 | Instance.DoesNotSupportShrinkStorage | Reducing storage capacity of log nodes is not supported yet. | Reducing the storage capacity of change data capture nodes is not supported. |
| |
403 | DiskCategory.NotSupport | The time series engine and search engine does not support capacity storage. You can select standard or performance cloud storage. | LindormTSDB and search engines do not support storage-optimized storage. You can select standard or performance cloud storage. |
| |
500 | Instance.CreationFailed | Create instance failed due to internal error. | Failed to create the instance due to an internal error. |
| |
500 | UpgradeCapacityFailed.InternalError | Upgrade instance capacity failed due to internal error. | Failed to upgrade the instance capacity due to an internal error. |
| |
404 | InstanceConfig.NotFound | The config of instance not found. | The instance configuration was not found. |
| |
400 | EncryptionType.ParameterInvalid | EncryptionType is invalid. | The encryption type is invalid. |
| |
403 | OperationForbidden | The operation is forbidden, please contact us for more information. | The operation is forbidden. Contact us for more information. |
| |
500 | Instance.FailedAllocatingVpcIp | Failed allocating vpc ip. | Failed to allocate a VPC IP address. |
| |
404 | VSwitchInfo.NotFound | Vswitch info lost. | The vSwitch information is lost. |
| |
400 | VSwitchCount.Invalid | Vswitch count is invalid. | The vSwitch count is invalid. |
| |
404 | Subdomain.NotFound | Failed to get subdomain. | Failed to get the subdomain. |
| |
400 | PayType.IsNotValid | Pay type is not valid. | The payment type is invalid. |
| |
400 | PayType.IsNotChanged | Pay type is not changed. | The payment type was not changed. |
| |
400 | UpgradeType.Invalid | The upgrade type parameter is invalid. Check the validity of the UpgradeType parameter. | The upgrade type parameter is invalid. Check the validity of the "UpgradeType" parameter. |
| |
400 | GenLindormV2DescFailed | Generate lindorm v2 meta data failed. | Failed to generate Lindorm V2 metadata. |
| |
400 | LindormV2Desc.CapacityStorageNotSupported | Capacity storage is not supported for Lindorm V2 instances. | Lindorm V2 instances do not support storage-optimized storage. |
| |
400 | MultiChangeIsNotAllowedConcurrently | Multiple differences have been detected. Only one type of difference can be submitted at a time. | Multiple changes were detected. You can submit only one type of change at a time. |
| |
400 | UnsupportedServiceType | The service type of the instance is unsupported. | The service type of the instance is not supported. |
| |
400 | ParamsTablesInvalid | The parameter 'Tables' is empty or invalid. | The "Tables" parameter is empty or invalid. |
| |
400 | RestoreTimeInvalid | The restore time is invalid. | The restore time is invalid. |
| |
400 | WrongTimeFormat | The time format is invalid. | The time format is invalid. |
| |
400 | DescribeTypeInvalid | The describe type is invalid. | The describe type is invalid. |
| |
400 | WhiteIpListInvalid | White IP list is invalid. | The IP whitelist is invalid. |
| |
400 | SecurityGroupListInvalid | Security group list is invalid. | The security group list is invalid. |
| |
400 | ActionTypeInvalid | Action type is invalid. | The action type is invalid. |
| |
400 | SecurityGroupListExceed | The num of security groups exceeds 10. | The number of security groups exceeds 10. |
| |
400 | OnlyPublicCloudAllowed | Only public cloud is allowed to do this operation. | Only public cloud environments can perform this operation. |
| |
400 | Ssl.NotEnabled | SSL has not been enabled yet. | SSL is not enabled. |
| |
400 | Port.Invalid | The port is invalid. | The port is invalid. |
| |
400 | RecordType.Invalid | The record type is invalid. | The record type is invalid. |
| |
400 | Path.TooLong | The path is too long. | The path is too long. |
| |
400 | JobName.Invalid | The job name is invalid. | The job name is invalid. |
| |
400 | FileDir.Invalid | The file directory is invalid. | The file directory is invalid. |
| |
400 | LdpsComponent.Invalid | The ldps component is invalid. | The ldps component is invalid. |
| |
400 | InvalidAccount | The account is invalid. | The account is invalid. |
| |
400 | WeakPassword | The password is too weak. | The password is too weak. |
| |
400 | TimeWindowExceedLimit | The proactive maintenance time window must not exceed 4 hours. | The proactive maintenance time window cannot exceed 4 hours. |
| |
400 | Instance.IsDeleted | Instance is deleted. | The instance is deleted. |
| |
404 | Instance.NotExist | The instance does not exist. Please confirm the validity of the InstanceId parameters. | The instance does not exist. Confirm the validity of the "InstanceId" parameter. |
| |
400 | Instance.NotActive | The instance status is not running, and other operations are temporarily not allowed to be submitted. | The instance is not running. Other operations cannot be submitted at this time. |
| |
400 | Instance.StatusUnknown | Instance status is unknown. | The instance status is unknown. |
| |
400 | Instance.UpdateFailed | Update instance security ip list failed. | Failed to update the instance security IP list. |
| |
400 | SecurityGroup.UpdateFailed | Update instance security groups failed. | Failed to update the instance security groups. |
| |
400 | SecurityGroup.DescribeFailed | Describe instance security groups failed. | Failed to describe the instance security groups. |
| |
400 | Instance.UpdateFailed | Update UI account and password failed. | Failed to update the UI account and password. |
| |
400 | Instance.DoesNotSupportChangeClass | Changing specifications or number of nodes is not supported yet. | Changing specifications or the number of nodes is not supported. |
| |
400 | InstanceInvalid | Only lindorm v2 instance support current operation. | Only Lindorm V2 instances support the current operation. |
| |
400 | LindormSpec.Invalid | The engine specification is invalid or unsupported. | The engine specification is invalid or unsupported. |
| |
400 | InsStorageInvalid | Storage capacity must be greater than 80GiB and a multiple of 80. | The storage capacity must be greater than 80 GiB and a multiple of 80. |
| |
400 | ReduceNodes.ParamError | Engine nodes must be at least %s, and be reduced at most %s each time. | The number of engine nodes must be at least %s. You can reduce the number of nodes by a maximum of %s at a time. |
| |
400 | ReduceNodes.ParamError | This engine still has some data, please clear the data before closing engine. | This engine still contains data. Clear the data before you close the engine. |
| |
400 | UpgradeNodes.StepSizeInvalid | The step size for node quantity adjustment is invalid. It should be a multiple of %s. | The step size for node quantity adjustment is invalid. It must be a multiple of %s. |
| |
400 | EngineTypeInvalid | This engine type is invalid. | This engine type is invalid. |
| |
400 | Order.CreateFailed | Create order failed, please contact us for more help. | Failed to create the order. Contact us for help. |
| |
403 | StreamVersion.TooLow | The minor version of stream engine is too low, please upgrade first. | The minor version of the stream engine is too low. Upgrade it first. | Upgrade the stream engine to the latest version. | |
403 | SearchVersion.TooLow | The minor version of search engine is too low, please upgrade first. | The minor version of the search engine is too low. Upgrade it first. | Upgrade the search engine to the latest version. | |
403 | LindormVersion.TooLow | The minor version of lindorm engine is too low, please upgrade first. | The minor version of the Lindorm engine is too low. Upgrade it first. | Upgrade the Lindorm engine to the latest version. | |
404 | LdpsCloudVpcNotFound | Prepare compute engine resource error, please contact us for more help. | An error occurred while preparing compute engine resources. Contact us for help. |
| |
404 | SecurityGroup.NotFound | Get cloud security groups failed. | Failed to get the cloud security groups. |
| |
404 | VswitchAcquireError | Get vswitch for spark cluster error, please contact us for more help. | An error occurred while getting the vSwitch for the Spark cluster. Contact us for help. |
| |
404 | ComputeResourceError | Prepare compute worker engine resource error, please contact us for more help. | An error occurred while preparing compute worker engine resources. Contact us for help. |
| |
400 | SecurityGroup.CreateFailed | Create instance security groups failed, please contact us for more help. | Failed to create the instance security groups. Contact us for help. |
| |
400 | ComputeEngine.UpdateFailed | Update compute engine resource limitation failed, please contact us for more help. | Failed to update the compute engine resource limits. Contact us for help. |
| |
400 | SLR.CreateError | Create serivce linked role error, please contact us for more help. | An error occurred while creating the service-linked role. Contact us for help. |
| |
404 | ComputeEngine.JobNotFound | This job not found. | This job was not found. |
| |
400 | Tags.ExceedLimitation | The number of tags exceeds the limit, the maximum is %s. | The number of tags exceeds the limit. The maximum is %s. |
| |
400 | InvalidTagKey.Malformed | The specified parameter "Tag.n.Key" is not valid. | The specified parameter "Tag.n.Key" is invalid. |
| |
400 | Duplicate.TagKey | The specified parameter "Tag.n.Key" is duplicated. | The specified parameter "Tag.n.Key" is a duplicate. |
| |
400 | InvalidParameter.ResourceType | The specified parameter "ResourceType" is not valid. | The specified parameter "ResourceType" is invalid. |
| |
400 | InvalidParameter.ResourceId | The specified parameter "ResourceId.n" is not valid. | The specified parameter "ResourceId.n" is invalid. |
| |
400 | NumberExceed.ResourceIds | The number of ResourceIds exceeds the limit, the maximum is %s. | The number of ResourceIds exceeds the limit. The maximum is %s. | Reduce the number of ResourceIds to be within the limit. | |
400 | InvalidParameter.ApiVersionMismatch | The input instance serviceType %s does not match the api version %s, you should call api %s. | The input instance serviceType %s does not match the API version %s. You must call API %s. |
| |
400 | AutoScaleRequest.Failed | Request to autoScaler service failed. | The request to the auto-scaler service failed. |
| |
400 | InvalidParameter.CronExpr | Cron expression is invalid. | The cron expression is invalid. |
| |
400 | GrantAclFailed | Failed to grant ACL for user '%s' on instance %s. | Failed to grant the ACL for user '%s' on instance %s. |
| |
400 | RevokeAclFailed | Failed to revoke ACL for user '%s' on instance %s. | Failed to revoke the ACL for user '%s' on instance %s. |
| |
400 | Forbidden.RegionNotFound | The provided RegionId does not match to the endpoint. | The operation failed. The provided RegionId does not match the endpoint. | Switch the endpoint to the same region. | |
499 | OperationFailed | The operation processing has failed due to some unknown error or exception, please contact us or submit a ticket for help. | The operation failed due to an unknown error or exception. Contact us or submit a ticket for help. |
| |
400 | SecurityIpStatus.NotActive | Security Ip Status Not Active. | The instance security group or whitelist is being updated. Try again later. |
| |
400 | LindormErrorCode.%s | %s. | A generic error code was returned. For more information, see the error message. | Modify your request parameters based on the error message and the OpenAPI documentation, and then try the request again. For more information, see the API Documentation Center. |