Basic management FAQ

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This topic answers common questions about creating and deleting File Storage NAS file systems and mount targets.

File system creation and limits

  • Each account can create up to 20 General-purpose NAS file systems and 200 Extreme NAS file systems in a single region.

  • Maximum capacity of a single file system: 10 PiB for Capacity-type General-purpose NAS, 1 PiB for Performance-type General-purpose NAS, 1 PiB for Advanced-type General-purpose NAS, and 256 TiB for Extreme NAS.

  • Maximum number of files in a single file system: 1 billion for General-purpose NAS and 500 million for Extreme NAS.

For more information, see Limits.

"Insufficient inventory" error

This error indicates that resources are unavailable in the selected availability zone. Try creating the file system in a different availability zone.

Mount targets

A mount target is an access point that specifies the network type and permissions for compute nodes, such as ECS instances, E-HPC, or container services, to connect to a file system. Multiple nodes can use the same mount target to access the file system.

Counting mounted compute nodes

If a file system is mounted to ECS instances, each ECS instance counts as one mounted compute node. If a file system is mounted to containers, each container counts as one mounted compute node.

Change the network type of a mount target

No. After a mount target is created, you cannot change its network type. To switch network types, create a mount target with the desired network type and then use it to remount the file system.

Note
  • If your file system has two mount targets and both use the classic network, you must remove one mount target before you can add a new VPC-type mount target. Perform this change during off-peak hours to minimize service disruption.

  • Before you switch, make sure that the ECS instances mounting the NAS file system have been migrated from the classic network to a VPC. For more information about how to switch the network type of an ECS instance, see Migrate an ECS instance from a classic network to a VPC.

For example, assume that you have a Capacity-type General-purpose NAS file system that is mounted using a classic network-type mount target. To switch the mount target to a VPC type, follow these steps:

  1. Create a new VPC-type mount target. For more information, see Add a mount target.

  2. Unmount the file system that uses the classic network-type mount target. For more information, see Unmount a file system.

    Log on to the NAS console. On the details page of the file system, go to the Mount Targets tab. In the Actions column of the mount target, choose image > Client List. Make sure the Client List is empty.

  3. Remount the file system at the original destination path using the VPC-type mount target. For more information, see Mount a file system.

  4. In the Actions column of the original classic network mount target, choose image > Disable and confirm the action.

  5. After you confirm that your services are not affected, choose image > Delete and confirm the action.

Switch the VPC for a NAS file system

Note

A General-purpose NAS file system supports up to two mount targets. An Extreme NAS file system supports only one mount target, and it must be a VPC-type mount target.

Only General-purpose NAS file systems support VPC switching. Extreme NAS file systems do not. To switch the VPC for a General-purpose NAS file system, perform one of the following operations:

  • Directly add a mount target.

    If the file system has only one mount target, you can add another one in the destination VPC and then use the new mount target to access the file system.

  • Remove an existing mount target and then add a new one in the destination VPC.

    A General-purpose NAS file system supports a maximum of two mount targets. If the limit is reached, you must first remove an old mount target before you can add a new one in the destination VPC.

    1. Unmount the file system from the old VPC. For more information, see Unmount a mount directory from the NAS console or Unmount a mount directory by running commands.

    2. Remove the old mount target. For more information, see Delete a mount target.

    3. Add a mount target in the destination VPC. For more information, see Add a mount target.

    4. Mount the file system by using the new mount target. For more information, see Mounting scenarios.

Delete a mount target created by Cloud Shell

When you use Cloud Shell to manage your NAS resources, a mount target is automatically created in the mount target list of the file system.

To delete a mount target created by Cloud Shell, use one of the following methods:

  • Delete the mount target from the NAS console

    1. Log on to the NAS console.

    2. In the left-side navigation pane, choose File System > File System List.

    3. In the top navigation bar, select the resource group and region where your file system resides.image

    4. On the File System List page, find the target file system and choose in the Actions column.

    5. In the Delete File System dialog box, find the mount target that was created by Cloud Shell and click Delete in the Actions column.

      You can hover over the icom icon to confirm whether the mount target is the one that you want to delete.

    6. In the Delete Mount Target dialog box, confirm the information and click OK.

    7. Click Cancel to close the Delete File System dialog box.

  • Delete the mount target from Cloud Shell

    1. Log on to Cloud Shell.

    2. In the top menu bar, choose .

    3. In the Unmount File Storage dialog box, confirm the ID of the file system that you want to unmount.

      • If the mount target was created by the current RAM user, select Current User and click Unmount.

      • If the mount target was created by another RAM user, log on with your Alibaba Cloud account, select RAM User, and then click Unmount.

Delete a mount target created by Cloud Backup

When you use Cloud Backup to back up the resources of a General-purpose NAS file system, Cloud Backup automatically creates a mount target in the file system.

To delete a mount target created by Cloud Backup, use one of the following methods:

Note

Deleting a mount target used for backups will cause subsequent backup jobs to fail.

  • Remove the mount target from the NAS file system

    1. Log on to the NAS console.

    2. In the left-side navigation pane, choose File System > File System List.

    3. In the top navigation bar, select the resource group and region where your file system resides.image

    4. On the File System List page, find the target file system and choose in the Actions column.

    5. In the Delete File System dialog box, find the mount target that was created by Cloud Backup and click Delete in the Actions column.

      You can hover over the icom icon to confirm whether the mount target is the one that you want to delete.

    6. In the Delete Mount Target dialog box, confirm the information and click OK.

    7. Click Cancel to close the Delete File System dialog box.

  • Delete the mount target from the File Backup page

    1. Log on to the NAS console.

    2. In the left-side navigation pane, choose Data Service > File Backup (Cloud Backup Service).

    3. In the top navigation bar, select the resource group and region where your file system resides.image

    4. On the File Backup page, click Manage Mounts.

    5. In the Manage Mounts panel, find the target file system and click Remove Mount Target.

    6. Follow the on-screen instructions in the dialog box and click Confirm to delete the mount target.

Delete a mount target created by PAI

When PAI uses a NAS file system as a dataset for data processing and modeling, it automatically creates a mount target in the file system.

To delete a mount target created by PAI, follow these steps:

  1. Log on to the NAS console.

  2. In the left-side navigation pane, choose File System > File System List.

  3. In the top navigation bar, select the resource group and region where your file system resides.image

  4. On the File System List page, find the target file system and choose in the Actions column.

  5. In the Delete File System dialog box, find the mount target created by PAI and click Delete in the Actions column.

    You can hover over the image icon to confirm whether the mount target is the one that you want to delete.

  6. In the Delete Mount Target dialog box, confirm the information and click OK.

  7. Click Cancel to close the Delete File System dialog box.

View mounted clients

Note

Only General-purpose NAS file systems support this feature.

  1. Log on to the NAS console.

  2. In the left-side navigation pane, choose File System > File System List.

  3. In the top navigation bar, select the resource group and region where your file system resides.image

  4. On the File System List page, click the ID of the target file system, and then click the Mount Targets tab.

  5. In the Mount Targets list, find the target mount target and choose Client List in the Actions column.

    In the Client List dialog box, view the IP addresses of the mounted clients.

    Note

    This list shows only clients that have been active on the NAS file system within the last minute. Clients that are mounted but idle may not appear in this list.

File system deletion and permission groups

No. When you delete a file system, the associated permission group and its rules are not deleted. However, all of its mount targets are deleted. For information about how to delete a permission group, see Manage permission groups.

Warning

After a file system is deleted, its data cannot be recovered. Proceed with caution.

Recover accidentally deleted files

No.

To prevent accidental data loss, enable features such as snapshot, the recycle bin, or Cloud Backup. For more information, see Snapshots, Back up a General-purpose NAS file system, and Recycle bin.

Unable to delete files after mounting

This may be due to insufficient permissions in the permission group or an unsupported account. Make sure that the permission group allows read and write access and that you are logged on as an administrator (for Windows) or as the root user (for Linux).

Unable to create a classic network mount target

Starting from November 21, 2022, you can no longer create classic network-type mount targets for General-purpose NAS file systems. However, existing classic network mount targets can still be used to mount and access file systems.

Unable to delete a file system

You may not have the required permissions to delete the file system.

To delete a file system, a RAM user requires a custom policy. First, grant the RAM user view permissions for all file systems. Then, grant operational permissions, such as delete and modify, for the specific file system you want the user to manage. For more information, see Procedure for granting permissions to a RAM user and Example 1: Grant a RAM user permissions on a file system.

'ENIRamRole.NotAuth' error

  • Cause: The Authorize Extreme NAS and CPFS (AliyunNASManageENIRole) has not been granted.

    When you use an Extreme NAS or CPFS file system, File Storage NAS needs to access resources in other services, such as VPC and ECS. To do this, it uses the AliyunNASManageENIRole role by default.

  • Solution:

    1. Log on to the NAS console.

    2. On the Overview page, click Authorization Management in the References section.

    3. On the Authorize Extreme NAS and CPFS card, click Authorize Now.

    4. On the Cloud Resource Access Authorization page, confirm the role information and click Agree to Authorization.

NAS file system persistence after ECS instance release

Yes. When an ECS instance with a mounted NAS file system is released, the file system and its data are not affected.

CSI plug-in creation fails with the error The specified AZone inventory is insufficient

Symptoms

Creating a file system using the CSI plug-in fails and the following error message is returned:

ErrorCode: InvalidAZone.NotFound
Recommend:
RequestId: xxxxx
Message: The specified AZone inventory is insufficient.

Cause

An invalid availability zone was specified in the parameters.

Solution

Select a different availability zone. You can call the DescribeZones operation in the OpenAPI Developer Portal to retrieve a list of all availability zones in the target region and the file system types they support.

Alternatively, you can create the file system directly in the NAS console. For more information, see Create a file system.

Quickly delete large amounts of data

To delete non-nested subdirectories in parallel, open multiple terminal sessions, navigate to the NAS mount directory (for example, /mnt), and run the rm -rf command on each non-nested subdirectory.

Command hangs after file system deletion

Comment out the NAS configuration in the /etc/fstab file and then restart the server.

To prevent this issue from recurring, always unmount the file system in the operating system before you delete the file system in the console. If you configured auto-mounting, you must also remove or disable the corresponding configuration. For more information, see Unmount a mount directory from the NAS console, Unmount a mount directory by running commands, and Delete a file system.

Note

Restart the server only during a permitted maintenance window.

Data retention after a NAS resource is released

No. After you successfully release a NAS resource, your data is immediately deleted. Alibaba Cloud does not retain your deleted data. For more information, see File Storage NAS Service Level Agreement (SLA).

If a service is suspended due to an overdue payment, data in a General-purpose NAS file system is retained for 15 days, and data in an Extreme NAS file system is also retained for 15 days. If you do not pay the outstanding amount within this retention period, you are deemed to have voluntarily abandoned the NAS service. Alibaba Cloud will then terminate the service agreement, stop providing the service, and delete all your stored data. The data cannot be recovered after it is deleted. For more information, see Overdue payments.

View the throughput of an Extreme NAS file system

  1. Log on to the NAS console.

  2. In the left-side navigation pane, choose File System > File System List.

  3. In the top navigation bar, select a region.

  4. On the File System List page, click the ID of the target file system.

  5. On the Basic Information tab, check the throughput of the file system based on its Maximum Capacity and Bandwidth. For more information about the bandwidth of different Extreme NAS specifications, see Performance metrics.