Public error codes

Updated at:

Error codes

HTTP status code

Error code

Error message

Description

Action

400 AccountTypeRestricted Please submit the application for beta testing first. You can activate the product after the application is approved. Submit a public preview application first and wait for approval before activation.
400 AddSecurityGroupNotSupportWhenHaveNoSg The specified haven not security group endpoint add security group is not supported. A security group cannot be added when no security group exists.
400 AlbExist The specified Alb already exists. The ALB instance already exists.
400 AlbNotFound The specified Alb does not exist. The ALI load balancing instance does not exist.
400 AliCroupCloudUserCanNotBuyNotInnerCommodity The privatelink_ postpay_ public_ Intl does not have a group cloud product label and is not allowed for internal group users to purchase. The privatelink_postpay_public_intl product does not have a group cloud migration commodity tag. Internal group users are not allowed to purchase this product.
400 CheckServiceLinkRoleError Failed to check the service linked role. Failed to check the service-linked role.
400 CheckServiceLinkRoleError The ServiceLink role check error. The service-linked role validation failed.
400 ConcurrentCallNotSupported The operation conflicts with other operations. Please try again later. A concurrent operation conflict occurred.
400 Conflict.ServiceName The ServiceName %s is conflict. The service name %s conflicts with an existing service name.
500 CreateOrderFailed The system is busy. Please try again later. The system is busy. Try again later.
400 CSS_CREATE_ORDER_ERROR create order error. Failed to activate the product or create the order.
400 DeleteFailedDueToEndpointExist The specified EndpointService id deleted failed , due to EndpointExist. The endpoint has not been deleted.
400 DependencyViolation.PrivateDnsName The specified resource of %s depends on %s, so the operation cannot be completed. The resource %s depends on %s, which prevents the operation from being completed.
400 DryRunOperation The specified operation is a dry run operation. The dry run for the current operation succeeded.
400 DuplicatedSecurityGroupId The specified SecurityGroupId.%s %s is duplicated. The SecurityGroupId parameter is duplicate.
400 DuplicatedTagKey The tag keys is duplicated. The tag key is duplicate.
400 EndpointAssociatedVpc The endpoint is associated with a vpc. The endpoint is already associated with a VPC. Delete the route entries of the endpoint first.
400 EndpointConnectionNotFound The specified endpoint connection does not exist. The endpoint connection was not found.
400 EndpointConnectionOperationDenied The endpoint is being connected. The endpoint connection is being processed. Operations are not allowed.
400 EndpointDependenceViolation The specified endpoint has dependent zone(s). The endpoint contains zones and cannot be deleted.
400 EndpointDuplicated The endpoint of the service already exists and cannot be created again. An endpoint for this service already exists. Do not create it again.
400 EndpointExist The specified Endpoint already exists. The endpoint already exists.
400 EndpointHasNotChanged endpoint has nothing changed. No changes were made to the endpoint.
400 EndpointLocked The specified Endpoint is locked. The endpoint is locked.
400 EndpointMustContainSecurityGroup The specified endpoint must have at least one security group. The endpoint must be associated with at least one security group.
400 EndpointNotFound The specified Endpoint does not exist. The endpoint was not found.
400 EndpointOperationDenied The specified operation of endpoint is not allowed. The endpoint is being processed. Operations are not allowed.
400 EndpointProtected The specified Endpoint is protected. Deletion protection is already enabled for the endpoint.
400 EndpointServiceConnectionDependence You cannot delete EndpointService with Endpoint connected. An endpoint service that has associated endpoints cannot be deleted.
400 EndpointServiceConnectionDependence There are connections between the endpoint service and the dualstack endpoint, the endpoint service address ip version not support switching from dualstack to ipv4. A connection exists between the endpoint service and a dual-stack endpoint. Switching from dual-stack to single-stack is not supported.
400 EndpointServiceConnectResourceNotSupport The service is not support connect resource. The endpoint service does not support connections.
400 EndpointServiceDeleted The specified Service is already deleted. The endpoint service has been deleted.
400 EndpointServiceDependenceViolation The specified EndpointService already contains a resource. The endpoint service has associated resources.
400 EndpointServiceDowngradeNotAllowed The EndpointService is not allowed for downgrade. The endpoint service does not allow downgrade.
400 EndpointServiceExist The specified Endpoint Service already exists. The endpoint service already exists.
400 EndpointServiceIsNotAuthorized The specified endpoint service %s is not authorized to user %d. The endpoint service has not authorized this user for access.
400 EndpointServiceLocked The specified Service is locked. The endpoint service is locked.
400 EndpointServiceNotAuthorized The specified endpoint service is not authorized to user. The endpoint service has not been authorized to the user.
400 EndpointServiceNotFound The specified Service does not exist. The endpoint service does not exist.
400 EndpointServiceNotSupportedZone The specified endpoint service does not support the zone. The endpoint service does not support the current zone.
400 EndpointServiceNotSupportIpv6 The param supportIpv6 of EndpointService is forbidden , resource is not support ipv6. The endpoint service does not support IPv6.
400 EndpointServiceOperationDenied The specified operation of endpoint service is not allowed. The endpoint service is being processed. Operations are not allowed.
400 EndpointServicePayerForbidden The param Payer of EndpointService is forbidden, user is not in the whitelist. The billing type of the endpoint service is not in the whitelist.
400 EndpointServicePayerForbidden The parameter EndpointServicePayer is forbidden. The user is not in the whitelist. The billing type of the endpoint service is not in the whitelist.
400 EndpointServiceResourceCannotRemove The service resource cannot be removed. The service resource cannot be removed.
400 EndpointServiceResourceExist The specified resource already exists. The resource already exists under the endpoint service. Do not add it again.
400 EndpointServiceResourceNotFound The specified service resource is not found. The endpoint service resource was not found.
400 EndpointServiceResourceTypeMismatch the service resource type not match request type. The service resource type does not match the request type.
400 EndpointServiceResourceTypeNotEqual the service resource type not equal request type. The resourceType in the request does not match the service type.
400 EndpointServiceResourceTypeNotSupport The specified resource type is not supported. The service resource type of the endpoint service is not supported.
400 EndpointZoneDuplicated The zone is duplicated for the Endpoint. Duplicate zones are not allowed under the endpoint service.
400 EndpointZoneExist The specified zone of Endpoint already exists. The zone already exists under the endpoint. Do not add it again.
400 EndpointZoneNotFound The specified zone of Endpoint does not exist. The zone under the endpoint was not found.
400 EniIpUnavailable The specified IP address is unavailable. The specified IP address is unavailable.
400 GatewayLoadBalancerNotSupportSecurityGroup The gateway load balancer not support security group. The Gateway Load Balancer type does not support configuring security groups.
400 GatewayLoadBalancerNotSupportZoneConnection The gateway load balancer not support zone connection. The Gateway Load Balancer (GWLB) type does not support zone connection operations.
400 GatewayLoadBalancerZoneCountDeny The GatewayLoadBalancer zone count not support The number of zones does not meet the limit. The operation cannot be performed.
400 GenerateInstanceIdFailed The system is busy. Please try again later. The system is busy. Try again later.
400 GenerateResourceIdFailed Failed to generate ResourceId. Failed to generate a resource ID.
400 IdempotenceSignatureMismatch There is an idempotence signature mismatch between this and the previous request. The idempotency signature does not match the most recent request.
400 IllegalParam.%s The specified parameter %s is invalid. The parameter %s is invalid.
400 IllegalParam.AddressIpVersion The specified parameter AddressIpVersion is invalid. The specified AddressIpVersion parameter does not meet the requirements.
400 IllegalParam.Ip The specified parameter IP is invalid. The specified IP address format does not meet the requirements.
400 IllegalParam.Ipv6Address The specified parameter Ipv6Address is invalid. The specified IPv6 address format does not meet the requirements.
400 IllegalParam.ResourceAllocateMode The param of ResourceAllocateMode is illegal. The parameter ResourceAllocateMode is invalid.
400 IllegalParam.ResourceReplaceMode The param of ResourceReplaceMode is illegal. The parameter ResourceReplaceMode is invalid.
400 IllegalParamFormat.%s The param format of %s is illegal. The format of the specified %s is invalid. Check the parameter constraints and try again.
400 IllegalParamLength.%s The param length of %s is illegal. The length of the specified %s is invalid. Check the parameter constraints and try again.
400 IllegalParamSize.%s The param size of %s is illegal. The size of the specified %s is invalid. Check the parameter constraints and try again.
400 IllegalTagKeyParam IllegalTagKeyParam IllegalTagKeyParam
400 IllegalTagScopeParam The tag scope is Illegal. The tag scope is Illegal.
400 IllegalTagValueParam The tag value is Illegal. The tag value is Illegal.
400 IncorrectPrivateServiceDomainVerifyState The custom domain name has not passed the verification. The custom service domain name has not been verified.
400 IncorrectResultSizeDataAccessException incorrect result size data access. An incorrect result was returned.
500 InternalError The request processing has failed due to some unknown error. An internal system error occurred. Try again.
400 InvalidAcceptLanguage.NotFound The specified AcceptLanguage (%s) is invalid. Valid values are (zh-CN), (en-US), (ja) . Only Chinese (zh-CN), English (en-US), and Japanese (ja) are allowed. The AcceptLanguage parameter is invalid. Valid values: [ zh-CN, en-US, ja ].
400 InvalidAccountStatus.NotEnoughBalance Your account does not have enough balance. Your account balance is insufficient.
400 InvalidEndpointId.NotFound The specified EndpointId %s does not exist. The parameter EndpointId is invalid.
400 InvalidParam.%s The param of %s is invalid. The parameter %s is invalid.
400 InvalidParam.PolicyDocument The parameter of %s is invalid. The parameter %s is invalid.
400 InvalidParam.PrivateDnsEnabled The parameter of %s is invalid. The parameter %s is invalid.
400 InvalidParam.PrivateDnsName The param of %s is invalid. The parameter %s is invalid.
400 InvalidPermissionType.NotFound The specified PermissionType %s is invalid. Valid values are %s. The parameter PermissionType is invalid.
400 InvalidResourceId.NotFound The specified ResourceIds are not found in our records. The specified ResourceIds are not found in our records.
400 InvalidServiceId.NotFound The specified ServiceId %s does not exist. The ServiceId parameter is invalid.
400 InvalidServiceName.NotFound The specified ServiceName %s does not exist. The ServiceName parameter is invalid or does not exist.
400 InvalidStatus.NotFound The specified Status %s is invalid. Valid values are %s. The Status parameter is invalid.
400 LoadBalancerHaveNotPrivateLink The specified slb does not have support privateLink field. The SLB is missing the supportPrivateLink field.
400 LoadBalancerNotFound The specified load balancer does not exist. The load balancing instance does not exist.
400 LoadBalancerNotSupportPrivateLink The specified SLB does not support PrivateLink. The current load balancing instance does not support PrivateLink.
400 Mismatch.ResourceType The %s is mismatched for %s and %s. %s does not match between %s and %s.
400 Mismatch.UserIdAndUserArn The %s and %s are mismatched. The parameters %s and %s do not match.
400 MissingParam.%s You must specify the parameter %s. The %s parameter is not provided.
400 MissingParam.%s The param of %s is missing. The %s parameter is missing.
400 MissingParam.ResourceAllocateMode The param of %s is missing. The ResourceAllocateMode parameter is missing.
400 MissingParam.ResourceId The param of %s is missing. The ResourceId parameter is missing.
400 MissingParam.UserArn The param of UserArn is missing. The UserArn parameter is missing.
400 MissingResourceIdOrTagParam The resource id and tag is empty. The resource id and tag is empty.
400 MissingTagKeyParam The tag key is empty. The tag key is empty.
400 MissingTagValueParam The tag value is empty. The tag value is empty.
400 NeedOpenProduct The product is not activated. The service has not been activated.
400 NlbNotSupportServiceResourceReplace The specified nlb is not support service resource replace. NLB-type resources do not support EPS resource scheduling.
400 NoOperationPermission You are not authorized to perform the operation. You are not authorized to perform this operation.
400 NoPermission You are not authorized to access the specified API operation. You do not have the permission to perform this operation.
400 OperationDenied.AddressIpVersionNotSupportSpecifyIpv6 The AddressIpVersion of the endpoint does not support specifying IPv6 address. The AddressIpVersion of the endpoint does not support specifying an IPv6 address.
400 OperationDenied.CurrentResourceAutoAllocated The operation is not allowed because of CurrentResourceAutoAllocated. The operation is rejected because automatic allocation of EPS resource has not been disabled for the current zone resource.
400 OperationDenied.EndpointPolicyNotSupport The operation is not allowed because of EndpointPolicyNotSupport. The operation is not allowed because the endpoint policy is not supported.
400 OperationDenied.EndpointProtected The operation is not allowed because of EndpointProtected. The endpoint has managed protection enabled. The operation is not allowed.
400 OperationDenied.EndpointServiceNotSupportDualstack The specified endpoint service does not support dualstack. The endpoint service does not support dual-stack.
400 OperationDenied.EndpointTypeNotSupportDualstack The specified endpoint type does not support dualstack, only the Interface and GatewayLoadBalancer types support dual stack. The endpoint type does not support dual-stack. Only Interface and GatewayLoadBalancer types support dual-stack.
400 OperationDenied.NoAvailableServiceResource The operation is not allowed because of no available resource in some zones of vpc-endpoint-service. The operation is not allowed because some zones of the endpoint service do not have resources.
400 OperationDenied.NoAvailableServiceResource The operation is not allowed because of there are no resource in some available zones of endpoint service. The operation is not allowed because some zones of the endpoint service do not have resources.
400 OperationDenied.NotSupportDualStackSwitchToIpv4 AddressIpVersion does not support switching from DualStack to IPv4. The AddressIpVersion of the endpoint does not support switching from dual-stack to single-stack.
400 OperationDenied.PrivateDomainNotSupport The operation is not allowed because of PrivateDomainNotSupport. The operation is not supported due to %s.
400 OperationDenied.PrivateDomainStatusNotSupport The operation is not allowed because of %s. The operation is not supported due to %s.
400 OperationDenied.RamPolicyNotSupport The operation is not allowed because of RamPolicyNotSupport. The operation is not allowed because RAM policies are not supported.
400 OperationDenied.ResourceTypeNotSupportDualStack The specified resource type does not support dualstack. The backend resource type of the service does not support dual-stack.
400 OperationDenied.ServiceResourceIpVersionMismatch The endpoint service and service resource AddressIpVersion do not match. The AddressIpVersion of the endpoint service does not match the backend resource.
400 OperationDenied.VSwitchNotSupportDualstack The specified VSwitch does not support dualstack. The vSwitch does not support dual-stack.
400 OperationDenied.ZoneAffinityNotSupport The operation is not allowed because of zone affinity not support. The operation is not allowed because domain name-based nearest access is not supported.
400 OrderOpend You have already activated the service. Go to the console to start using it. The service has already been activated. Go to the console to use it.
400 ParamDescriptionInvalid The specified Description is invalid. The Description parameter is invalid.
400 ParamEndpointIdInvalid The specified EndpointId is invalid. The parameter EndpointId is invalid.
400 ParamEndpointNameInvalid The specified EndpointName is invalid. The EndpointName parameter is invalid.
400 ParamSecurityGroupIdInvalid The specified SecurityGroupId%s is invalid. The SecurityGroupId parameter is invalid.
400 ParamServiceIdInvalid The specified ServiceId is invalid. The ServiceId parameter is invalid.
400 ParamServiceNameInvalid The specified ServiceName is invalid. The ServiceName parameter is invalid.
400 ParamVpcIdInvalid The specified VpcId is invalid. The VpcId parameter is invalid.
400 ParamVSwitchIdInvalid The specified VSwitchId is invalid. The VSwitchId parameter is invalid.
400 PrivateDomainAlreadyExistsInTheVpc The custom domain name already exists in the VPC. A custom domain name with the same name already exists in this VPC.
400 QuotaExceed.TagsPerResource The maximum number of tags for each resource is exceeded The maximum number of tags for each resource is exceeded
400 QuotaExceeded.epZonePerEndpoint The quota of %s is exceeded, usage %s/%s. The number of zones for a single endpoint has reached the limit.
400 QuotaExceeded.totalEpPerVpc The quota of %s is exceeded, usage %s/%s. The number of VPC endpoints for a single VPC has reached the quota limit.
400 QuotaExceeded.totalIdleEndpoint The quota of %s is exceeded, usage %s/%s. The total number of idle unconnected endpoints has reached the limit.
400 QuotaMisMatched The resource you applied for has exceeded the quota. The requested resources exceed the quota.
400 RegionNotFound The specified Region is not found. The current product does not support this region.
400 ResourceAutoAllocateViolation The specified endpoint service must have at least one automatically allocated resource in one zone. A zone must contain at least one resource that can be automatically allocated.
400 ResourceNotEnough.VSwitchIp The specified resource of VSwitchIp is not enough. The number of available IP addresses in the vSwitch is insufficient.
404 ResourceNotFound.ALB The specified resource of %s is not found. The resource %s does not exist.
400 SecurityGroupExist The specified security group already exists. The security group already exists.
400 SecurityGroupNotFound The specified security group does not exist. The security group was not found.
400 SecurityGroupTypeNotSupport The specified security group type is not supported. The security group type is not supported.
400 SecurityGroupTypeOnlySingleTypeSupporteded The specified security group only support one type. A security group supports only one type.
400 ServiceResourceNotSupportDowngrade The service is not support downgrade. Downgrading endpoint service resources is not supported.
400 ServiceResourceNotSupportIpv6 The resource is not support ipv6. The endpoint service does not support IPv6.
400 SpecifiedAlbNotSupport The specified alb %s is not supported. The specified ALB instance is not supported.
400 SystemBusy System is busy. Please try again later. The system is busy. Try again later.
400 TagInfoNotExist Tag info not exist The tag information does not exist.
400 TagPermissionDenied Tag Permission Denied Tag Permission Denied
400 UnsupportedFeature.PrivateDnsName The feature of %s is not supported. The feature %s is not supported.
400 UnsupportedFeature.VpcNat The feature of VpcNat is not supported. The VpcNat type is not supported.
400 UpdateBandWidthUnSupported Bandwidth updates are not supported for this service. Updating bandwidth is not allowed for this service.
400 UserARNNotEqualUserId The userARN is not equal userId. When UserId is not empty, userARN must be equal to userId.
400 UserIdAndUserARNEmpty The userId and userARN is empty. Both UserId and UserARN are empty.
400 VpcNatServiceException vpcNat Service Exception The VPC NAT service is abnormal.
400 VpcNatServiceException The vpcNat service is busy The VPC NAT service is busy. Try again later.
400 VpcNotFound The specified VPC does not exist. The VPC was not found.
400 VpcTunnelNotFound The specified VPC tunnel does not exist. The VPC channel was not found.
400 VSwitchNotFound The specified vSwitch does not exist. The vSwitch was not found.
400 VSwitchStatusNotAllowed The specified vswitch status is not Available. The vSwitch is not yet available.
400 ZoneIdNotSupportedByEndpointService The specified NetworkInterface.%s.ZoneId %s is not supported by endpoint service %s. Available Zones are %s. The value specified for the NetworkInterface.N.ZoneId parameter is not in the zones supported by the endpoint service.
400 ZoneIdNotSupportedByPrivateLink The specified Resource.%s.ZoneId %s is not supported by PrivateLink service. Available Zones are %s. The PrivateLink service does not support the zone specified by the Resource.N.ZoneId parameter.
400 ZoneOperationDenied You cannot operate the specified zone. Operations are not allowed in this zone.
400 IncorrectStatus.ResourceConfiguration The specified resource configuration status is invalid. The configuration status of the corresponding resource is invalid.
400 IncorrectStatus.ResourceGateway The specified resource gateway status is invalid. The specified resource gateway status is invalid.