Activate the WeCom mini program

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Quick BI provides a WeCom mini program that lets WeCom users view reports on their mobile devices. A WeCom administrator can activate this mini program for their enterprise. Once employees bind their accounts to the mini program or are added to the Quick BI organization, they can view reports in the WeCom mobile client. This topic explains how to activate the WeCom mini program and authorize its interface in Quick BI.

Prerequisites

You are an administrator of your WeCom organization and have the WeCom client installed and registered.

Limitations

Quick BI Professional Edition allows you to authorize up to five WeCom enterprises. This feature is useful when your organization consists of multiple independent entities, such as subsidiaries or branches, that need to access the same Quick BI instance.

Procedure

On the WeCom interface authorization page, click Add Authorization. In the Add New Authorization dialog box, follow these steps.

Step 1: Activate the Quick BI mini program

Install the Quick BI mini program in the WeCom mobile client.

  1. Open your WeCom mobile client and scan the QR code in the Add New Authorization dialog box.

  2. On the App Details page, click Add App to complete the installation.

Step 2: Authorize the WeCom API

After the mini program is installed, click Next in the Add New Authorization dialog box to proceed from the Scan to Activate step to the Enter CorpId step.

  1. Obtain your enterprise CorpId

    Log on to the WeCom Service Provider admin console. On the Service Provider Info page, copy your enterprise's CorpId.

  2. Enter the CorpId

    In the Add New Authorization dialog box, paste the copied CorpId into the CorpId field and click Verify. The system automatically identifies and displays your enterprise name.

  3. After you confirm that the organization is correct, click Next to authorize the new enterprise.

    This binds the WeCom enterprise with the specified CorpId to your Quick BI organization. You can click Go to User Management to go to the Member Management page and sync members from the enterprise. For detailed instructions, see Add a WeCom User.

Step 3: Configure the mini program

Note

Accounts synced from office software such as DingTalk, WeCom, or Lark can create and edit reports in the mini program on the PC client if they have edit permissions.

The default open method for the mini program is Workbench. You can change this setting to Open in Browser as needed.

Note

This configuration only affects how the mini program opens on the PC client.

  • When the open method is set to Workbench, you can view and edit reports within the workbench.

  • When the open method is set to Open in Browser, clicking the mini program opens your browser to view and edit reports.

Next steps

After authorizing an enterprise, you can also edit or revoke the authorization, and sync WeCom members.

Revoke authorization for an enterprise

Click the image icon next to the enterprise card, and then click Revoke Authorization in the confirmation dialog box to unbind the enterprise.

Sync WeCom members

In the Add User section, use the Sync from Office Software option to add WeCom users.

Bind a WeCom account

Once the WeCom interface is authorized, users can bind their accounts in Personal Settings by using the Bind WeCom account option to scan a QR code.

Organization administrators can bind WeCom accounts for other users in member management.

FAQ

Problem

A user clicks the Quick BI application in WeCom and receives the following error:

Cause

This error occurs because your organization has exceeded its WeCom license quota. As a third-party service provider, Quick BI provisions a number of WeCom licenses equal to the number of licenses in your Quick BI organization. Each login consumes one license. Once this limit is reached, other users cannot log in and will see this error.

Solution

  • Solution 1: In the WeCom admin console, navigate to App Management > Apps > Third-party. Select and edit the Quick BI mini program. Modify the "Visibility Scope" to remove unnecessary accounts. Ensure that the number of users in the visibility scope does not exceed the number of WeCom accounts in your Quick BI organization.

  • Solution 2: In your Quick BI organization, navigate to Organization Management > User Management > Member Management. Add the WeCom member who is unable to open the mini program to your Quick BI organization.