Self-service connection diagnostics

Updated at:

After you purchase an ApsaraDB RDS instance, you might be unable to connect to it. Most connection failures are due to network connectivity issues. This topic describes how to use the self-service diagnostics tool to troubleshoot these connections over an internal or public network and quickly resolve any problems.

How it works

  • The connection diagnostics tool checks the connectivity from the client to the RDS instance. The connectivity check fails if the client's IP address is not in the instance whitelist.

  • The instance whitelist check supports CIDR blocks. The check passes if the client's IP address falls within a CIDR block in the whitelist.

Usage notes

An ECS instance can connect to an RDS instance over the internal network only if both instances are in the same Virtual Private Cloud (VPC). If the instances are in different VPCs, they cannot connect even if the IP address of the ECS instance is in the whitelist. To enable communication between the two VPCs, you can either switch to the same VPC or use a VPC Peering Connection.

Procedure

  1. Go to the RDS Instances page. In the top navigation bar, select the region where your instance is located, and then click the instance ID.

  2. In the left-side navigation pane, click Database Connection.

  3. In the Connection Troubleshooting section, add the IP address of the client that needs to access the RDS instance. This can be the internal IP address of an ECS instance or the public IP address of an external client:

    • To add an internal IP address: Click the Intranet Troubleshooting tab, and then click Add intranet ECS IP. In the dialog box, select the target ECS instance, move it to the Selected ECS Instances column, and then click OK.

    • To add a public IP address: Click the Extranet Troubleshooting tab, and then click Add Extranet IP. Enter an IP address, or click Load Local Public IP Address (If there is a network proxy on your PC, please turn it off first), and then click OK.

      Note

      This feature can automatically retrieve your public IP address only if your computer is not using a network proxy.

  4. Click Start Check.

    After the check is complete, take the appropriate action based on the result:

    Status

    Actions

    Normal

    No action is required.

    IP Address Not in Whitelist

    In the Action column, click Configure Whitelist to add the IP address to the whitelist.

    Abnormal

    In the Action column, click Create ticket.

Related topics