Public error codes

Updated at:

Error codes

HTTP status code

Error code

Error message

Description

Action

402 AccountArrears Your available balance is negative. Please top up your account before making a purchase. Your account balance is less than 0. Top up your account and try again.
400 AccountNotRealNameAuthenticated Account has not completed real-name authentication. The account has not completed real-name verification.
400 ActiveBranchesExisted Cannot disable branching when active branches exist. Active branches exist. The branch feature cannot be disabled.
409 ApiKeyLimitReached The maximum number of user API keys for this instance has been reached. The number of AccessKey pairs for the instance has reached the upper limit.
409 ApiKeyNameConflict An API key with the same name already exists for this instance. An API key with the same name already exists for the instance.
404 ApiKeyNotFound API key not found or does not belong to the instance given. The API key was not found or does not belong to the specified MO instance ID.
404 ApiKeyNotFound No active apikey found for this instance. The instance does not have an active API key.
409 ApprovalAlreadyDecided The tool approval has already been decided. The tool approval decision has already been made. You cannot repeat this operation.
400 BindingCapacityExceeded The number of bound instances has reached capacity limit. Please unbind first. The number of bound instances has reached the capacity limit. Unbind some instances first.
400 BindingNotFound No active binding found. No valid binding record was found.
400 BranchCountExceeded The number of branches exceeds the maximum allowed limit. The number of branches exceeds the allowed upper limit.
400 BranchDepthExceeded The branch depth exceeds the maximum allowed limit. The branch depth exceeds the allowed upper limit.
400 BranchingAlreadyEnabled Branching is already enabled for this instance. The branch feature is already enabled for the instance.
400 BranchingNotEnabled Branching is not enabled on this instance. The branch feature is not enabled for this instance.
400 BranchingNotEnabled Branching is not enabled for this instance. The branch feature has not been enabled for the instance.
400 BranchInstanceClassInvalid The specified branch instance class is not supported. Allowed: 1C2G, 2C4G, 4C8G, 8C16G. The branch instance specifications are invalid or not supported.
400 BranchInstanceClassInvalid The specified instance class is invalid for branch. The branch instance specifications are invalid or not supported.
400 BranchNotFound The specified branch does not exist. The specified branch does not exist.
403 BranchResourceInsufficient Insufficient resources to create the branch instance. Insufficient resources to create the branch instance.
400 BranchStorageInvalid The specified storage configuration is invalid for branch. The branch storage configuration is invalid.
400 BranchStorageReduceForbidden Branch storage cannot be reduced. Branch storage capacity cannot be scaled down.
400 BranchStorageReduceForbidden Storage reduction is forbidden for branch. Reducing branch storage capacity is not allowed.
400 BranchTemporaryClassChangeForbidden Temporary branches cannot change instance class. Convert to protected first. Temporary branches do not support specification changes. Convert the branch to a protected branch first.
400 BranchTemporaryClassChangeForbidden Temporary class change is forbidden for branch. Temporary specification changes for branches are not allowed.
400 BranchTypeChangeInvalid BranchType only supports changing from temporary to protected. BranchType can only be changed from temporary to protected.
400 BranchTypeChangeInvalid The branch type change is invalid. The branch type change is invalid.
400 ChildBranchesExisted Cannot delete branch with child branches. The branch has child branches and cannot be deleted.
400 CommodityNotPurchasable This account cannot purchase the commodity. The current account cannot purchase this product. Products for enterprise cloud migration are not supported.
451 ContentModeration Content moderation violation. The request contains non-compliant content.
451 Content_Moderation Content Moderation Violation. The content moderation check failed. Check whether the question contains non-compliant content.
404 ContextDbLibraryFileNotFound The ContextDB library file was not found. The ContextDB library file does not exist or the current caller does not have access permissions.
400 ContextDbLibraryFileTooLarge The file exceeds the allowed single-file size limit. A single file exceeds the maximum size allowed by the library.
400 ContextDbLibraryFileTypeNotAllowed The file type is not allowed. The file type is not within the allowed range of the library.
404 ContextDbScheduledTaskNotFound The ContextDB scheduled task was not found. The ContextDB scheduled task does not exist or the current caller does not have access permissions.
404 ContextDbSkillNotFound The ContextDB Skill was not found. The ContextDB Skill does not exist or the current caller does not have access permissions.
404 ContextDbSkillOAuthSessionNotFound The ContextDB Skill OAuth session was not found. The ContextDB Skill OAuth session does not exist or the current caller does not have access permissions.
409 ConversationBusy The conversation is already resuming a tool approval round. The conversation is recovering tool approval. The current request cannot execute concurrently.
404 ConversationNotFound Conversation does not exist. The conversation does not exist.
503 CredentialsNotConfigured Aliyun AK SK credentials are not configured. The Alibaba Cloud AccessKey ID and AccessKey secret are not configured.
503 CredentialsNotConfigured Aliyun AK/SK credentials are not configured. The Alibaba Cloud access credentials are not configured.
409 CustomAgentNameDuplicated A custom agent with the same name already exists. A custom agent with the same name already exists.
404 CustomAgentNotFound The custom agent was not found or is not accessible. The custom agent does not exist or the current user does not have permission to access it.
400 CustomAgentQuotaExceeded The maximum number of custom agents has been reached. The number of custom agents has reached the upper limit.
400 CustomKeyLimitExceededError Custom key limit exceeded. The number of custom keys has exceeded the upper limit.
409 DomainNotReady The instance domain is not ready yet. The instance domain name is not ready for use.
400 DomainNotReadyError Domain is not ready yet, please try again later. The domain name is not ready.
409 FileUploadConflict The uploaded file conflicts with the current request. The uploaded file conflicts with the current request.
403 FileUploadForbidden The uploaded file is not accessible to the current user. The current user does not have permission to access the uploaded file.
400 FileUploadValidationError The uploaded file reference is invalid. The uploaded file reference is invalid.
403 File_upload_forbidden Upload token does not match the upload session. The file upload authentication information does not match. Check whether the file belongs to the corresponding user.
503 GatewayDisabled AI Gateway is not enabled. The AI gateway is not enabled.
400 IdempotentParameterMismatch The request uses the same client token as a previous, but non-identical request. Do not reuse a client token with different requests, unless the requests are identical. The request parameters associated with the same client token are inconsistent.
400 IncorrectInstanceState Current instance status does not support this operation. The current instance status does not support this operation.
409 InstanceConflict The instance already exists and conflicts with the request. The instance already exists and conflicts with this request.
400 InstanceIdRequired instanceId is required and must be non-empty. The instanceId parameter is required and cannot be empty.
404 InstanceNotFound MO Instance not found or does not belong to the uid given. The MO instance was not found, or the MO instance does not belong to this UID.
404 InstanceNotFound MO Instance not found or does not belong to the specified account. The MO instance does not exist or does not belong to the current account.
400 InstanceNotFoundError No active instance found. No active instance was found.
400 InstanceQuotaExceededError Instance quota exceeded, cannot create new API key. The instance quota has been exhausted. A new API key cannot be created.
409 InstanceReleased The instance has been released. Please create with a new instanceId. The instance has been released.
403 InsufficientResourceCapacity There is not enough host resource inventory. Insufficient resources.
500 InternalError An internal error occurred. An internal error occurred.
500 InternalError %s. An internal system error occurred.
500 InternalError System internal exception. An internal system error occurred.
500 InternalError Failed to release postpay instance. The server failed to process the request.
500 InternalError Internal server error. The server failed to process the request.
400 InvalidConfigContent.Format Content does not satisfy the inspection configuration schema or processor catalog. The Content does not conform to the inspection configuration structure, metric catalog, or threshold constraints.
400 InvalidConfigType.Value ConfigType must be template or item. The ConfigType must be template or item.
400 InvalidContextDbLibraryFilename The filename is invalid. The file name is invalid. Check for whitespace, path separators, control characters, and length.
400 InvalidContextDbLibraryFileSize The file size must be a positive integer. The file size must be a positive integer.
400 InvalidDBInstanceStatus DB instance status is not valid. The RDS PostgreSQL instance status is invalid.
400 InvalidEndTime.Format EndTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ. The EndTime must be in UTC format YYYY-MM-DDTHH:MM:SSZ.
400 InvalidFrequency.Value Frequency is not a supported inspection schedule. The Frequency is not a supported inspection execution frequency.
400 InvalidGroupName Specified group name is not valid. The group name is invalid.
400 InvalidHttpHeaderNameError Header names must contain only alphanumeric characters (a-z, 0-9) and hyphens (-), and must not start or end with a hyphen. The request header name format is invalid.
400 InvalidImageDimensions The image is invalid, or its dimensions are not supported. The image cannot be decoded, the content type does not match, or either the width or height is not greater than 10 pixels.
400 InvalidInspectionConfig.Value An inspection configuration parameter is invalid. The inspection configuration parameter is invalid.
400 InvalidInstance.NotFound Specified instance does not exist. The specified instance does not exist.
400 InvalidInstanceIds.Value InstanceIds is invalid or does not match the selected template engine. The InstanceIds are invalid or do not match the selected template engine.
400 InvalidIpWhitelistError Invalid IP address or CIDR in whitelist. The IP address or CIDR block in the whitelist is invalid.
400 InvalidModelId The requested model is not available. The specified model is not within the currently supported range. Check whether the ModelId is correct.
400 InvalidOrder No valid order found, please check whether RDS Copilot Professional Edition has been activated and ensure that the order is valid. No valid order exists. Check whether the RDS AI Assistant Professional Edition is activated and the order is valid.
400 InvalidPageParamError Invalid pagination parameter. Page must be at least 1, and pageSize must be between 1 and 100. The pagination parameter is invalid.
400 InvalidPagination.Value PageNumber or PageSize is outside the supported range. The PageNumber or PageSize is out of the supported range.
400 InvalidParam The provided parameter is invalid. The parameter is invalid.
400 InvalidParameter The request contains an invalid or missing parameter. The request contains incorrect parameters or is missing required parameters.
400 InvalidParameter %s. Request parameter validation failed. See the response message for details.
400 InvalidParameter Request parameter validation failed. Request parameter validation failed.
400 InvalidParameter The provided parameter is invalid. The parameter is invalid.
400 InvalidParameter Request parameter is invalid. The request parameter is invalid.
400 InvalidQuantityError Invalid quantity: must be an integer between 1 and 50. The quantity must be an integer between 1 and 50.
400 InvalidQuotaValueError LimitType must be fixed or ratio. TokenQuota must be a positive integer and limitRate must be between 0.0 and 1.0. The key quota parameter is invalid.
400 InvalidQuotaValueError Keys quota setting is not correct. The key quota parameter is invalid.
400 InvalidRegionId.Format RegionId is invalid for this inspection request. The RegionId format is invalid. This parameter is not required for the default instance inspection process.
400 InvalidReportLanguage.Value ReportLanguage is not supported. ReportLanguage only supports zh-CN, en-US, ja-JP, or zh-TW.
400 InvalidReportParameter.Value An inspection report parameter is invalid. The inspection report parameter is invalid.
400 InvalidRequest.Format The request body must be a non-empty JSON object. The request body must be a non-empty JSON object.
400 InvalidScheduledId.Format ScheduledId must be a non-empty scheduled inspection identifier. ScheduledId must be a non-empty identifier of a scheduled inspection task.
400 InvalidScheduledStartTime.Format The scheduled start time must use the UTC format HH:mm:ssZ. The StartTime or TaskStartTime for scheduled inspection must use the UTC format HH:mm:ssZ.
400 InvalidSessionIdHeaderTypeError SessionIds must be a list of strings. SessionIds must be a list of strings.
400 InvalidSessionIdHeaderValueError SessionIds contains invalid value. SessionIds contains invalid values.
400 InvalidStartTime.Format StartTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ. StartTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ.
400 InvalidTaskId.Format TaskId must be a non-empty inspection task identifier. TaskId must be a non-empty identifier of an inspection task.
400 InvalidTaskParameter.Value An inspection task identifier is invalid. The inspection task identifier parameter is invalid.
400 InvalidTemplate.Value TemplateId is missing, inaccessible, or incompatible with the target instances. The TemplateId is missing, inaccessible, or incompatible with the target instance.
400 InvalidTimeParameter.Value An inspection time or frequency parameter is invalid. The inspection time or execution frequency parameter is invalid.
400 InvalidTimeRange.Value StartTime must be earlier than EndTime. StartTime must be earlier than EndTime.
400 InvalidTimeRangeHours.Value TimeRange must be an integer from 1 to 168 hours. TimeRange must be an integer from 1 to 168, in hours.
400 InvalidToolApprovalCursor Invalid tool approval cursor. The tool approval cursor parameter value is invalid.
422 InvalidToolApprovalMode Invalid ToolApprovalMode value. The ToolApprovalMode parameter value is invalid.
400 InvalidUserIdentity.Missing The authenticated caller identity is missing. The authenticated caller identity information is missing.
403 InvalidUserOrder There is no valid order for this UID. No valid order exists for this UID.
400 InvalidWorkspaceId.Conflict The request contains conflicting WorkspaceId values. The WorkspaceId values provided in the request conflict with each other. Make sure the workspace identifiers are consistent across all locations in the request and try again.
400 InvalidWorkspaceId.Missing WorkspaceId is required for the ContextDB management App. A WorkspaceId is required when managing applications with ContextDB. Specify the ContextDB workspace for this request and try again.
400 InvalidWorkspaceId.Value WorkspaceId is invalid. The WorkspaceId is invalid. Check the workspace identifier, specify a valid ContextDB WorkspaceId, and try again.
400 InvokeError %s. %s.
400 LibraryFileTooLarge The file exceeds the ContextDB Library file size limit. The file exceeds the maximum single file size limit of the ContextDB Library.
400 MasterInstanceNotExist Master instance does not exist. The primary instance does not exist.
404 MessageNotFound Message does not exist. The message does not exist.
503 MetaDBNotConfigured AI Gateway metadb is not configured (METADB DSN is empty). The AI gateway metadata database is not ready.
503 MetaDBNotConfigured AI Gateway metadb is not configured. The metadb connection setting is empty. The AI gateway metadata database is not configured.
405 MethodNotAllowed The HTTP method is not allowed for this resource. The HTTP method for the request to this resource is incorrect.
400 MissingBranchName The request is missing the BranchName parameter. The request is missing the BranchName parameter.
400 MissingInstanceName The request is missing the InstanceName parameter. The request is missing the InstanceName parameter.
400 MissingParameter A required inspection parameter is missing. The required inspection parameters are missing.
400 MissingParentBranchName The request is missing the ParentBranchName parameter. The ParentBranchName parameter is missing.
400 MissingServiceLinkedRole %s. The service-linked role authorization is missing.
400 MissingSourceBranch The request is missing the SourceBranchName parameter. The request is missing the SourceBranchName parameter.
400 MissingTargetBranch The request is missing the TargetBranch parameter. The request is missing the TargetBranch parameter.
404 MoApiKeyNotFoundError The specified API key was not found or has been disabled. The specified API key does not exist or has been disabled.
503 MoColdPathQueryFailedError Cold path usage detail query failed. Failed to query the usage details of historical archiving.
404 MoConsumerNotFoundError No active consumer found for this instance. The instance does not have any active consumers.
400 MoContentSafetyNotEnabledError AI content safety (AiSecurityGuard) is not enabled on the gateway. Please enable it in the console first. The AI content security feature has not been enabled on the gateway.
500 MoCredentialNotConfiguredError Server credentials are not configured. The server-side credentials are not configured.
400 ModelNotSupportVision The requested model does not support image input. The specified model does not support image input. Select a model that supports visual capabilities or remove the image.
403 ModelSelectionRequiresPaidOrder Selecting a non-default model requires a valid paid order. A valid paid order is required to select a non-default model.
400 ModifyBranchNoChange At least one property (BranchType, DBInstanceClass, DBInstanceStorage) must be specified. At least one attribute must be specified for modification: BranchType, DBInstanceClass, or DBInstanceStorage.
400 ModifyBranchNoChange No changes were made to the branch configuration. The branch configuration has not changed.
400 MoDomainNotReadyError Domain is not ready yet, please try again later. The domain name is not ready.
400 MoExportBeforeRetentionError Usage detail export is earlier than RDS retention and archive query is not enabled. The export start time exceeds the retention period and archive query is not enabled.
400 MoExportInProgressError Previous usage detail export task is still in progress, please wait for it to complete. The previous usage detail export task is still running.
429 MoExportQueueFullError Usage detail export queue is full, please try again later. The usage detail export queue is full.
400 MoExportTimeRangeInvalidError endTime must be greater than startTime. The end time must be later than the start time.
400 MoExportTimeRangeTooLargeError Export time range must be within 7 days. The export time range cannot exceed 7 days.
400 MoExportTimeRequiredError startTime and endTime are required. The start time and end time are required.
400 MoInstanceIdRequiredError instanceId is required. The instanceId parameter is missing.
404 MoInstanceMappingNotFoundError No active instance mapping found. No active instance mapping exists.
400 MoInvalidApiKeysError ApiKeys parameter is missing, empty, or contains invalid elements. The ApiKeys parameter is missing, empty, or contains invalid elements.
400 MoInvalidBatchItemsError Items parameter is missing, empty, or has invalid format. The Items parameter is missing, empty, or in an invalid format.
400 MoInvalidIpWhitelistError Invalid IP address or CIDR in whitelist. The IP address or CIDR block in the whitelist is invalid.
400 MoInvalidSafetyDimensionError Invalid safety dimension type. Valid types: Global, ContentModeration, PromptAttack, SensitiveData, ModelHallucination, MaliciousUrl. The security detection dimension is invalid.
400 MoInvalidSafetyLevelError Invalid safety level. Valid levels: high, medium, low, observe. The security detection level is invalid.
400 MoInvalidSafetyRulesError Rules parameter is missing or empty. The Rules parameter is missing or empty.
404 MoNoActivePostpayOrderError No active postpay order found for this instance. The instance does not have a valid pay-as-you-go order.
400 MoOverflowPostpayRequiredError Enabling overflow requires an active POSTPAY instance. An active pay-as-you-go instance is required to enable overflow.
400 MoPostpayRatioNotAllowedError Ratio mode is not supported for POSTPAY instances. Use 'fixed' mode instead. Pay-as-you-go instances do not support the proportional quota mode.
400 MoProLikeCustomKeyNotAllowed Custom API keys are not supported for Pro or Enterprise instances. Creating custom keys is not allowed for Professional Edition or Professional Edition (AI Computing) managed objects.
400 MoQueryBeforeRetentionError Usage detail query is earlier than RDS retention and archive query is not enabled. The query time exceeds the retention period and archive query is not enabled.
400 MoQueryRangeTooLargeError Usage detail query time range is too large. The time range for the usage detail query is too large.
429 MoQuotaExceeded The MO token quota of the routed Standard instance has been exhausted and the request is rate limited. Please wait for quota recovery or purchase a capacity pack. The MO token quota of the standard instance that traffic is routing to has been exhausted. Wait for the quota to recover or purchase a capacity plan.
403 NoPermission Permission denied. You do not have the permission to perform this operation.
403 NoPermission Permission denied, %s. Permission denied, %s.
404 NotFound The requested resource was not found. The requested resource was not found.
400 NoValidStandardOrder no valid standard order found or capacity pack is zero. No valid Standard Edition order was found, or the number of standard plans is 0.
400 ParentBranchInvalid The parent branch is invalid. Only protected branches can be used as parent. The parent branch is invalid. Only protected branches are allowed.
409 PendingToolApproval The conversation has pending tool approvals. The conversation has pending tool approvals. Complete all approvals before continuing the conversation.
403 PermissionDenied User has no operation permission. The user does not have the operation permission.
400 PermissionDenied No valid order found or permission denied. No valid order was found, or the permission was denied.
400 PluginConfigInvalidError PluginConfig must be a key/value map (object). PluginConfig must be a key-value object.
400 PluginConfigKeyNotSupportedError PluginConfig contains unsupported key. The plugin configuration contains unsupported keys.
400 PluginConfigValueInvalidError The specified plugin configuration value is invalid. The specified plugin configuration value is invalid.
400 PluginConfigValueOutOfRangeError The specified plugin configuration value is outside the allowed range. The specified plugin configuration value exceeds the allowed range.
400 PluginNameRequiredError PluginName is required. The PluginName parameter is missing.
400 PluginNotFoundError Specified plugin not found on gateway. The specified plugin was not found in the gateway.
400 PluginNotSupportedError Specified pluginName is not supported. The specified plugin name is not supported.
409 PrivateDomainAlreadyBoundError Private domain is already bound to this instance. The private domain name is already bound to this instance.
500 PrivateDomainCreateFailedError Failed to create private domain. Failed to create the private domain name.
400 PrivateDomainCreatingError Private domain is currently creating. The private domain name is being created.
400 QueryDateFormatInvalidError StartTime and endTime must be in YYYY-MM-DD format. The start time and end time must use the YYYY-MM-DD format.
400 QuotaAlertBatchFailedError All quota alert operations failed. All quota alert operations failed.
400 QuotaAlertItemsRequiredError The apikeys parameter must not be empty. The apikeys parameter cannot be empty.
429 QuotaExceeded Resource quota exceeded. The resource creation quota has been exceeded.
409 QuotaInsufficient The requested quota change exceeds the quota available on the system API key. The requested token quota exceeds the remaining token quota of the instance system API key.
400 QuotaSumExceededError Sum of custom key quotas exceeds instance total quota. The total quota of custom keys exceeds the total instance quota.
429 RateLimitError The request was rejected because the invocation rate limit was exceeded. The request was rejected because the call frequency limit was exceeded.
404 RcmInstanceNotFound The specified RDS Custom Model instance was not found. The specified RDS custom model instance does not exist.
400 RcmInvalidParameter Invalid parameter value. The parameter value is invalid.
404 RcmNoValidInstance No valid RDS Custom Model instance found for this user. The current user does not have a valid RDS custom model instance.
400 RdsInstanceIdRequired rdsInstanceId is required and must be non-empty. The rdsInstanceId parameter is required and cannot be empty.
400 RdsInstanceNotFound RDS instance not found or does not belong to the current user. The RDS instance does not exist or does not belong to the current user.
409 ResourceAlreadyExists Resource state conflict. A resource status conflict occurred.
404 ResourceNotFound Resource not found. The specified resource does not exist.
403 SandboxCloudPermissionRoleNotAssumable The specified RAM role cannot be assumed by the service identity. The specified RAM role cannot be assumed by the RDS AI service identity. The sandbox cloud permission configuration was not updated.
404 SandboxCloudPermissionRoleNotFound The specified RAM role does not exist. The specified RAM role does not exist. The sandbox cloud permission configuration was not updated.
404 ScheduledTask.NotFound The specified scheduled inspection task does not exist or is not accessible. The specified scheduled inspection task does not exist, or the current account does not have access to it.
400 SessionIdRequiredError SessionIds is required and must be a non-empty list of strings. SessionIds must be a non-empty list of strings.
400 SessionIdsListTooLargeError SessionIds list exceeds the maximum allowed size (10). The SessionIds list allows a maximum of 10 items.
400 SessionIdsTooLongError SessionIds contains a header name that exceeds the maximum length (64). A request header name in SessionIds exceeds 64 characters.
400 SkillDescriptionRequired Skill description is required. A skill description must be provided.
400 SkillDescriptionTooLong Skill description cannot exceed 1000 characters. The skill description cannot exceed 1000 characters.
402 AccountArrears Your available balance is negative. Please top up your account before making a purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 AccountNotRealNameAuthenticated Account has not completed real-name authentication. Account not completed real name authentication
400 ActiveBranchesExisted Cannot disable branching when active branches exist. Active branches exist. The branch feature cannot be disabled.
409 ApiKeyLimitReached The maximum number of user API keys for this instance has been reached. the number of instances ak reaches the upper limit
409 ApiKeyNameConflict An API key with the same name already exists for this instance. An API key with the same name already exists for the instance.
404 ApiKeyNotFound API key not found or does not belong to the instance given. The api key is not found or does not belong to the given MO instance id.
404 ApiKeyNotFound No active apikey found for this instance. The instance does not have an active API key.
409 ApprovalAlreadyDecided The tool approval has already been decided. The tool approval decision has already been made. Do not repeat the operation.
400 BindingCapacityExceeded The number of bound instances has reached capacity limit. Please unbind first. The number of bound instances has reached the maximum capacity. Please unbind them first.
400 BindingNotFound No active binding found. No active binding found.
400 BranchCountExceeded The number of branches exceeds the maximum allowed limit. The number of branches exceeds the allowed upper limit.
400 BranchDepthExceeded The branch depth exceeds the maximum allowed limit. The branch depth exceeds the allowed upper limit.
400 BranchingAlreadyEnabled Branching is already enabled for this instance. The branch feature is already enabled for the instance.
400 BranchingNotEnabled Branching is not enabled on this instance. The branch function is not turned on for this instance.
400 BranchingNotEnabled Branching is not enabled for this instance. The branch feature has not been enabled for the instance.
400 BranchInstanceClassInvalid The specified branch instance class is not supported. Allowed: 1C2G, 2C4G, 4C8G, 8C16G. The branch instance specification is invalid or not supported.
400 BranchInstanceClassInvalid The specified instance class is invalid for branch. The branch instance specification is invalid or not supported.
400 BranchNotFound The specified branch does not exist. The specified branch does not exist.
403 BranchResourceInsufficient Insufficient resources to create the branch instance. Insufficient resources to create the branch instance.
400 BranchStorageInvalid The specified storage configuration is invalid for branch. The branch storage configuration is invalid.
400 BranchStorageReduceForbidden Branch storage cannot be reduced. Branch storage capacity does not allow shrinking.
400 BranchStorageReduceForbidden Storage reduction is forbidden for branch. Reducing branch storage capacity is not allowed.
400 BranchTemporaryClassChangeForbidden Temporary branches cannot change instance class. Convert to protected first. Temporary branches do not allow instance specifications to be changed. Convert to a protected branch first.
400 BranchTemporaryClassChangeForbidden Temporary class change is forbidden for branch. Temporary specification changes for branches are not allowed.
400 BranchTypeChangeInvalid BranchType only supports changing from temporary to protected. BranchType only support changes from temporary to protected.
400 BranchTypeChangeInvalid The branch type change is invalid. The branch type change is invalid.
400 ChildBranchesExisted Cannot delete branch with child branches. The branch has child branches and cannot be deleted.
400 CommodityNotPurchasable This account cannot purchase the commodity. This product cannot be purchased with the current account (currently, products on the cloud of the group are not supported)
451 ContentModeration Content moderation violation. Non-compliant content in request
451 Content_Moderation Content Moderation Violation. CSI verification failed, please check whether the problem contains non-compliant content.
404 ContextDbLibraryFileNotFound The ContextDB library file was not found. The ContextDB library file does not exist or the current caller does not have access permissions.
400 ContextDbLibraryFileTooLarge The file exceeds the allowed single-file size limit. A single file exceeds the maximum size allowed for the repository.
400 ContextDbLibraryFileTypeNotAllowed The file type is not allowed. The file type is not within the allowed range of the library.
404 ContextDbScheduledTaskNotFound The ContextDB scheduled task was not found. ContextDB the timed task does not exist or the current caller does not have permission to access it.
404 ContextDbSkillNotFound The ContextDB Skill was not found. The ContextDB Skill does not exist or the current caller does not have access permissions.
404 ContextDbSkillOAuthSessionNotFound The ContextDB Skill OAuth session was not found. The ContextDB Skill OAuth session does not exist or the current caller does not have access permissions.
409 ConversationBusy The conversation is already resuming a tool approval round. The conversation is recovering tool approval. The current request cannot execute concurrently.
404 ConversationNotFound Conversation does not exist. Conversation does not exist.
503 CredentialsNotConfigured Aliyun AK SK credentials are not configured. The Alibaba Cloud access credentials are not configured.
503 CredentialsNotConfigured Aliyun AK/SK credentials are not configured. The Alibaba Cloud access credentials are not configured.
409 CustomAgentNameDuplicated A custom agent with the same name already exists. A custom agent with the same name already exists.
404 CustomAgentNotFound The custom agent was not found or is not accessible. The custom smart body does not exist or the current user does not have access.
400 CustomAgentQuotaExceeded The maximum number of custom agents has been reached. The number of custom agents has reached the upper limit.
400 CustomKeyLimitExceededError Custom key limit exceeded. The number of custom keys has exceeded the upper limit.
409 DomainNotReady The instance domain is not ready yet. The instance domain name is not ready for use.
400 DomainNotReadyError Domain is not ready yet, please try again later. The domain name is not yet ready.
409 FileUploadConflict The uploaded file conflicts with the current request. The upload file conflicts with the current request.
403 FileUploadForbidden The uploaded file is not accessible to the current user. The current user does not have permission to access the uploaded file.
400 FileUploadValidationError The uploaded file reference is invalid. The uploaded file reference is invalid.
403 File_upload_forbidden Upload token does not match the upload session. The file upload authentication information does not match, please check whether it is the file of the corresponding user.
503 GatewayDisabled AI Gateway is not enabled. The AI gateway is not enabled.
400 IdempotentParameterMismatch The request uses the same client token as a previous, but non-identical request. Do not reuse a client token with different requests, unless the requests are identical. The request parameters associated with the same client token are inconsistent.
400 IncorrectInstanceState Current instance status does not support this operation. The operation is not supported in the current instance state.
409 InstanceConflict The instance already exists and conflicts with the request. The instance already exists and conflicts with this request.
400 InstanceIdRequired instanceId is required and must be non-empty. instanceId is required and must be non-empty.
404 InstanceNotFound MO Instance not found or does not belong to the uid given. The MO instance is not found, or the MO instance does not belong to the uid.
404 InstanceNotFound MO Instance not found or does not belong to the specified account. The MO instance does not exist or does not belong to the current account.
400 InstanceNotFoundError No active instance found. No active instance was found.
400 InstanceQuotaExceededError Instance quota exceeded, cannot create new API key. The instance quota has been exhausted. A new API key cannot be created.
409 InstanceReleased The instance has been released. Please create with a new instanceId. The instance has been released.
403 InsufficientResourceCapacity There is not enough host resource inventory. Insufficient resources
500 InternalError An internal error occurred. The server failed to process the request.
500 InternalError %s. System internal exception
500 InternalError System internal exception. System internal exception
500 InternalError Failed to release postpay instance. The server failed to process the request.
500 InternalError Internal server error. The server failed to process the request.
400 InvalidConfigContent.Format Content does not satisfy the inspection configuration schema or processor catalog. Content does not satisfy the inspection configuration schema, processor catalog, or threshold constraints.
400 InvalidConfigType.Value ConfigType must be template or item. ConfigType must be template or item.
400 InvalidContextDbLibraryFilename The filename is invalid. The file name is invalid. Check for whitespace, path separators, control characters, and length.
400 InvalidContextDbLibraryFileSize The file size must be a positive integer. The file size must be a positive integer.
400 InvalidDBInstanceStatus DB instance status is not valid. RDS PG instance status is invalid
400 InvalidEndTime.Format EndTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ. EndTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ.
400 InvalidFrequency.Value Frequency is not a supported inspection schedule. Frequency is not a supported inspection schedule.
400 InvalidGroupName Specified group name is not valid. Invalid group name
400 InvalidHttpHeaderNameError Header names must contain only alphanumeric characters (a-z, 0-9) and hyphens (-), and must not start or end with a hyphen. The request header name format is invalid.
400 InvalidImageDimensions The image is invalid, or its dimensions are not supported. The picture cannot be decoded, the content type does not match, or the width and height are no greater than 10 pixels on either side.
400 InvalidInspectionConfig.Value An inspection configuration parameter is invalid. An inspection configuration parameter is invalid.
400 InvalidInstance.NotFound Specified instance does not exist. The specified instance does not exist.
400 InvalidInstanceIds.Value InstanceIds is invalid or does not match the selected template engine. InstanceIds is invalid or does not match the selected template engine.
400 InvalidIpWhitelistError Invalid IP address or CIDR in whitelist. The IP address or CIDR block in the whitelist is invalid.
400 InvalidModelId The requested model is not available. The model specified in the request is not currently supported. Check whether the ModelId is correct.
400 InvalidOrder No valid order found, please check whether RDS Copilot Professional Edition has been activated and ensure that the order is valid. No valid order found, please check whether RDS Copilot Professional Edition has been activated and ensure that the order is valid.
400 InvalidPageParamError Invalid pagination parameter. Page must be at least 1, and pageSize must be between 1 and 100. The pagination parameter is invalid.
400 InvalidPagination.Value PageNumber or PageSize is outside the supported range. PageNumber or PageSize is outside the supported range.
400 InvalidParam The provided parameter is invalid. Invalid parameter
400 InvalidParameter The request contains an invalid or missing parameter. Incorrect parameters were passed in to the request, or several parameters were missing.
400 InvalidParameter %s. The request parameter verification failed. For more information, see the return message.
400 InvalidParameter Request parameter validation failed. Request parameter verification failed
400 InvalidParameter The provided parameter is invalid. Invalid parameter.
400 InvalidParameter Request parameter is invalid. The request parameter is invalid.
400 InvalidQuantityError Invalid quantity: must be an integer between 1 and 50. The quantity must be an integer between 1 and 50.
400 InvalidQuotaValueError LimitType must be fixed or ratio. TokenQuota must be a positive integer and limitRate must be between 0.0 and 1.0. The key quota parameter is invalid.
400 InvalidQuotaValueError Keys quota setting is not correct. The key quota parameter is invalid.
400 InvalidRegionId.Format RegionId is invalid for this inspection request. RegionId is invalid. The default inspection workflow does not require this parameter.
400 InvalidReportLanguage.Value ReportLanguage is not supported. ReportLanguage must be zh-CN, en-US, ja-JP, or zh-TW.
400 InvalidReportParameter.Value An inspection report parameter is invalid. An inspection report parameter is invalid.
400 InvalidRequest.Format The request body must be a non-empty JSON object. The request body must be a non-empty JSON object.
400 InvalidScheduledId.Format ScheduledId must be a non-empty scheduled inspection identifier. ScheduledId must be a non-empty scheduled inspection identifier.
400 InvalidScheduledStartTime.Format The scheduled start time must use the UTC format HH:mm:ssZ. The scheduled StartTime or TaskStartTime must use the UTC format HH:mm:ssZ.
400 InvalidSessionIdHeaderTypeError SessionIds must be a list of strings. SessionIds must be a list of strings.
400 InvalidSessionIdHeaderValueError SessionIds contains invalid value. SessionIds contains invalid values.
400 InvalidStartTime.Format StartTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ. StartTime must use the UTC format YYYY-MM-DDTHH:MM:SSZ.
400 InvalidTaskId.Format TaskId must be a non-empty inspection task identifier. TaskId must be a non-empty inspection task identifier.
400 InvalidTaskParameter.Value An inspection task identifier is invalid. An inspection task identifier is invalid.
400 InvalidTemplate.Value TemplateId is missing, inaccessible, or incompatible with the target instances. TemplateId is missing, inaccessible, or incompatible with the target instances.
400 InvalidTimeParameter.Value An inspection time or frequency parameter is invalid. The inspection time or execution frequency parameter is invalid.
400 InvalidTimeRange.Value StartTime must be earlier than EndTime. StartTime must be earlier than EndTime.
400 InvalidTimeRangeHours.Value TimeRange must be an integer from 1 to 168 hours. TimeRange must be an integer from 1 to 168 hours.
400 InvalidToolApprovalCursor Invalid tool approval cursor. The tool approval cursor parameter value is invalid.
422 InvalidToolApprovalMode Invalid ToolApprovalMode value. The ToolApprovalMode parameter value is invalid.
400 InvalidUserIdentity.Missing The authenticated caller identity is missing. Missing authenticated caller identity information.
403 InvalidUserOrder There is no valid order for this UID. There is no valid order for this UID
400 InvalidWorkspaceId.Conflict The request contains conflicting WorkspaceId values. The WorkspaceId values provided in the request conflict with each other. Make sure the workspace identifiers are consistent across all locations in the request and try again.
400 InvalidWorkspaceId.Missing WorkspaceId is required for the ContextDB management App. A WorkspaceId is required when managing applications with ContextDB. Specify the ContextDB workspace for this request and try again.
400 InvalidWorkspaceId.Value WorkspaceId is invalid. The WorkspaceId is invalid. Check the workspace identifier, specify a valid ContextDB WorkspaceId, and try again.
400 InvokeError %s. Invoke error.
400 LibraryFileTooLarge The file exceeds the ContextDB Library file size limit. File exceeds ContextDB Library single file size limit.
400 MasterInstanceNotExist Master instance does not exist. The primary instance does not exist.
404 MessageNotFound Message does not exist. Message does not exist.
503 MetaDBNotConfigured AI Gateway metadb is not configured (METADB DSN is empty). AI Gateway Metabase not ready
503 MetaDBNotConfigured AI Gateway metadb is not configured. The metadb connection setting is empty. The AI gateway metadata database is not configured.
405 MethodNotAllowed The HTTP method is not allowed for this resource. The HTTP method for the request to this resource is incorrect.
400 MissingBranchName The request is missing the BranchName parameter. The request is missing a BranchName parameter.
400 MissingInstanceName The request is missing the InstanceName parameter. The request is missing a InstanceName parameter.
400 MissingParameter A required inspection parameter is missing. Required inspection parameters are missing.
400 MissingParentBranchName The request is missing the ParentBranchName parameter. The ParentBranchName parameter is missing.
400 MissingServiceLinkedRole %s. The service-linked role authorization is missing.
400 MissingSourceBranch The request is missing the SourceBranchName parameter. The request is missing a SourceBranchName parameter.
400 MissingTargetBranch The request is missing the TargetBranch parameter. The request is missing a TargetBranch parameter.
404 MoApiKeyNotFoundError The specified API key was not found or has been disabled. The specified API key does not exist or has been disabled.
503 MoColdPathQueryFailedError Cold path usage detail query failed. Failed to query the usage details of historical archiving.
404 MoConsumerNotFoundError No active consumer found for this instance. The instance does not have any active consumers.
400 MoContentSafetyNotEnabledError AI content safety (AiSecurityGuard) is not enabled on the gateway. Please enable it in the console first. The AI content security feature has not been enabled on the gateway.
500 MoCredentialNotConfiguredError Server credentials are not configured. The server-side credentials are not configured.
400 ModelNotSupportVision The requested model does not support image input. The model specified in the request does not support image input. Select a model that supports visual capabilities or remove images.
403 ModelSelectionRequiresPaidOrder Selecting a non-default model requires a valid paid order. Selecting a non-default model requires a valid paid order.
400 ModifyBranchNoChange At least one property (BranchType, DBInstanceClass, DBInstanceStorage) must be specified. At least one modifying attribute (BranchType, DBInstanceClass, or DBInstanceStorage) needs to be specified.
400 ModifyBranchNoChange No changes were made to the branch configuration. The branch configuration has not changed.
400 MoDomainNotReadyError Domain is not ready yet, please try again later. The domain name is not yet ready.
400 MoExportBeforeRetentionError Usage detail export is earlier than RDS retention and archive query is not enabled. The export start time exceeds the retention period and archive query is not enabled.
400 MoExportInProgressError Previous usage detail export task is still in progress, please wait for it to complete. The previous usage detail export task is still running.
429 MoExportQueueFullError Usage detail export queue is full, please try again later. The usage detail export queue is full.
400 MoExportTimeRangeInvalidError endTime must be greater than startTime. The end time must be later than the start time.
400 MoExportTimeRangeTooLargeError Export time range must be within 7 days. The export time range cannot exceed 7 days.
400 MoExportTimeRequiredError startTime and endTime are required. The start time and end time are required.
400 MoInstanceIdRequiredError instanceId is required. The instanceId parameter is missing.
404 MoInstanceMappingNotFoundError No active instance mapping found. No active instance mapping exists.
400 MoInvalidApiKeysError ApiKeys parameter is missing, empty, or contains invalid elements. The ApiKeys parameter is missing, empty, or contains invalid elements.
400 MoInvalidBatchItemsError Items parameter is missing, empty, or has invalid format. The Items parameter is missing, empty, or in an invalid format.
400 MoInvalidIpWhitelistError Invalid IP address or CIDR in whitelist. The IP address or CIDR block in the whitelist is invalid.
400 MoInvalidSafetyDimensionError Invalid safety dimension type. Valid types: Global, ContentModeration, PromptAttack, SensitiveData, ModelHallucination, MaliciousUrl. The security detection dimension is invalid.
400 MoInvalidSafetyLevelError Invalid safety level. Valid levels: high, medium, low, observe. The security detection level is invalid.
400 MoInvalidSafetyRulesError Rules parameter is missing or empty. The Rules parameter is missing or empty.
404 MoNoActivePostpayOrderError No active postpay order found for this instance. The instance does not have a valid pay-as-you-go order.
400 MoOverflowPostpayRequiredError Enabling overflow requires an active POSTPAY instance. An active pay-as-you-go instance is required to enable overflow.
400 MoPostpayRatioNotAllowedError Ratio mode is not supported for POSTPAY instances. Use 'fixed' mode instead. Pay-as-you-go instances do not support the proportional quota mode.
400 MoProLikeCustomKeyNotAllowed Custom API keys are not supported for Pro or Enterprise instances. Custom API keys are not supported for Pro or Enterprise instances.
400 MoQueryBeforeRetentionError Usage detail query is earlier than RDS retention and archive query is not enabled. The query time exceeds the retention period and archive query is not enabled.
400 MoQueryRangeTooLargeError Usage detail query time range is too large. The time range for the usage detail query is too large.
429 MoQuotaExceeded The MO token quota of the routed Standard instance has been exhausted and the request is rate limited. Please wait for quota recovery or purchase a capacity pack. The MO token quota of the routed Standard Edition instance has been exhausted. Please wait for the quota to be restored or purchase a capacity package.
403 NoPermission Permission denied. Permission denied, %s.
403 NoPermission Permission denied, %s. Permission denied, %s.
404 NotFound The requested resource was not found. The requested resource was not found.
400 NoValidStandardOrder no valid standard order found or capacity pack is zero. no valid standard order found or capacity pack is zero.
400 ParentBranchInvalid The parent branch is invalid. Only protected branches can be used as parent. The parent branch is invalid. Only protected branches are allowed.
409 PendingToolApproval The conversation has pending tool approvals. Conversation there are pending tool approvals, complete all approvals before continuing the conversation.
403 PermissionDenied User has no operation permission. User has no operation permission
400 PermissionDenied No valid order found or permission denied. No valid order found or permission denied.
400 PluginConfigInvalidError PluginConfig must be a key/value map (object). PluginConfig must be a key-value object.
400 PluginConfigKeyNotSupportedError PluginConfig contains unsupported key. The plugin configuration contains unsupported keys.
400 PluginConfigValueInvalidError The specified plugin configuration value is invalid. The specified plugin configuration value is invalid.
400 PluginConfigValueOutOfRangeError The specified plugin configuration value is outside the allowed range. The specified plugin configuration value exceeds the allowed range.
400 PluginNameRequiredError PluginName is required. The PluginName parameter is missing.
400 PluginNotFoundError Specified plugin not found on gateway. The specified plugin was not found in the gateway.
400 PluginNotSupportedError Specified pluginName is not supported. The specified plugin name is not supported.
409 PrivateDomainAlreadyBoundError Private domain is already bound to this instance. The private domain name is already bound to this instance.
500 PrivateDomainCreateFailedError Failed to create private domain. Failed to create the private domain name.
400 PrivateDomainCreatingError Private domain is currently creating. The private domain name is being created.
400 QueryDateFormatInvalidError StartTime and endTime must be in YYYY-MM-DD format. The start time and end time must be in the YYYY-MM-DD format.
400 QuotaAlertBatchFailedError All quota alert operations failed. All quota alert operations failed.
400 QuotaAlertItemsRequiredError The apikeys parameter must not be empty. The apikeys parameter cannot be empty.
429 QuotaExceeded Resource quota exceeded. Create resource quota exceeding limit
409 QuotaInsufficient The requested quota change exceeds the quota available on the system API key. the token quota of the request exceeds the token quota of the api key of the instance.
400 QuotaSumExceededError Sum of custom key quotas exceeds instance total quota. The total quota of custom keys exceeds the total instance quota.
429 RateLimitError The request was rejected because the invocation rate limit was exceeded. The request was rejected because it exceeded the call frequency limit.
404 RcmInstanceNotFound The specified RDS Custom Model instance was not found. The specified RDS custom model instance does not exist.
400 RcmInvalidParameter Invalid parameter value. The parameter value is invalid.
404 RcmNoValidInstance No valid RDS Custom Model instance found for this user. The current user does not have a valid RDS custom model instance.
400 RdsInstanceIdRequired rdsInstanceId is required and must be non-empty. rdsInstanceId is required and must be non-empty.
400 RdsInstanceNotFound RDS instance not found or does not belong to the current user. RDS instance not found or does not belong to the current user.
409 ResourceAlreadyExists Resource state conflict. A resource status conflict occurred.
404 ResourceNotFound Resource not found. The specified resource does not exist.
403 SandboxCloudPermissionRoleNotAssumable The specified RAM role cannot be assumed by the service identity. The specified RAM role cannot be assumed by the RDS AI service Sandbox the cloud permission configuration is not updated.
404 SandboxCloudPermissionRoleNotFound The specified RAM role does not exist. The specified RAM role does not exist, Sandbox the cloud permission configuration is not updated.
404 ScheduledTask.NotFound The specified scheduled inspection task does not exist or is not accessible. The specified scheduled inspection task does not exist or is not accessible.
400 SessionIdRequiredError SessionIds is required and must be a non-empty list of strings. SessionIds must be a non-empty list of strings.
400 SessionIdsListTooLargeError SessionIds list exceeds the maximum allowed size (10). The SessionIds list can contain a maximum of 10 items.
400 SessionIdsTooLongError SessionIds contains a header name that exceeds the maximum length (64). A request header name in SessionIds exceeds 64 characters.
400 SkillDescriptionRequired Skill description is required. The skill description is required.
400 SkillDescriptionTooLong Skill description cannot exceed 1000 characters. The skill description cannot exceed 1000 characters.
400 SkillInvalidDbtype The specified database type or skill content mapping is invalid. The specified database type or skill content mapping is invalid.
400 SkillNameDuplicated Skill name already exists. The skill name already exists.
400 SkillNameInvalid Skill name can only contain lowercase letters, numbers and hyphens. The skill name can contain only lowercase letters, digits, and hyphens.
403 SkillNotBelongToUser One or more skills are not accessible to the current user. The current user does not have access to one or more skills.
403 SkillNotDeletable System skill cannot be deleted. System skills cannot be deleted.
403 SkillNotEditable System skill cannot be edited. System skills cannot be edited.
404 SkillNotFound Skill not found. The skill does not exist.
400 SkillQuotaExceeded You have reached the maximum limit of skills. The number of skills has reached the upper limit.
404 StorageInstanceNotFound Storage instance not found or does not belong to the uid given. The storage instance ID does not exist, or the storage instance ID does not belong to this UID.
404 StorageInstanceNotFound Storage instance not found or does not belong to the specified account. The storage instance does not exist or does not belong to the current account.
400 SystemKeyQuotaNotConfigurableError Cannot configure quota for system key. Quota configuration is not allowed for system keys.
404 TaskNotFound The resource of the specified ld does not exist. The resource with the specified ID does not exist.
404 ToolApprovalNotFound The tool approval resource is not found. The tool approval resource does not exist or you do not have access to it.
409 ToolApprovalResumeInvalid The specified tool approval call cannot be resumed. The specified tool approval invocation cannot be resumed.
503 ToolApprovalUnavailable The tool approval service is temporarily unavailable. The tool approval service is temporarily unavailable. Try again later.
429 TooManyRequests The current maximum concurrent requests have exceeded the threshold. The current maximum number of concurrent requests has exceeded the threshold. Purchase an AI capacity plan to increase the concurrency limit or reduce the number of concurrent requests.
401 Unauthorized Authentication failed: missing or invalid API key. Authentication failed. The API key is not provided or is incorrect.
401 Unauthorized The request could not be authenticated. The request failed to pass identity authentication.
400 UnsupportedDBInstanceLockMode The DB instance lock mode does not support this operation. The instance lock mode does not support the current operation.
400 UnsupportedDBInstanceStatus The instance status does not support this operation. The current instance status does not support this operation.
400 UnsupportedDBInstanceStatus The DB instance status does not support this operation. The current instance status does not support this operation.
400 UnsupportedDBInstanceType The DB instance type does not support this operation. The instance type does not support the current operation.
502 UpstreamError Upstream service returned an error. The upstream service returned an error.
404 UserNotFound User does not exist. The user does not exist.
400 VpcIdRequiredError VpcId is required. The VpcId parameter is missing.
423 WorkspaceLocked Current workspace is locked. The ContextDB Workspace is locked.
400 ZoneNotMatchedError No vSwitch in the VPC matches the availability zones supported by the endpoint service. No vSwitch in the VPC matches the zones supported by the endpoint service.