Connect to ApsaraDB for SelectDB with DMS

Updated at:

ApsaraDB for SelectDB uses the MySQL network protocol, allowing you to connect to instances with MySQL-compatible command-line tools, JDBC/ODBC drivers, and GUI tools such as Data Management Service (DMS).

Background information

DMS is a GUI-based data management tool from Alibaba Cloud for relational and NoSQL databases. It supports data management, SQL operations, data import/export, database cloning, performance optimization, and security auditing.

Prerequisites

Procedure

  1. Log on to the ApsaraDB for SelectDB console.

  2. In the upper-left corner, select the region where the instance is located.

  3. On the Instances page, click the target Instance ID to go to the Instance Details page.

  4. On the Instance Details page, click Log On to DMS in the upper-right corner.

  5. Configure the following parameters.

    Parameter

    Description

    Database Type

    Defaults to SelectDB,ApsaraDB for SelectDB instance. This setting cannot be changed.

    Instance Region

    Defaults to the region of the current ApsaraDB for SelectDB instance. This setting cannot be changed.

    Note

    To log on to an ApsaraDB for SelectDB instance in another region, select the target region from the drop-down list.

    Instance ID

    Defaults to the instance ID of the current ApsaraDB for SelectDB instance. This setting cannot be changed.

    Note

    To log on to another ApsaraDB for SelectDB instance, select the target instance ID from the drop-down list.

    Database Account

    The account to log on to the database.

    Database Password

    The password for the database account.

    Remember Password

    Select Remember Password to automatically log on to the ApsaraDB for SelectDB instance in subsequent sessions.

    Control Mode

    The following control modes are supported:

    • Flexible Management

    • Stable Change

    • Secure Collaboration

    For more information, see control modes.

    Note
    • When you log on to an ApsaraDB for SelectDB instance by using DMS for the first time, the control mode defaults to Flexible Management. After you log on successfully, you can change the control mode by editing the instance. For more information, see Edit instance information and Control modes.

    • After you configure the logon parameters, you can click Test Connection in the lower-left corner. If the test connection fails, use the error message to check the information you entered.

  6. Click Logon.

    After you log on successfully, double-click the target database in the left-side navigation pane. This opens the SQL Console, where you can run SQL statements. For more information, see Create a database and write data to it.

FAQ

Q: What do I do if a whitelist-related error occurs when I log on to an ApsaraDB for SelectDB instance by using DMS?

设置白名单

A: Click Configure Whitelist in the dialog box. The system automatically adds the IP addresses of DMS servers to the database whitelist. If this fails, you must add the IP addresses manually. For more information, see Add DMS IP CIDR blocks.