Connect to ApsaraDB for SelectDB with DMS
ApsaraDB for SelectDB uses the MySQL network protocol, allowing you to connect to instances with MySQL-compatible command-line tools, JDBC/ODBC drivers, and GUI tools such as Data Management Service (DMS).
Background information
DMS is a GUI-based data management tool from Alibaba Cloud for relational and NoSQL databases. It supports data management, SQL operations, data import/export, database cloning, performance optimization, and security auditing.
Prerequisites
You have created an ApsaraDB for SelectDB instance. For more information, see Create an instance.
You have reset the admin password of the instance. For more information, see Reset the admin password of an instance.
You have added the IP addresses of DMS servers to the ApsaraDB for SelectDB of your ApsaraDB for SelectDB instance. For more information about the DMS IP addresses and how to configure a whitelist, see DMS IP CIDR blocks and Configure a whitelist.
Procedure
Log on to the ApsaraDB for SelectDB console.
Click Logon.
After you log on successfully, double-click the target database in the left-side navigation pane. This opens the SQL Console, where you can run SQL statements. For more information, see Create a database and write data to it.
FAQ
Q: What do I do if a whitelist-related error occurs when I log on to an ApsaraDB for SelectDB instance by using DMS?

A: Click Configure Whitelist in the dialog box. The system automatically adds the IP addresses of DMS servers to the database whitelist. If this fails, you must add the IP addresses manually. For more information, see Add DMS IP CIDR blocks.