Failed to deliver logs to OSS
This topic describes how to resolve failures that occur when you ship logs to Object Storage Service (OSS).
Endpoint error
Problem description
AccessDenied: The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.Possible cause
This error indicates that the region of the Simple Log Service project does not match the region of the OSS bucket.
Solution
Ensure that the Simple Log Service project and the OSS bucket are in the same region. For more information about endpoints, see Private network.
If a Simple Log Service project is in the Hangzhou Finance Cloud region, you can ship logs only to the public network of the same region (oss-cn-hzfinance). Shipping logs to the China East 1 Finance Cloud region (oss-cn-hzjbp) is not supported. The OSS endpoint for the public network of the Hangzhou Finance Cloud region is oss-cn-hzfinance-internal.aliyuncs.com.
RAM role does not exist
Problem description
EntityNotExist.Role: The role not exists:Possible cause
This error indicates that the specified Resource Access Management (RAM) role does not exist. This may be because the provided Alibaba Cloud Resource Name (ARN) is incorrect.
Solution
Ensure that you specify the correct ARN.
For more information, see How to obtain an ARN.
No object access permissions
Problem description
You have no right to access this object because of bucket acl.Possible cause
This error indicates that Simple Log Service has insufficient permissions to access the object. This issue occurs because the access control list (ACL) policy of the OSS bucket prevents Simple Log Service from performing write operations.
Solution
To ensure that the OSS data shipping job runs correctly, adjust the ACL policy to grant the required access permissions. For more information, see Overview of permissions and access control.