Error message Client.SystemConfigure.RootNotFound

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The "Client.SystemConfigure.RootNotFound" error occurs during SMC migration when the system fails to locate the root directory on the target disk.

Problem description

During SMC migration, the migration task returns the error message "Client.SystemConfigure.RootNotFound".

Causes

The target disk system configuration is incorrect, and the system cannot find the root directory. This issue typically occurs because the boot or etc directory is missing on the source system.

Solution

  1. Check whether the boot directory and etc directory in the source system are normal:

    1. Run ls /boot to check whether the boot directory exists.

    2. Run ls /etc to check whether the etc directory exists.

  2. If the directories exist, check the SMC client installation directory, and run the ./go2aliyun_client --rerun --forcesync command in the SMC client installation directory, and then retry. If the boot directory or etc directory in the file system is missing, resolve the file system corruption issue on the source server, and then run the client again to attempt migration.

  3. If the issue persists, collect the /smc/go2aliyun_client*/Logs logs and contact us.