The "Client.SystemConfigure.RootNotFound" error occurs during SMC migration when the system fails to locate the root directory on the target disk.
Problem description
During SMC migration, the migration task returns the error message "Client.SystemConfigure.RootNotFound".
Causes
The target disk system configuration is incorrect, and the system cannot find the root directory. This issue typically occurs because the boot or etc directory is missing on the source system.
Solution
-
Check whether the
bootdirectory andetcdirectory in the source system are normal:-
Run
ls /bootto check whether thebootdirectory exists. -
Run
ls /etcto check whether theetcdirectory exists.
-
-
If the directories exist, check the SMC client installation directory, and run the
./go2aliyun_client --rerun --forcesynccommand in the SMC client installation directory, and then retry. If thebootdirectory oretcdirectory in the file system is missing, resolve the file system corruption issue on the source server, and then run the client again to attempt migration. -
If the issue persists, collect the
/smc/go2aliyun_client*/Logslogs and contact us.