This topic describes the causes of and solutions to the "Customer.Client.Network.ConnectFailed" error during an SMC migration task.
Problem description
A migration task in SMC fails and reports the error message "Customer.Client.Network.ConnectFailed".
Causes
The SMC client on the source system fails to connect to the transit service on the destination instance. The possible causes are as follows:
The destination instance can be a transit instance or the final destination instance. The ID of the transit or destination instance is available on the migration task details page.
The transit service on port 8080 of the destination instance is not running correctly.
The source server cannot access the
IP:8080port on the destination instance.
Solutions
Verify that port 8080 on the destination instance is accessible and running correctly.
Go to the Instances page of the ECS console.
In the upper-left corner, select the region and resource group of the destination instance.
Confirm that the destination instance is in the Running state.
If the instance is in the Running state, proceed to the next step.
If the instance is in the Stopped state, start the instance.
If the instance has been released, create another migration task. For more information, see Migrate a server to an ECS instance.
Click the ID of the destination instance to open the instance details page. On the Scheduled Tasks tab, click Send Command.
For Windows: Enter
netstat -ano | findstr 8080and click Execute Now.For Linux systems: In the command input box, enter
netstat -ano | grep 8080and click Execute Now.
If the command runs successfully and returns output for port 8080, the port is working as expected.
Check the inbound rules of the security group for the destination instance. Ensure that traffic on port 8080 is allowed and no other rules block this port.
NoteBy default, an SMC migration task automatically associates a temporary security group with the destination instance and allows inbound traffic on port 8080.
Access
http://<destination instance IP>:8080from a server other than the source server to verify that it is working correctly.Linux system:
curl http://<destination instance IP>:8080.On Windows: In a browser, go to
http://<destination instance IP>:8080.
If a response in the standard JSON format such as
{"code":-101,"message":"smc p2vs get ok."}is returned, the status is normal.NoteBy default, the public IP address of the destination instance is used. If you selected the private migration mode, use the private IP address of the destination instance.
Check if the network services on the source system are running correctly.
Verify that local network services are running as expected. Check the configurations of the hosts file and DNS.
By default, migration tasks use the public migration mode for data transfer. Make sure that the source system can access the Internet.
If the migration task is configured to use the private migration mode, make sure that a private connection is established between the source system and the destination VPC and vSwitch. For more information, see Private migration.
NoteIf you are unsure whether a private connection is established, use the public migration mode. If you selected the private migration mode by mistake, switch to the public migration mode and try again.
Test the network connectivity from the source system to the destination instance.
In the security group for the destination instance, allow inbound traffic for the ICMP protocol. Then, use the ping command to test the network connection from the source server to the destination instance.
If the test fails, check your local network and intermediate devices, such as a firewall or proxy, for outbound rules that restrict access by IP address.
Access
http://<Destination instance IP address>:8080to test whether the source server can connect to port 8080 on the destination instance.Linux system:
curl http://<destination instance IP>:8080.For Windows: use a browser to access
http://<destination-instance-ip>:8080.
If a normal JSON response such as
{"code":-101,"message":"smc p2vs get ok."}is returned, the connection is successful. Otherwise, the connection has failed, and you must check your local network configuration or intermediate network devices, such as firewalls or proxies, for outbound IP or port access restrictions.Check whether Alibaba Cloud Firewall is enabled. If Alibaba Cloud Firewall is enabled, check whether an access control policy, such as one for the Internet firewall or VPC firewall, is blocking network traffic. For more information, see Internet firewall.
After you resolve the network issue, run the SMC client to retry the operation. For more information, see Run the SMC client.