OS migration with SMC fails if your server lacks sufficient disk space or memory. This page lists error messages by scenario and explains how to resolve them.
Error messages
One of the following error messages appears during an OS migration:
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Available system memory is less than 300M, memory requirement is not satisfied. -
Total system memory is less than 512M, memory requirement is not satisfied. -
Available system storage is less than 2G, storge requirement is not satisfied. -
To ensure the migration, this machine must have 2G free space on disk and 300MB RAM available. -
To ensure the migration, this machine must have 512MB RAM at least totally. -
To ensure the migration, this machine must have 4G free space on disk and 600M RAM available -
Memory detected: *MiB, required: *MiB
Cause
The server does not meet the minimum disk space or memory requirements. Requirements vary by migration scenario.
CentOS/Red Hat to Alibaba Cloud Linux migrations
Applicable migration paths:
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CentOS 7 to Alibaba Cloud Linux 2
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CentOS 8 to Alibaba Cloud Linux 3
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Red Hat 8 to Alibaba Cloud Linux 3
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Error message |
Cause |
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Available memory is less than 300 MiB. |
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Total memory is less than 512 MiB. |
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Available system disk space is less than 2 GiB. |
CentOS to Anolis OS migrations
Applicable migration paths:
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CentOS 7 to Anolis OS 7
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CentOS 8 to Anolis OS 8
|
Error message |
Cause |
|
|
Available disk space is less than 2 GiB and available memory is less than 300 MiB. |
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Total memory is less than 512 MiB. |
Cross-version migrations (major version upgrade)
Applicable migration paths:
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CentOS 7 to Alibaba Cloud Linux 3
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CentOS 7 to Anolis OS 8
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Red Hat 7 to Alibaba Cloud Linux 3
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Alibaba Cloud Linux 2 to Alibaba Cloud Linux 3
|
Error message |
Cause |
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Available disk space is less than 4 GiB and available memory is less than 600 MiB. |
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Total memory is below the minimum threshold: 1.5 GiB for x86_64, 2 GiB for aarch64. |
Solution
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Connect to the ECS instance whose OS you want to migrate. Connect to a Linux instance by using a password or key.
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Free up disk space or memory, depending on which resource is insufficient.
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If the root directory disk space is insufficient:
Clean up the
/tmpand/var/logdirectories:WarningVerify that the files are no longer needed. Deleting in-use files may affect your workloads.
rm -rf /tmp/* rm -rf /var/log/syslog.* # Delete earlier syslog files. -
If available memory is insufficient:
Suspend non-essential services, such as Java or NGINX processes, to free up memory. Restart them after the migration completes.
For example, to suspend an NGINX process:
ps aux | grep nginx # Find the process ID (PID) of the NGINX process. kill -SIGSTOP <nginx-pid> # Suspend the NGINX process.
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After you resolve the network issue, run the SMC client to retry the operation. For more information, see Run the SMC client.
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If you suspended any processes in Step 2, restart them after the migration completes.
For example, to resume the NGINX process:
kill -SIGCONT <nginx-pid>