What do I do if I receive an S11 error code indicating an error in the network connection to the intermediate service of the destination instance?

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When you use Server Migration Center (SMC) to run a migration job, the error "S11_* An error occurred in the network connection of the intermediate service for the destination instance." may be reported. This topic explains the cause and provides solutions.

Problem description

During an SMC migration job, the "S11_* An error occurred in the network connection of the intermediate service for the destination instance." error is reported. The following S11_* error codes may appear:

  • S11_U28

  • S11_U7

  • S11_U56

  • S11_U6

Cause

The network connection between the SMC client on the source server and the intermediate service of the destination instance may fail due to one of the following causes:

Note

The destination instance refers to the intermediate instance or the target instance for migration. You can find its ID on the details page of the migration job.

  • An exception occurs on port 8080, which is used by the intermediate service of the destination instance.

  • The source server cannot access the destination instance over port 8080.

Solution

  1. Check whether the intermediate service of the destination instance is normal.

    1. Log in to the ECS console.

    2. In the left-side navigation pane, choose Instances & Images > Instance.

    3. In the top navigation bar, select the region where the target ECS instance is located.image.png

    4. Check whether the destination instance is running as expected.

    5. Find the destination instance and click its ID. On the page that appears, click the Remote Commands/Files tab. Then, click Send Remote Commands.

      • If the source server runs a Windows operating system, enter netstat -ano | findstr 8080 in the Command Content section, then click Run.

      • If the source server runs a Linux operating system, enter netstat -ano | grep 8080 in the Command Content section, then click Run.

      If port 8080 information is returned in the Command Output section, the intermediate service of the destination instance is running normally.

    6. Check whether port 8080 is enabled in the inbound rules of the security group of the destination instance and whether any security group rules conflict.

      Note

      By default, SMC associates the destination instance with a temporary security group during migration and enables port 8080 in the inbound rules.

    7. From a server other than the source server, access http://<IP address of the destination instance>:8080 to check whether the network connection is established.

      • If the server runs a Linux operating system, run the curl http://<IP address of the destination instance>:8080 command.

      • If the server runs a Windows operating system, use a browser to access http://<IP address of the destination instance>:8080.

      If JSON content such as {"code":-101,"message":"smc p2vs get ok."} is returned, the network connection is established.

      Note

      By default, the public IP address of the destination instance is used. If you migrate data over a virtual private cloud (VPC), the private IP address is used instead.

  2. Check whether the network service of the source server is normal.

    1. Check whether the local network service of the source server is normal and whether configurations such as the hosts file and DNS settings are valid.

    2. By default, SMC migrates data over the Internet. Make sure that the source server has Internet access.

    3. If you migrate data over a VPC, make sure that the source server is connected to the specified VPC and vSwitch. For more information, see Migrate servers over a private network.

      Note

      If you are unsure whether the source server is connected to the specified VPC and vSwitch, set the Network Type parameter to Public Network when you create a migration job. If the migration job fails with VPC selected, change Network Type to Public Network and try again.

  3. Check whether the network between the source server and destination instance is connected.

    1. Enable Internet Control Message Protocol (ICMP) in the inbound rules of the security group of the destination instance. Then, run the ping command to check connectivity between the source server and the destination instance.

      If the network is disconnected, check local network configurations or intermediate network devices. For example, verify that the firewall does not block the SMC endpoint IP address and that the proxy server allows outbound traffic to it.

    2. Access http://<IP address of the destination instance>:8080 to check whether the source server is connected to the destination instance by using port 8080.

      • If the source server runs a Linux operating system, run the curl http://<IP address of the destination instance>:8080 command.

      • If the source server runs a Windows operating system, use a browser to access http://<IP address of the destination instance>:8080.

      If JSON content such as {"code":-101,"message":"smc p2vs get ok."} is returned, the connection is established. Otherwise, check local network configurations or intermediate network devices. For example, verify that the firewall does not block the SMC endpoint IP address and port and that the proxy server allows outbound traffic to them.

    3. Check whether Cloud Firewall is enabled and whether access control policies block network access, such as Internet firewall or VPC firewall policies. For more information, see Firewall Settings.

  4. After you resolve the network issue, run the SMC client to retry the operation. For more information, see Run the SMC client.