在Ubuntu实例中使用apt-get update命令时提示“The following signatures were invalid: KEYEXPIRED 1544811256”

问题描述

在Ubuntu实例中使用apt-get update命令时,提示以下信息。

The following signatures were invalid: KEYEXPIRED 1544811256

问题原因

由于使用的软件源签名到期,需要更新过期的key。

解决方案

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。
  1. 执行以下命令,获取过期的key。
    sudo apt-key list | grep -A 1 expired
  2. 执行以下命令,更新过期的key。
    apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys [$Key]
    说明:[$Key]指的是之前获取到的过期的key.
  3. 重新执行以下命令,进行软件更新。 
    apt-get update

适用于

  • 云服务器ECS
  • 轻量应用服务器