SecureCRT在连接Linux使用VI编辑器时提示"E437: terminal capability'cm' required"报错

问题描述

SecureCRT连接Linux使用VI编辑器时提示以下错误信息。

E437: terminal capability "cm" required
Press ENTER or type command to continue

问题原因

这个错误一般是环境变量TERM没有配置或者配置错误所致。

解决方案

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。
  1. 您可以执行export TERM=xterm命令临时解决。
  2. 您可以将export TERM=xterm添加到/etc/profile文件中以保证后续重启后也生效。

适用于

  • 云服务器ECS