使用ossbrowser工具登录OSS时报NetworkingError错误

问题描述

在创建Bucket后,需要使用ossbrowser工具管理OSS,在完成ossbrowser的安装后,登录时报NetworkingError错误。

问题原因

以下是登录失败报错的部分原因:

  • Endpoint设置错误。
  • 以RAM用户登录,但没有被赋予OSS管理权限。
  • AccessKey信息填写错误。

解决方案

您可以先阅读OSS Browser使用说明,确认设置的规范性无误后,然后请根据不同阿里云环境进行排查:

  1. 根据阿里云环境填写Endpoint值:
    • 公共云
      确认填写为默认(公共云)
    • 非公共云
      确认填写为自定义
      说明
      • 自定义:输入Endpoint信息,填写HTTP或HTTPS加对应地域的Endpoint,选择使用HTTP或HTTPS方式登录。例如 https://oss-cn-beijing.aliyuncs.com。地域域名信息请参见访问域名和数据中心
      • cname:可使用绑定的自定义域名登录。绑定自定义域名请参见绑定自定义域名
      • 如果不选择自定义,那么类似金融云、政务云、专有云等特殊环境的用户登录就会出现异常,例如HTTPS异常、或者Endpoint和Bucket设置不一致。
  2. 如果您是RAM用户登录,请确认已被赋予OSS管理权限:
    1. 登录RAM 访问控制
    2. 在左侧导航栏中单击用户,然后单击您当前的RAM用户名称。
    3. 单击权限管理,在个人权限继承用户组的权限中,确认当前RAM用户拥有OSS管理权限。
  3. 确认Endpoint的网络类型:
    • 在本地客户端时请使用外网访问的Endpoint地址。
    • 在VPC网络中请使用VPC的Endpoint地址,详情请参见OSS访问域名的使用规范
  4. 如果Endpoint设置正确,仍然无法登录,请在客户端侧依次执行下列命令,确认能否正常连接Endpoint地址。如果无法ping通Endpoint地址,或者无法连通443及80端口,请测试链路连通性,详情请参见链路测试方法
    ping [$Endpoint]
    telnet [$Endpoint] 80
    telnet [$Endpoint] 443
    说明:[$Endpoint]指您配置的Endpoint地址。
  5. 如果可以正常访问Endpoint地址,仍然无法登录OSS Browser客户端,则可能是由于您的OSS被攻击或者分享了违规内容,导致OSS被切入沙箱,详情请参见OSS沙箱机制
  6. 如果您是跨境访问OSS时,建议您开启传输加速后重试,详情请参见传输加速

适用于

  • 对象存储OSS