使用云效构建时发现某些依赖包不是最新的

使用云效构建时发现某些依赖包不是最新的

更新时间:2020-04-26 12:03:54

问题描述

使用云效构建项目时,部分依赖包不是最新的版本。

问题原因

使用maven构建会有缓存。

解决方案

以下是snapshot版本和release版本的处理方法。

snapshot版本

在maven构建命令中加入-U选项,执行命令类似如下。

mvn -U clean package -Dmaven.test.skip=true

released版本

 使用maven构建命令时,加入rm -rf命令,清理缓存目录。执行命令类似如下。

rm -rf /home/admin/.m2/repository &&mvn -U clean package -Dmaven.test.skip=true

适用于

  • 云效

如果您的问题仍未解决,您可以在阿里云社区免费咨询,或提交工单联系阿里云技术支持。