MySQL数据库变更为高版本后无法导入原低版本数据

MySQL数据库变更为高版本后无法导入原低版本数据

更新时间:2020-07-10 16:37:15

问题描述

在进行MySQL数据库变更后,例如从5.1版本升级至5.7版本,出现无法导入低版本数据的问题。

解决方案

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。

登录DMS控制台,单击SQL窗口,执行以下SQL语句,再正常执行数据导入操作即可。登录DMS控制台和导入MySQL数据的方法,请参见使用DMS控制面板导入MySQL数据

set session sql_mode = '';

适用于

  • 云虚拟主机

如果您的问题仍未解决,您可以在阿里云社区免费咨询,或提交工单联系阿里云技术支持。