问题描述
在客户端操作系统中,通过ping命令对公网的ECS实例进行可访问性测试时,存在网络不通的问题。
问题原因
该问题的可能原因如下:
ECS实例的配置问题。
资源资费问题。
安全访问控制问题。
资源使用率问题。
系统相关设置问题。
运营商问题。
解决方案
对ECS实例外网地址ping不通的配置相关问题进行排查之前,需要确认ECS已经存在公网IP地址或者已经绑定EIP。其他问题参考以下各步骤说明操作。
配置相关:检查ECS实例状态和外网相关配置。
登录云服务器管理控制台,单击左侧导航栏中的实例,查看目标实例的状态,确认目标实例为运行中状态。
使用NAT网关并存在SNAT条目,具体操作请参见使用SNAT访问公网。
资费相关:检查相关资源是否存在欠费情况。 确认ECS是否欠费、NAT网关是否欠费、EIP是否欠费。登录阿里云控制台,进入对应的产品控制台,单击费用>用户中心,查看资源费用情况。
安全相关:检查ECS安全组、云防火墙、安全管控状态。
安全组相关问题:具体操作请参见删除ECS实例的默认安全组规则导致无法ping通ECS实例。
云防火墙相关问题:请登录云防火墙控制台,在访问控制中,检查是否存在由外对内的拒绝规则,禁止了端口的访问和ICMP协议。
安全管控相关问题:具体操作请参见添加安全组规则,添加对安全组ICMP协议的入方向的安全策略。
使用率相关:检查外网相关资源使用率,如公网带宽使用率达到100%等。
突发性能实例性能约束模式,当CPU使用率达到100%时可能导致无法ping通或ping丢包,具体操作请参见突发性能实例概述。
EIP或固定公网IP资源被占满时,可能会导致ping操作被限速丢弃而无法ping通。
ECS内部配置相关:检查iptables、第三方VPN网关、云锁等。
Linux系统:具体操作请参见Linux系统的ECS中没有禁ping却ping不通的解决方法。
Windows系统:具体操作请参见Windows实例ping外网地址提示“一般故障”。
运营商问题:检查运营商是否存在网络问题,如公网运营商链路中断,路由震荡等。 具体操作请参见使用ping命令丢包或不通时的链路测试方法。
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