Windows Server出现termdd蓝屏问题如何处理?

更新时间:
复制 MD 格式

本文介绍Windows Server 2008 R2出现termdd蓝屏问题的原因及解决方案。

问题描述

Windows Server 2008 R2在运行过程中出现termdd(错误代码是0x000000D1或者其他)蓝屏问题,如下图所示。

A problem has been detected and windows has been shut down to prevent damage
to your computer.

DRIVER_IRQL_NOT_LESS_OR_EQUAL

If this is the first time you've seen this Stop error screen,
restart your computer. If this screen appears again, follow
these steps:

Check to make sure any new hardware or software is properly installed.
If this is a new installation, ask your hardware or software manufacturer
for any windows updates you might need.

If problems continue, disable or remove any newly installed hardware
or software. Disable BIOS memory options such as caching or shadowing.
If you need to use Safe Mode to remove or disable components, restart
your computer, press F8 to select Advanced Startup Options, and then
select Safe Mode.

Technical information:

*** STOP: 0x000000D1 (0x0000000000000000,0x0000000000000002,0x0000000000000000,0xFFFFF88002B43006)

***     termdd.sys - Address FFFFF88002B430^

Dump信息中显示termdd.sys(C:\Windows\System32\drivers\termdd.sys)文件的版本在6.1.7601.24441以下。

问题原因

是系统漏洞导致。微软于20190514日修复了该漏洞,CVE详细信息请参考CVE-2019-0708。 

解决方案

  1. 更新系统。

    Windows自动更新系统

    使用Windows更新,将系统更新至最新。

    1. 远程连接ECS实例。

      具体操作,请参见使用Workbench登录Windows实例

    2. 修改注册表中的WSUS地址。

      1. 依次选择开始 > 运行 > regedit

      2. 进入计算机\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate路径,将WUServerWUStatusServer的值修改为http://update.cloud.aliyuncs.com

    3. 依次选择开始 > 控制面板 > 系统和安全 > Windows Update

    4. 扫描更新后,单击安装更新

    5. 更新完成后,重启Windows系统。

    手动更新系统

    1. 远程连接ECS实例。

      具体操作,请参见使用Workbench登录Windows实例

    2. 下载累计安全补丁KB4499164或者仅安全更新补丁KB4499175

    3. 双击安装补丁。

    4. 重启Windows系统。

    公共命令更新系统

    1. 登录ECS管理控制台

    2. 在左侧导航栏,选择运维与监控 > 云助手

    3. 公共命令页签,找到公共命令ACS-ECS-ApplySecurityPatches-for-windows.ps1,单击执行

    4. 选择待更新的Windows实例并配置其他参数,更新系统。

      具体操作,请参见查看和执行公共命令

  2. 验证问题是否修复。

    • 查看已安装的补丁。

      自动更新系统或者手动更新系统后,打开CMD命令行,使用systeminfo命令查看已安装的补丁,确认系统安装了KB4499164或者KB4499175补丁。

      [55]:  KB3156019
      [56]:  KB3159398
      [57]:  KB3161949
      [58]:  KB3161958
      [59]:  KB3172605
      [60]:  KB3177467
      [61]:  KB3179573
      [62]:  KB3181988
      [63]:  KB3210131
      [64]:  KB4019990
      [65]:  KB4040980
      [66]:  KB4093108
      [67]:  KB4103712
      [68]:  KB4284867
      [69]:  KB4338823
      [70]:  KB4343205
      [71]:  KB4343899
      [72]:  KB4457145
      [73]:  KB4462915
      [74]:  KB4467106
      [75]:  KB4471328
      [76]:  KB4474419
      [77]:  KB4480960
      [78]:  KB4486654
      [79]:  KB4489885
      [80]:  KB4493448
      [81]:  KB4499175
      [82]:  KB4503269
      [83]:  KB4507456
    • 查看termdd.sys文件版本。

      确认termdd.sys(C:\Windows\System32\drivers\termdd.sys)文件版本是否在6.1.7601.24441及以上。

    如果确认系统安装了KB4499164或者KB4499175补丁以及termdd.sys文件版本在6.1.7601.24441及以上,蓝屏问题将得到解决。