全部产品

安装EDAS Agent后控制台状态为“未知”或“异常”

KB: 44536

 · 

更新时间:2021-03-18 09:50

问题描述

安装EDAS Agent后,控制台的状态为“未知”或“异常”。

问题原因

  • 原因一:admin用户没有/home/admin目录的权限。
  • 原因二:ECS实例名和/etc/hosts文件中解析信息不一致。

解决方案

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。
  1. 登录安装Agent的ECS实例,查看/home/admin/edas-agent/logs目录下的std.log和agent.log日志文件。
    • std.log是Agent安装过程中的日志。
    • agent.log是Agent的运行日志。
  2. 如果日志中存在“Permission denied”或“Not such file”信息,说明可能是原因一导致的问题。
    1. 执行以下命令,确认admin用户没有/home/admin目录的权限。
      ll /home/admin -d
    2. 参考以下命令,给admin用户添加/home/admin目录的权限。
      说明:执行以下命令前,需要确认改动不会影响您的业务。
      chown admin:admin /home/admin
      chmod u+rwx /home/admin
    3. 然后重新安装Agent。
  3. 如果问题未解决,可能是原因二导致,编辑/etc/hosts文件,确认ECS实例名和实例IP解析信息不一致。将ECS实例名修改为正确的实例名,保存并退出,然后重新安装Agent即可。

适用于

  • 企业级分布式应用服务EDAS