EDAS应用无法访问页面

问题描述

通过HTTP方式访问EDAS应用,无法访问EDAS应用,且远程过程调用RPC服务无法调用。

问题原因

EDAS应用通过HTTP方式无法访问的可能原因如下:

  • 应用配置路径错误。
  • 应用端口为对外开放。
  • 网络问题。
  • 应用本身错误。
  • 服务器到服务注册中心网络不可达、服务权限限制、服务调用超时等。
  • RPC服务无法调用。

解决方案

  1. 登录EDAS控制台,单击左侧导航栏的应用列表
  2. 单击应用名称,在应用基本信息页面,检查应用的访问路径。如下图所示,Tomcat Context设置为根目录,检查应用的访问连接中是否添加了项目名,正确应该是/_ehc.html,没有项目名。
  3. 使用Telnet工具检查对应的应用端口是否对外开放,如果未开放,则开放对应的端口,详情请参见无法访问ECS集群的应用端口
  4. 端口已经开放但仍然无法访问时,可登录应用所在服务器,通过curlping命令,检查访问地址是否有信息返回。
    • 如果正常,请检查访问机器到应用所在服务器的网络,将网络问题解决后进行重试。
    • 如果异常,请执行以下操作,检查程序运行情况:
      1. 登录ECS实例,执行以下命令,查看Java程序进程ID。
        ps -ef |grep java
      2. 依次执行如下命令,通过JVM工具排查程序运行是否正常。
        sudo jstack -F [$ID]
        sudo jstat -class [$VMID] [$Interval] [$Count]
        说明
        • [$ID]为Java程序的进程ID。
        • [$VMID]:VM的进程号,即当前运行的Java进程号。

        • [$Interval]:间隔时间,单位为秒或毫秒。

        • [$Count]:打印次数,如果默认为空,则打印无数次。

      3. 执行以下命令,查看堆内存情况。
        jmap -heap [$Port]
        说明:[$Port]为端口号。
  5. 请检查Tomcat日志错误,直到解决所有日志错误为止,详情请参见EDAS如何使用日志文件排查问题
  6. 如RPC服务无法调用,请参见RPC服务无法调用进行处理

适用于

  • 企业级分布式应用服务EDAS