PostgreSQL兼容函数