阿里云首页> 其他> 【其他】OSS开放支持HTTP/2通知

【其他】OSS开放支持HTTP/2通知

【阿里云】【OSS】【功能变更】

 变更时间:2018年11月12日

 变更内容:陆续开放支持HTTP/2,而由于低版本Go语言存在缺陷,可能导致HTTP/2请求处理异常,可参考缺陷详情

 届时使用低版本Go 语言,通过HTTPS访问OSS并且客户端开启支持HTTP/2时,则可能会出现访问异常。

 建议:

 1. 您将Go语言升级至Go1.8 及以上版本。

 2. 如果您是在Docker Registry 中使用低版本Go 语言访问OSS, 建议您将Docker Registry 升级至2.6.0 及以上版本。详情请参考HTTP/2更新说明

 如果您是使用OSS官方SDK访问OSS,则不受影响。