阿里云首页> 安全公告> 【漏洞预警】Gitlab Wiki API 远程代码执行漏洞CVE-2018-18649

【漏洞预警】Gitlab Wiki API 远程代码执行漏洞CVE-2018-18649

2018年10月30日,阿里云云盾应急响应中心监测到Gitlab 官方发布安全更新通告,披露了一个远程代码执行漏洞,攻击者利用漏洞可直接获取服务器权限。


漏洞描述

Gitlab Wiki API 是一组用于对Gitlab项目Wiki页面进行创建、编辑、列表、删除等功能的接口。该API在处理外部输入时未做有效过滤,导致攻击者构造特定的恶意请求,可以在目标服务器上执行任意代码命令。


影响范围

Gitlab CE/EE 11.3 及之后的版本


风险评级

CVE-2018-18649:严重


安全建议

升级Gitlab CE/EE至最新版本,官方升级引导链接:https://about.gitlab.com/update/

1、进入Gitlab实例的/admin/application_settings页面

2、在"Import sources"选项下取消"GitLab export"的选中复选框

3、点击Save changes保存


官方公告

https://about.gitlab.com/2018/10/29/security-release-gitlab-11-dot-4-dot-3-released/



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云云盾应急响应中心

2018.10.30