阿里云首页> 安全公告> 【漏洞预警】ThinkPHP5远程代码执行高危漏洞

【漏洞预警】ThinkPHP5远程代码执行高危漏洞

2018年12月10日,阿里云云盾应急响应中心监测到ThinkPHP官方发布安全更新,披露了一个高危安全漏洞,攻击者构造特定的恶意请求,可以直接获取服务器权限,受影响的版本包括5.0和5.1版本。


漏洞描述

由于ThinkPHP5框架对控制器名没有进行足够的安全检测,导致在没有开启强制路由的情况下,黑客构造特定的请求,可直接GetWebShell。


漏洞评级

严重


影响版本

ThinkPHP 5.0系列 < 5.0.23

ThinkPHP 5.1系列 < 5.1.31


安全版本

ThinkPHP 5.0系列 5.0.23

ThinkPHP 5.1系列 5.1.31


安全建议

升级ThinkPHP至安全版本

云盾WAF已可防御此漏洞攻击

云盾网站威胁扫描系统已支持对该漏洞检测

云盾态势感知应急漏洞模块已支持对该漏洞一键检测,详情登陆云盾控制台


相关链接

https://blog.thinkphp.cn/869075



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云云盾应急响应中心

2018.12.10