阿里云首页> 安全公告> 【漏洞预警】ThinkPHP5 核心类Request远程代码执行高危漏洞

【漏洞预警】ThinkPHP5 核心类Request远程代码执行高危漏洞

2019年1月11日,阿里云云盾应急响应中心监测到ThinkPHP官方发布安全更新,披露了一个高危安全漏洞,攻击者构造特定的恶意请求,可以直接获取服务器权限,受影响的版本包括5.0.0~5.0.23版本及5.1多个版本。


漏洞描述

由于ThinkPHP5框架对Request类的method处理存在缺陷,导致黑客构造特定的请求,可直接GetWebShell。


漏洞评级

严重


影响版本

ThinkPHP 5.0系列 < 5.0.24

ThinkPHP 5.1多个版本


安全版本

ThinkPHP 5.0系列 5.0.24


安全建议

升级ThinkPHP至安全版本


云盾WAF已可防御此漏洞攻击

云盾网站威胁扫描系统已支持对该漏洞检测

云盾云安全中心应急漏洞模块已支持对该漏洞一键检测


相关链接

https://blog.thinkphp.cn/910675



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云云盾应急响应中心

2019.1.11