阿里云首页> 安全公告> 【漏洞预警】Confluence 远程命令执行高危漏洞(CVE-2019-3396)

【漏洞预警】Confluence 远程命令执行高危漏洞(CVE-2019-3396)

2019年4月04日,阿里云云盾应急响应中心监测到Confluence 官方发布安全更新,指出 Confluence Server 与 Confluence Data Center 中的 Widget Connector 存在服务端模板注入漏洞,攻击者能利用此漏洞能够实现目录穿越遍历甚至远程命令执行。


漏洞描述

Confluence Server 与 Confluence Data Center 中的 Widget Connector 存在服务端模板注入漏洞,攻击者构造特定请求可远程遍历服务器任意文件,甚至实现远程命令执行攻击。近期有安全研究人员披露漏洞利用PoC,阿里云云盾应急响应中心提醒用户尽快升级相关软件。


漏洞评级

CVE-2019-3395 严重

CVE-2019-3396 严重


影响软件

Confluence Server

Confluence Data Center


安全版本

6.6.x 系列:6.6.12 及以上

6.12.x系列:6.12.3 及以上

6.13.x系列:6.13.3 及以上

6.14.x系列:6.14.2 及以上


安全建议

以下任选一种皆可修复漏洞


1、升级至安全版本。下载链接:


https://www.atlassian.com/software/confluence/download/

https://atlassian.com/software/confluence/download/data-center


2、升级Widget Connector 组件。


Linux系统运行如下命令查找widgetconnector-*.jar文件所在位置:

find / -name "widgetconnector-*"




下载最新版本的widgetconnector-3.1.4.jar替换,并重启Confluence应用




云盾WAF已可防御此漏洞攻击

云盾网站威胁扫描系统已支持对该漏洞检测

云盾云安全中心应急漏洞模块已支持对该漏洞一键检测

云盾云防火墙已可防御此漏洞攻击


相关链接

https://confluence.atlassian.com/doc/confluence-security-advisory-2019-03-20-966660264.html



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云云盾应急响应中心

2019.4.04