阿里云首页> 安全公告> 【漏洞预警】Redis 4.x/5.x 远程命令执行高危漏洞

【漏洞预警】Redis 4.x/5.x 远程命令执行高危漏洞

2019年7月09日,阿里云应急响应中心监测到有安全研究人员披露Redis 4.x/5.x 远程命令执行高危漏洞利用代码工具。针对未授权或弱口令的Redis服务,攻击者通过构造特定请求,成功利用漏洞可在目标服务器上执行任意命令,风险极大。


漏洞描述

在Reids 4.x之后,Redis新增了模块功能特性,通过外部拓展,可以实现新的Redis命令,通过写c语言并编译出.so文件,可实现代码执行漏洞。阿里云应急响应中心提醒Redis用户尽快采取安全措施阻止漏洞攻击。


影响版本

Redis 4.x

Redis 5.x


安全建议

一,通过阿里云安全组禁止Redis端口对外或只允许特定安全ip地址访问,如下:



二、加固Redis,增加权限控制和密码策略等:https://help.aliyun.com/knowledge_detail/37447.html



云盾网站威胁扫描系统已支持对该漏洞检测

云盾云安全中心应急漏洞模块已支持对该漏洞一键检测

云盾云防火墙已发布针对此漏洞的虚拟补丁





我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云应急响应中心

2019.7.09