阿里云首页> 安全公告> 【漏洞预警】fastjson < 1.2.51 远程代码执行漏洞

【漏洞预警】fastjson < 1.2.51 远程代码执行漏洞

近日,阿里云应急响应中心监测到fastjson爆出远程代码执行漏洞,可导致直接获取服务器权限,官方已发布公告说明,影响版本 < 1.2.51,请使用到的用户尽快升级至安全版本。


漏洞描述

fastjson < 1.2.51版本存在代码执行漏洞,当用户提交一个精心构造的恶意的序列化数据到服务器端时,fastjson在反序列化时存在漏洞,可导致远程任意代码执行。阿里云应急响应中心提醒fastjson用户尽快采取安全措施阻止漏洞攻击。


影响版本

fastjson < 1.2.51


安全版本

fastjson >= 1.2.51


安全建议

根据官方漏洞公告提示升级fastjson组件:https://github.com/alibaba/fastjson/wiki/update_faq_20190722


相关链接

https://github.com/alibaba/fastjson/wiki/update_faq_20190722


云盾网站威胁扫描系统已支持对该漏洞检测

云盾云安全中心应急漏洞模块已支持对该漏洞一键检测




我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云应急响应中心

2019.7.10