阿里云首页> 安全公告> 【漏洞预警】fastjson < 1.2.60 远程拒绝服务漏洞

【漏洞预警】fastjson < 1.2.60 远程拒绝服务漏洞

近日,阿里云应急响应中心监测到fastjson爆出远程拒绝服务漏洞,攻击者在请求中构造特定json字符串,可远程造成服务器内存和CPU等资源耗尽,最终拒绝服务。官方已发布公告说明,最新的1.2.60和带有sec06字符的版本不受影响,请使用到的用户尽快升级至安全版本。


漏洞描述

fastjson处理\x转义字符不当,攻击者在请求中构造特定json字符串可导致服务器内存和CPU等资源耗尽,最终拒绝服务。阿里云应急响应中心提醒fastjson用户尽快采取安全措施阻止漏洞攻击。


影响版本

fastjson < 1.2.60

fastjson sec版本 < sec06


安全版本

fastjson >= 1.2.60

fastjson sec版本 >= sec06


安全建议


注意:较低版本升级至最新版本1.2.60可能会出现兼容性问题,建议升级至特定版本的sec06 bugfix版本


升级至安全版本,参考下载链接:http://repo1.maven.org/maven2/com/alibaba/fastjson/


相关链接

https://github.com/alibaba/fastjson/pull/2692


云盾云安全中心应急漏洞模块已支持对该漏洞一键检测




我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云应急响应中心

2019.9.5