阿里云首页> 安全公告> 【漏洞预警】WebLogic高危漏洞预警(CVE-2019-2891、CVE-2019-2890)

【漏洞预警】WebLogic高危漏洞预警(CVE-2019-2891、CVE-2019-2890)

2019年10月16日,阿里云应急响应中心监测到Oracle官方发布安全公告,披露WebLogic服务器存在多个高危漏洞,包括反序列化等。黑客利用漏洞可能可以远程获取WebLogic服务器权限,风险较大。


漏洞描述

CVE-2019-2891中,未经授权的攻击者可以通过精心构造的HTTP请求向Console组件发起请求,从而接管WebLogic服务器。CVE-2019-2890中,未经授权的攻击者则通过构造T3协议请求,绕过WebLoig的反序列化黑名单,从而接管WebLogic服务器。


漏洞评级

CVE-2019-2891:高危

CVE-2019-2890:高危


影响版本

WebLogic 10.3.6.0.0

WebLogic 12.1.3.0.0

WebLogic 12.2.1.3.0


安全建议


一、禁用T3协议

如果您不依赖T3协议进行JVM通信,可通过暂时阻断T3协议缓解此漏洞带来的影响。

1. 进入Weblogic控制台,在base_domain配置页面中,进入“安全”选项卡页面,点击“筛选器”,配置筛选器。

2. 在连接筛选器中输入:weblogic.security.net.ConnectionFilterImpl,在连接筛选器规则框中输入:* * 7001 deny t3 t3s。

3. 保存生效(无需重启)。


二、排查弱口令

排查Weblogic管理后台是否存在弱口令,增强密码强度。


三、升级补丁


相关链接

https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云应急响应中心

2019.10.16