阿里云首页> 安全公告> 【漏洞预警】Docker 容器逃逸漏洞(CVE-2020-15257)

【漏洞预警】Docker 容器逃逸漏洞(CVE-2020-15257)

2020年12月01日,阿里云应急响应中心监测到 containerd 官方发布安全更新,修复了 Docker 容器逃逸漏洞(CVE-2020-15257)。


漏洞描述

Containerd 是一个控制 runC 的守护进程,提供命令行客户端和 API,用于在一个机器上管理容器。在特定网络条件下,攻击者可通过访问containerd-shim API,从而实现Docker容器逃逸。阿里云应急响应中心提醒 containerd 用户尽快采取安全措施阻止漏洞攻击。


影响版本

containerd < 1.4.3

containerd < 1.3.9


安全版本

containerd >= 1.4.3

containerd >= 1.3.9


安全建议

1. 升级 containerd 至最新版本。

2. 通过添加如 deny unix addr=@**的AppArmor策略禁止访问抽象套接字。


相关链接

https://github.com/containerd/containerd/security/advisories/GHSA-36xw-fx78-c5r4



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云应急响应中心

2020.12.01