阿里云首页> 安全公告> 【漏洞预警】Apache Skywalking GraphQL 注入与远程代码执行漏洞

【漏洞预警】Apache Skywalking GraphQL 注入与远程代码执行漏洞

2021年1月23日,蚂蚁安全非攻实验室 @fatansyC4t 向Apache官方报告了Apache Skywalking SQL注入与远程代码执行漏洞。2021年2月7日,阿里云应急响应中心监测到 Apache Skywalking 官方发布安全更新修复该漏洞。


漏洞描述

Apache SkyWalking是一款开源的应用性能监控系统,包括指标监控,分布式追踪,分布式系统性能诊断。Apache SkyWalking的某GraphQL功能存在SQL注入漏洞,攻击者可以构造恶意请求查询数据库敏感信息,或利用H2数据库特性进一步造成远程代码执行漏洞。阿里云应急响应中心提醒 Apache Skywalking 用户尽快采取安全措施阻止漏洞攻击。


漏洞评级

Apache Skywalking GraphQL 注入漏洞 高危


漏洞证明


影响版本

Apache Skywalking < v8.4.0


安全版本

Apache Skywalking < v8.4.0


安全建议

1、升级Apache Skywalking 到最新的 v8.4.0 版本。

2、将默认h2数据库替换为其它支持的数据库。


相关链接

https://github.com/apache/skywalking/releases/tag/v8.4.0


云盾WAF已可防护该类漏洞,并提供7天免费漏洞应急服务,为您争取漏洞修复时间,应急开通地址:https://c.tb.cn/I3.XzCtR

阿里云云安全中心应急漏洞模块已支持对该漏洞一键检测
阿里云云防火墙已可防御此漏洞攻击


我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单联系反馈。


阿里云应急响应中心

2021.2.7