阿里云首页> 安全公告> 【漏洞预警】Apache Solr 多个中高危漏洞(CVE-2021-27905等)

【漏洞预警】Apache Solr 多个中高危漏洞(CVE-2021-27905等)

2021年4月13日,阿里云应急响应中心监测到Apache Solr存在SSRF漏洞等多个中高危漏洞。


漏洞描述

Apache Solr是一个开源的搜索服务,使用Java语言开发。Apache Solr的某些功能存在过滤不严格,在Apache Solr未开启认证的情况下,攻击者可直接构造特定请求开启特定配置,并造成SSRF漏洞等。阿里云应急响应中心提醒Solr用户尽快采取安全措施阻止漏洞攻击。


漏洞评级

CVE-2021-27905 Apache Solr SSRF漏洞 中危

CVE-2021-29262 Apache Solr 敏感信息泄漏漏洞 中危

CVE-2021-29943 Apache Solr 越权读取数据漏洞 中危


漏洞细节:未公开

漏洞POC:未公开

漏洞EXP:未公开

在野利用:未知


漏洞复现


影响版本

Apache Solr < 8.8.2


安全版本

Apache Solr 8.8.2


安全建议

1、增加身份验证/授权,可参考官方文档:https://lucene.apache.org/solr/guide/8_6/authentication-and-authorization-plugins.html

2、禁止Solr API 以及管理 UI 直接对公网开放。设置防火墙,以便只允许受信任的计算机和人员访问。

3、升级Apache Solr至最新版本。


相关链接

https://www.mail-archive.com/announce@apache.org/msg06482.html

https://www.mail-archive.com/announce@apache.org/msg06481.html

https://www.mail-archive.com/announce@apache.org/msg06480.html


云盾WAF已可防御此漏洞攻击

云盾漏洞扫描已支持对该漏洞检测

云盾云安全中心应用漏洞模块已支持对该漏洞一键检测


我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云应急响应中心

2021.4.13