阿里云首页> 安全公告> 【漏洞预警】runc 符号链接挂载与容器逃逸漏洞(CVE-2021-30465)

【漏洞预警】runc 符号链接挂载与容器逃逸漏洞(CVE-2021-30465)

2021年5月31日,阿里云应急响应中心监测到 国外安全研究人员披露 CVE-2021-30465 runc 符号链接挂载与容器逃逸漏洞。


漏洞描述

runc是容器Runtime的一个实现,主要作用是使用Linux Kernel提供的如namespaces等进程隔离机制,构建供容器运行的隔离环境。CVE-2021-30465 中,攻击者可通过创建恶意POD及container,利用符号链接以及条件竞争漏洞,可挂载宿主机目录至 container 中,并最终可能导致容器逃逸。阿里云应急响应中心提醒 runc 用户尽快采取安全措施阻止漏洞攻击。


漏洞细节:公开

漏洞POC:公开

漏洞EXP:公开

在野利用:未知


漏洞评级

CVE-2021-30465 runc 符号链接挂载与容器逃逸漏洞 高危


影响版本

runc <= 1.0.0-rc94


安全版本

runc 1.0.0-rc95


安全建议

1、升级 runc 至最新版本。


相关链接

https://github.com/opencontainers/runc/security/advisories/GHSA-c3xm-pvg7-gh7r



我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单联系反馈。

阿里云应急响应中心

2021.5.31