阿里云首页> 安全公告> 【漏洞通告】YApi管理平台任意代码执行漏洞

【漏洞通告】YApi管理平台任意代码执行漏洞

2021年7月7日,阿里云应急响应中心监测到互联网上披露YApi管理平台任意命令执行漏洞。


漏洞描述

YApi 是一个可本地部署的、打通前后端及QA的、可视化的接口管理平台。2021年7月7日,阿里云应急响应中心监测到互联网上披露YApi管理平台任意命令执行漏洞。若Yapi对外开放注册功能,攻击者可在注册并登录后,通过构造特殊的请求执行任意代码,接管服务器。阿里云应急响应中心提醒 YApi 用户尽快采取安全措施阻止漏洞攻击。


漏洞细节:公开

漏洞POC:公开

漏洞EXP:公开

在野利用:存在


漏洞评级

YApi管理平台任意命令执行漏洞 高危


影响版本

YApi <= 1.9.2


安全建议

官方尚未发布修复Release版本,可按照以下方式进行缓解

1、利用阿里云安全组设置Yapi仅对可信地址开放。

2、编辑Yapi目录下的 config.json 文件,设置 closeRegister 为 true,关闭Yapi的前台注册功能。

{
  "closeRegister":true
}



相关链接

https://github.com/YMFE/yapi


云盾WAF已可防护该类漏洞,并提供7天免费漏洞应急服务,为您争取漏洞修复时间,应急开通地址:https://c.tb.cn/I3.XzCtR

阿里云云安全中心应急漏洞模块已支持对该漏洞一键检测

阿里云云防火墙已可防御此漏洞攻击


我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时发送邮件至alicloud-vul@alibabacloud.com

阿里云应急响应中心

2021.7.7