本文介绍接入Agent后找不到应用的解决办法以及接入应用后无法看到接口数据的原因。
接入Agent之后,AHAS控制台看不到应用?
请参考以下步骤检查。
- 确保选择了正确的地域(Region)。切换地域(Region)步骤请参见如何切换地域(Region)。
- 确保引入了相应的依赖,并进行了正确的配置。请参见应用防护接入。
- 确保本机时间正确,程序所在的机器时间要跟当地标准时间一致。
- 检查应用是否是EDAS应用,如果是EDAS应用必须用Admin账号接入Agent,否则将无法接入成功。
- 查看日志/home/admin/logs/csp/sentinel-record.log是否有报错,根据报错内容进行修改。
- 如果日志或者目录不存在,则执行
java -version
查看内容。如下图所示,如果没有输出Agent相关信息,即Agent没有接入成功,文件没有挂载上。
解决方案如下:
AHAS控制台可以看到应用,但是没有数据显示?
请确保对应资源有访问量。资源要有访问量才会在请求链路页面显示。
- AHAS刚接入应用之后,应用防护页面各个应用数据显示为空,这是因为应用没有实时流量就不会有数据。此时您可以通过PTS发起少量压测流量或手动访问,例如通过浏览器访问应用即可看到请求,控制台中将显示对应的流量数据。
- 在应用防护页面中,展示的是最近5分钟的数据统计,所以可以看到近5分钟的趋势图。但接口数据展示的是实时数据,当实时数据为0时,接口详情将无数据显示。
- 请求链路页面显示的是单台机器上的所有调用链路数据,您可以通过下拉框切换机器查看不同机器的请求链路数据。
为什么AHAS概览页面应用数不为0,但应用防护页面却看不到应用?
问题现象
举例说明:如下图所示,AHAS概览页面的应用数显示为5。
![dt](https://help-static-aliyun-doc.aliyuncs.com/assets/img/zh-CN/6605005861/p674817.png)
同时,如下图所示,在应用防护页面却无法查看到任何应用。
![ry](https://help-static-aliyun-doc.aliyuncs.com/assets/img/zh-CN/7605005861/p674821.png)
可能原因
这是因为AHAS概览页统计的应用数为当天在线的应用,而在应用防护页面只展示当前在线应用以及收藏的应用。
解决方案
建议您接入应用后再次查看应用防护页面,接入应用的具体操作,请参见接入应用方式。