Q:源端数据库连接失败,如何处理?
A:检查源库信息和设置是否正常,详情请参见源库连接性检查。
Q:目标端数据库连接失败,如何处理?
A:检查目标库信息和设置是否正常,详情请参见目标数据库连接性检查。
Q:源或目标实例位于DTS暂不支持的地区,如何进行数据迁移和同步?
如果是数据迁移任务,您可以为数据库实例(如RDS MySQL)申请公网地址,以公网IP接入,实例地区可以选择DTS支持的地区,并将对应地区的DTS服务器IP地址段添加到实例的白名单中。需要添加的IP白名单,请参见添加DTS服务器IP地址白名单。
如果是数据同步任务,由于数据同步暂不支持将数据库实例作为公网IP接入,因此DTS暂不支持这些地区的数据同步。
Q:实例源或目标为域名接入形式,DTS的感知时间是多久?
A:DTS 将在10分钟内感知到域名绑定切换,并自动将DTS任务切换到域名绑定的新IP上。请确保在域名切换过程中,新老实例之间的Binlog复制关系持续保持10钟分以上。
Q:测试连接出现“不允许使用内网IP实例”怎么办?
问题描述:当目标库为AnalyticDB数据库时,配置迁移或同步任务的过程中,出现连接测试失败,提示“不允许使用内网IP实例“。
可能原因:目标库AnalyticDB数据库暂不支持连接测试。
解决方案:当目标库为AnalyticDB数据库时,在确保用户名和密码正确的情况下,可不进行测试连接,直接进行后续的配置操作。
该文章对您有帮助吗?