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通过远程桌面连接Windows系统的ECS实例时,提示“远程桌面连接已断开”错误怎么办?

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本文介绍通过远程桌面连接Windows系统的ECS实例时,提示“远程桌面连接已断开”错误的解决方案。

问题描述

通过远程桌面连接Windows系统的ECS实例时失败,并提示“远程桌面连接已断开”错误,具体显示如下图。

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问题原因

通过VNC登录Windows实例,进入事件查看器查看系统日志,提示“终端服务器安全层在协议流中检测到错误,并已取消客户端连接”的错误,该问题可能是由于ECS实例的注册表中Certificate子键损坏导致的。

说明

注册表中Certificate子键负责终端服务通信中数据信息的认证和加密,它一旦被损坏,终端服务的协议组件就会检测到错误,中断客户端与ECS实例之间的通信。导致Certificate子键损坏的原因很多,如管理员安装和卸载某些系统软件、对终端服务参数的不合理配置等。

解决方案

本文操作以Windows Server 2008 R2系统版本为例,其他Windows系统版本操作类似。

  1. 通过VNC连接Windows实例。

    具体操作,请参见通过密码认证登录Windows实例

  2. 单击开始 > 运行,在运行对话框中输入regedit,单击确定

  3. 注册表编辑器窗口,依次选择HKEY_LOCAL_MACHINE>SYSTEM>ControlSet001>Control>Terminal Server>RCM,右键单击Certificate,选择删除,然后单击

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  4. 单击开始 > 管理工具 > 远程桌面服务,然后单击远程桌面会话主机配置

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  5. 进入RD 会话主机配置区域,双击RDP-Tcp,进入RDP-Tcp 属性页面,单击常规,将安全层选项修改为RDP 安全层,然后单击确定保存配置。

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  6. 重启Windows实例或重启服务器以更新配置。

  7. 使用远程桌面连接Windows实例,确认可以正常登录。