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Windows系统的ECS实例更新系统时,一直卡在0%该如何处理?

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本文中含有需要您注意的重要提示信息,忽略该信息可能对您的业务造成影响,请务必仔细阅读。

本文介绍Windows系统的ECS实例更新系统时,一直卡在0%的问题原因和解决方案。

问题现象

Windows系统的ECS实例更新系统时,一直卡在0%。通过实例健康诊断时提示“该实例的防火墙服务(对应的进程名称为mpssvc)目前不处于运行中,会导致Windows系统更新失败”。

问题原因

该问题可能是由于Windows防火墙服务(mpssvc)未运行,导致Windows更新失败。

解决方案

您可以通过修改注册表并启动防火墙服务,来解决上述问题。

  1. 远程连接Windows实例。

    具体操作,请参见通过密码或密钥认证登录Windows实例

  2. 查看Windows防火墙状态。

    1. 单击右下角的image.png图标,然后选择Windows 系统 > 控制面板

    2. 在控制面板页面,选择系统和安全 > 允许应用通过 Windows 防火墙

      如果弹出提示Windows 防火墙无法更改某些设置。错误代码 0x80070422,说明该问题是由于防火墙服务未运行导致。

      image.png
  3. 修改防火墙服务注册表。

    1. 选择开始 > 运行,输入regedit,打开注册表编辑器。

    2. 在注册表路径中输入HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mpssvc,按Enter键,然后查找Start

    3. 右键单击Start,然后单击修改(M)...

      image.png
    4. 在弹出的对话框中,基数选择十进制(D)数值数据(V)设置2,单击确定

      image.png
  4. 启动防火墙服务。

    1. 选择开始 > 运行,输入services.msc,单击确定

    2. 服务页面,找到Windows Defender Firewall服务,启动该服务。

  5. 重启实例,使以上修改生效。

    具体操作,请参见重启实例

    警告 重启实例会造成您的实例停止工作,可能导致业务中断,建议您在非业务高峰期时执行该操作。
  6. 重新更新Windows系统,如果可以正常更新,说明该问题已解决。

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