安装Windows更新或添加功能与角色并重启实例后, 操作系统长时间处于“Getting ready”状态怎么办?

本文介绍安装Windows更新或添加功能与角色并重启实例后,操作系统长时间处于“Getting ready”状态的问题原因和解决方案。

问题现象

Windows实例更新补丁或添加功能与角色并重启实例后,操作系统长时间处于“Getting ready”或“Getting Windows ready”状态。

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问题原因

可能是该实例存在异常状态(InstallPending)的更新包(包括系统补丁、新功能等),导致操作系统无法正常启动。

解决方案

您可以对有问题实例挂载修复盘,然后在实例中卸载该异常软件包以解决该问题。假设挂载盘符为D,具体步骤如下:

  1. 发起实例操作系统无法启动诊断。

    1. 登录ECS管理控制台

    2. 在左侧导航栏,单击自助问题排查

    3. 在顶部菜单栏左上角处,选择地域。

    4. 实例问题排查页签,单击实例无法连接或启动异常问题类型。

    5. 选择实例状态为已停止,无法正常启动问题、需要诊断的实例ID及时间范围,然后单击开始排查

      说明

      需要诊断的ECS实例必须处于已停止状态,具体操作,请参见停止实例

      实例健康诊断

      诊断完成后,实例处于运行中修复中状态。

      运行中、修复中

  2. 远程连接有问题的实例。

    您可以在诊断结果界面单击VNC远程连接,使用诊断报告中提供的临时登录实例的Administrator用户及密码信息登录挂载了修复盘的ECS实例。具体操作,请参见使用VNC登录实例

  3. 以管理员身份运行Windows PowerShell

    image.png

  4. 查找处于Pending状态的软件包。

    $pendingPackages = Get-WindowsPackage -Path D:\ | Where-Object {$_.PackageState -match 'InstallPending'}
  5. 卸载软件包。

    $pendingPackages | Remove-WindowsPackage
  6. 在实例列表页,将鼠标悬浮至修复中的状态上,然后单击卸载修复盘

    卸载修复盘

  7. 重启实例,使以上配置生效。

    具体操作,请参见重启实例

  8. 远程连接ECS实例,如果该实例可以正常连接,说明问题已修复。

    具体操作,请参见通过密码或密钥认证登录Windows实例