Windows Server 2008 R2因驱动签名无法验证导致启动失败

更新时间:
复制 MD 格式

本文介绍Windows Server 2008 R2系统因无法验证驱动的数字签名导致系统启动失败问题的原因和解决方案。

问题现象

Windows Server 2008 R2系统无法启动,如下所示,提示无法验证此文件的数字签名。

Windows 启动管理器
windows 未能启动。原因可能是最近更改了硬件或软件。解决此问题的步骤:
1. 插入 Windows 安装光盘并重新启动计算机。
2. 选择语言设置,然后单击"下一步"。
3. 单击"修复计算机"。
如果没有此光盘,请与您的系统管理员或计算机制造商联系,以获得帮助。
    文件:\Windows\system32\drivers\viostor.sys
    状态:0xc0000428
    信息:Windows 无法验证此文件的数字签名。
Enter=继续                                        Esc=退出

问题原因

该问题是由于系统不支持SHA256算法,导致无法验证驱动的数字签名。更多信息,请参见Windows 7 和 Windows Server 2008 R2 SHA-2 代码签名支持的可用性

解决方案

需要使用强制禁用签名模式进入系统,安装KB3033929补丁以支持SHA256算法,让驱动的SHA256签名可以被正确识别。具体操作步骤如下:

  1. 使用VNC方式远程连接Windows实例。

    具体操作,请参见通过VNC连接实例

  2. 在报错界面中直接按Enter键。

  3. 在如下启动界面中按F8键。

    Windows 启动管理器
    选择要启动的操作系统,或按 Tab 选择工具:
    (使用箭头键突出显示您的选择,然后按 Enter。)
    Windows Server 2008 R2
    若要为此选择指定高级选项,请按 F8。
    工具:
        Windows Memory Diagnostic
    Enter=选择            Tab=菜单                    Esc=取消
  4. 在高级启动选项界面选择禁用驱动程序签名强制,表示强制禁用签名模式,然后按Enter键。

    此时可以正常进入系统。

  5. 下载 KB3033929 补丁,并按照提示完成安装。

    说明

    安装补丁过程中,可能会出现补丁安装失败的情况,请您参考Windows Update补丁更新失败如何处理?进行排查。

  6. 安装完成后,重启实例。